Reply to topic

libblkid1 error in pkcon update

stephenhenderson
Registered Member
Posts
9
Karma
0

libblkid1 error in pkcon update

Sun May 12, 2019 12:13 pm
Ubuntu people says this a problem with Neo Repositories
How the heck do you do a bug report to Neon
pkcon refresh works fine

Code: Select all
pkcon update

Code: Select all
Fatal error: The following packages have unmet dependencies:
  libblkid1: Breaks: libblkid1 (!= 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5) but 2.33.2-0+18.04+bionic+build6 is to be installed
  libblkid1: Breaks: libblkid1 (!= 2.33.2-0+18.04+bionic+build6) but 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5 is to be installed


Code: Select all
sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) libblkid1:amd64 < 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5 | 2.33.2-0+18.04+bionic+build6 @hi pumH Ib >
Broken libblkid1:amd64 Breaks on libblkid1:i386 < 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5 -> 2.33.2-0+18.04+bionic+build6 @ii umU Ib > (!= 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5)
  Considering libblkid1:i386 5 as a solution to libblkid1:amd64 10408
  Added libblkid1:i386 to the remove list
  Conflicts//Breaks against version 2.31.1-0.4ubuntu3.3 for libblkid1 but that is not InstVer, ignoring
  Conflicts//Breaks against version 2.31.1-0.4ubuntu3 for libblkid1 but that is not InstVer, ignoring
  Fixing libblkid1:amd64 via keep of libblkid1:i386
 Try to Re-Instate (0) libblkid1:i386
Done
Calculating upgrade... Done
The following packages have been kept back:
  libblkid1 libblkid1:i386
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.


Code: Select all
sudo apt-cache policy libblkid1
[sudo] password for xxxxxxxxxxx:

Code: Select all
libblkid1:
  Installed: 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5
  Candidate: 2.33.2-0+18.04+bionic+build6
  Version table:
     2.33.2-0+18.04+bionic+build6 500
        500 http://archive.neon.kde.org/user bionic/main amd64 Packages
 *** 2.32-0.1+18.04+bionic+build4+18.04+bionic+build5 500
        500 http://archive.neon.kde.org/user bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     2.32-0.1+18.04+bionic+build4+18.04+bionic+build3 500
        500 http://archive.neon.kde.org/user bionic/main amd64 Packages
     2.32-0.1+18.04+bionic+build2 500
        500 http://archive.neon.kde.org/user bionic/main amd64 Packages
     2.31.1-0.4ubuntu3.3 500
        500 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64
Packages
     2.31.1-0.4ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
User avatar claydoh
Registered Member
Posts
403
Karma
5
OS

Re: libblkid1 error in pkcon update

Sun May 12, 2019 4:27 pm
Did you refresh first?


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
NoNameNoBlame
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 5:18 pm
Could be helpful to know,
where Your 32-Bits version comes from.

1/2)

Do:

$ aptitude why libblkid1:i386

Post the result here.

2/2)

To find all Your installed 32-Bit stuff, You can do:

$ apt list |& grep ' i386.*installed'

Don't post the result of this if it's more than 10 lines.
stephenhenderson
Registered Member
Posts
9
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 5:39 pm
I did a refresh, saids in original question.

Karma

Code: Select all
aptitude why libblkid1:i386
i   wine32:i386       Depends libwine:i386 (= 3.0-1ubuntu1)
i A libwine:i386      Depends libglib2.0-0:i386 (>= 2.12.0)
i A libglib2.0-0:i386 Depends libmount1:i386 (>= 2.19.1)   
i A libmount1:i386    Depends libblkid1:i386 (>= 2.17.2) 


Code: Select all
sudo apt list |& grep ' i386.*installed'
wine-stable-i386/bionic,now 4.0~bionic i386 [installed,automatic]
wine32/bionic,now 3.0-1ubuntu1 i386 [installed]


pkcon refresh
Code: Select all
Enabled                              http://dl.winehq.org/wine-builds/ubuntu bionic InRelease
 Enabled                              http://us.archive.ubuntu.com/ubuntu bionic InRelease
 Disabled                             http://dl.google.com/linux/chrome/deb stable InRelease
 Enabled                              http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
 Enabled                              http://deb.playonlinux.com bionic InRelease
 Enabled                              http://archive.canonical.com/ubuntu bionic InRelease
 Enabled                              http://security.ubuntu.com/ubuntu bionic-security InRelease
 Enabled                              http://dl.google.com/linux/chrome/deb stable Release
 Enabled                              http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease
 Enabled                              http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/lyzardking/ubuntu-make/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/noobslab/apps/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/unit193/encryption/ubuntu bionic InRelease


I like my wine 32
Oddly Discovery and Synaptic updates pull no errors.

Last edited by stephenhenderson on Sun May 12, 2019 6:06 pm, edited 1 time in total.
NoNameNoBlame
Karma
0
When You do:
$ aptitude why wine32

and the result is:
"No dependencies require to install wine32"

and You also don't know why it is installed,
that is: You didn't do it intentionally,

then: De-install wine32.

Edit:
I see winhq and playonlinux
among Your repositories.

You should recheck their requirements.

External repositories can be dangerous, if You don't
know the exact details.

And sometimes You have to decide:
What's more important:

a) The integrity of Your Operating System, or
b) Incompatible external software

Always choose "a)".

De-install the incompatible stuff.

You can reinstall it later, after You found
out how to install it in a compatible way if this
is possible. Probably it is. But not neccessarily.

Last edited by NoNameNoBlame on Sun May 12, 2019 6:15 pm, edited 1 time in total.
stephenhenderson
Registered Member
Posts
9
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 6:14 pm
I did install wine 32 should I get rid off it and install a 64 bit wine?
I do like my wine 32.
Oddly updates with Discovery and synaptic pull no errors.

Are you saying I can't run wine?

How to install Wine on Neon 18.04 Bionic
viewtopic.php?f=309&t=154066

Code: Select all
sudo apt-get install wine32
[sudo] password for stevehendo34:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
wine32:i386 is already the newest version (3.0-1ubuntu1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.


Note: I like your profile

Last edited by stephenhenderson on Sun May 12, 2019 6:18 pm, edited 1 time in total.
NoNameNoBlame
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 6:17 pm
I added an EDIT to my previous posting.

You shouldn't use "apt-get install".
"apt install" is always better.

BUT!
On KDE neon, You should use:

"pkcon install".

Last edited by NoNameNoBlame on Sun May 12, 2019 6:31 pm, edited 1 time in total.
stephenhenderson
Registered Member
Posts
9
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 6:25 pm
Might have to deinstall Neon it works in Ubuntu 19.04 gnome & kubuntu.

Thanks though!
NoNameNoBlame
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 6:35 pm
Good Luck!

Happy Distro-Hopping!

I only use STEAM on KDE neon. This works.
Because the STEAM client only installs into
the user's HOME-directory, and therefore
doesn't interfere with the rest of the OS.
stephenhenderson
Registered Member
Posts
9
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 7:29 pm
I'll probably will ditch wine on this Neon box sometime, this is the box I have hooked to my 4K TV, mostly streaming things like Hulu and Netflix and use Google Spyware.

I did give you credit by accepting your post so I think your answer is fine, Thanks again.
I tried getting rid of winehq and play on linux repo's.
Dude, it was worth a shot to use this support.
Distro hopper is kinda mean dish, don't you think.

I have Ubuntu, Arch, MX, Rasbian and Antix installed all on different hardware, even WSL on Windows 10.
I'm not hopping , Linux is Linux, I use a lot I3 window manager and suckless software alot on the daily driver. I hate games, they bore me, i'm old (65) and used Unix & BSD since the 70's. on mini computes (Vax HP IBM). I new Mad Dog Jon Hall, he got me on a Redhat 5 Alfa PC. when I worked for DEC.
NoNameNoBlame
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 7:34 pm
Why didn't You simply do:

# pkcon install playonlinux

on KDE neon, without external reopsitories?

It depends on "wine",
which depends on "wine-stable",
which depends on "wine64".
stephenhenderson
Registered Member
Posts
9
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 7:40 pm
Gotcha
NoNameNoBlame
Karma
0

Re: libblkid1 error in pkcon update

Sun May 12, 2019 7:51 pm
Regarding "Distro-Hopping":

My most humble apologies…

I really wasn't in the mood for insulting
innocent others - even by accident.

(But sometimes, I am. Aren't we all, sometimes?)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], Google Adsense [Bot]