Reply to topic

Neon is great! Just one small problem ... themes

hhyvarinen
Registered Member
Posts
5
Karma
0
I am new Neon user - congratulations to the KDE Neon team, great work. My new installation works great, fast and lightweight. This is the best KDE yet.
One thing I do not seem to manage - installing new Look and Feel themes from "System Settings > Workspace Themes". I can install Plasma Themes (which also prompts Install from File), but Breeze and Breeze Dark remain the only Look and Feels. When I try to install a new theme from Get New Look and Fee themes, the interface says "installing" but nothing ever happens.
I checked my .kde/share/apps and its subdirectories, nothing about themes. The only themes I see (as root) are in /usr/share/themes. This is where Breeze lives.
If I was to extract a downloaded theme from KDE Store, a .gz file as root to /usr/share/themes, would it work, or am I simply not understanding the GUI method right?
This is a brand new installation, just upgraded:

aptitude show kwin-x11
Package: kwin-x11
Version: 4:5.15.5-0xneon+18.04+bionic+build39
State: installed

All help appreciated,
Hannu
airdrik
Registered Member
Posts
1588
Karma
3
OS
First thing that I'll point out is that in KDE 5, most settings and such have moved from ~/.kde to either ~/.config or ~/.local/share (following XDG standards). As such per-user themes should be stored in ~/.local/share, in subdirectories depending on the theme.

How downloadable a theme is kind of depends on the theme in question as some may only be for older versions of KDE, or some may be set up weird so they can't be downloaded through those GHNS dialogs. That said, I would assume most of the look-and-feel themes should just work since those were introduced in the middle of the Plasma 5 series. They may take a while since a look-and-feel theme is actually more of a package containing a number of other theme components including desktop theme, color scheme and window decorations which all need to be downloaded and installed together when you install the look-and-feel theme.

Another thing you can try is using Discover to install them since Discover is set to be able to download and install (per-user) stuff from store.kde.org as well as the distro's repositories (and flatpak and snap, if you have those backends installed).


airdrik, proud to be a member of KDE forums since 2008-Dec.
hhyvarinen
Registered Member
Posts
5
Karma
0
Thank you for your help, I had partial success. I found the right folders, the themes go to ~/.local/share/plasma/look-and-feel and the plasma themes to ~/.local/share/plasma/desktoptheme.
I may have chosen themes that are incomplete for this installation, and when installing two themes manually - extracting the downloaded file to that dir - they basically work, though icons are not showing. I am a little closer ...
Hannu


airdrik wrote:First thing that I'll point out is that in KDE 5, most settings and such have moved from ~/.kde to either ~/.config or ~/.local/share (following XDG standards). As such per-user themes should be stored in ~/.local/share, in subdirectories depending on the theme.

How downloadable a theme is kind of depends on the theme in question as some may only be for older versions of KDE, or some may be set up weird so they can't be downloaded through those GHNS dialogs. That said, I would assume most of the look-and-feel themes should just work since those were introduced in the middle of the Plasma 5 series. They may take a while since a look-and-feel theme is actually more of a package containing a number of other theme components including desktop theme, color scheme and window decorations which all need to be downloaded and installed together when you install the look-and-feel theme.

Another thing you can try is using Discover to install them since Discover is set to be able to download and install (per-user) stuff from store.kde.org as well as the distro's repositories (and flatpak and snap, if you have those backends installed).
User avatar claydoh
Registered Member
Posts
395
Karma
5
OS
My first thought is that it might be a KDE store issue, but it works fine on Kubuntu 19.04 (Plasma 5.15.4, Frameworks 5.56.0).

On Neon (Plasma 5.15.5, Frameworks 5.58.0) it sits for a spell, then marks it as installed, but it is not.
I get this output in the terminal:

Code: Select all
claydoh@claydoh-ideapad:~$  kcmshell5 kcm_lookandfeel 
org.kde.kcoreaddons: Error loading plugin "kcm_lookandfeel" "The shared library was not found."
Plugin search paths are ("/usr/lib/x86_64-linux-gnu/qt5/plugins", "/usr/bin")
The environment variable QT_PLUGIN_PATH might be not correctly set
<Unknown File>:3:89: Unable to assign [undefined] to double
org.kde.knewstuff.core: Using a deprecated location for the knsrc file "lookandfeel.knsrc"  - please contact the author of the software which provides this file to get it updated to use the new location
QNetworkReplyHttpImplPrivate::_q_startOperation was called more than once QUrl("https://autoconfig.kde.org/ocs/providers.xml")
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap

<a whole bunch of this message, then this:
Code: Select all
org.kde.knewstuff.core: Command ' "kpackagetool5 -t Plasma/LookAndFeel -i /tmp/Sweet.tar.gz" ' failed with code 4


Kubuntu has a completely different output ,without the QPixmap message spam (which may or may not be related to the problem). The same theme selected in Neon installs and works as expected.


probably all related to this bug:
https://bugs.kde.org/show_bug.cgi?id=407593

Last edited by claydoh on Thu May 16, 2019 11:17 pm, edited 1 time in total.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
hhyvarinen
Registered Member
Posts
5
Karma
0
Claydoh, that's exactly what I am experiencing. I have Kubuntu 19.04 in another computer, it installs the same themes that I tried with one click from System Settings > Workspace Theme > Get new ....
So, is it fair to assume that this is KDE Store issue that they hopefully will be correcting ... ?
Thank you,
Hannu


claydoh wrote:My first thought is that it might be a KDE store issue, but it works fine on Kubuntu 19.04 (Plasma 5.15.4, Frameworks 5.56.0).

On Neon (Plasma 5.15.5, Frameworks 5.58.0) it sits for a spell, then marks it as installed, but it is not.
I get this output in the terminal:

[Kubuntu has a completely different output ,without the QPixmap message spam (which may or may not be related to the problem). The same theme selected in Neon installs and works as expected.


probably all related to this bug:
\https://bugs.kde.org/show_bug.cgi?id=407593
User avatar claydoh
Registered Member
Posts
395
Karma
5
OS
No, it looks like it may be a problem in the Get New Stuff tool, since it works in Kubuntu 19.04, which is slightly behind Neon in terms of Plasma and Frameworks. Someone already reported a bug, and I have added to it.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
behradj
Registered Member
Posts
1
Karma
0
i just notice that since updated to 15.5.5 i hopefuly fix that in next update
hhyvarinen
Registered Member
Posts
5
Karma
0
Seems that in spite of a series of updates, no fix to the " Get New Look And Feel Themes ... " problem yet.
I earlier discussions it got mentioned:

probably all related to this bug:
\https://bugs.kde.org/show_bug.cgi?id=407593

Any news?
Hannu
hhyvarinen
Registered Member
Posts
5
Karma
0
May 31st - Works now! Thank you

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], Exabot [Bot], Google [Bot], RogueScholar, smrtsmith, Sogou [Bot], tburke, Yahoo [Bot]