Reply to topic

Can't change locale

User avatar jbouter
Registered Member
Posts
4
Karma
0
OS

Can't change locale

Fri May 17, 2019 6:14 pm
Hi all,

I'm trying to change the locale settings on my fresh KDE Neon install, but I can't seem to change them. The language of KDE remains American English, where I want it to be British English. The lock screen and sddm are displaying seconds in their timestamps, which I don't want either.

The contents of my configuration files are:

/etc/default/locale
Code: Select all
LC_ALL=C
LANG=en_GB.UTF-8
LANGUAGE=en_GB.UTF-8
LC_TIME=nl_NL.UTF-8
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES=en_GB.UTF-8


/etc/locale.gen
Code: Select all
en_GB.UTF-8 UTF-8
en_US.UTF-8 UTF-8
nl_NL.UTF-8 UTF-8


/etc/environment
Code: Select all
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
LC_ALL=C
LANG=en_GB.UTF-8
LANGUAGE=en_GB.UTF-8
LC_TIME=nl_NL.UTF-8
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES=en_GB.UTF-8



~/.config/plasma-localerc
Code: Select all
[Formats]
LANG=en_GB.US-ASCII
LC_COLLATE=nl_NL.US-ASCII
LC_MEASUREMENT=nl_NL.US-ASCII
LC_MONETARY=nl_NL.US-ASCII
LC_NUMERIC=nl_NL.US-ASCII
LC_TIME=nl_NL.US-ASCII
useDetailed=true

[Translations]
LANGUAGE=en_GB


~/.config/plasma-locale-settings.sh
Code: Select all
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=en_GB.US-ASCII
export LC_NUMERIC=nl_NL.US-ASCII
export LC_TIME=nl_NL.US-ASCII
export LC_MONETARY=nl_NL.US-ASCII
export LC_MEASUREMENT=nl_NL.US-ASCII
export LC_COLLATE=nl_NL.US-ASCII
export LANGUAGE=en_GB


I have configured the Regional Settings in plasma settings to be the following:
Language: British English (default)
Formats:
Region: en_GB
Detailed Settings: nl_NL

I have attempted to remove all config files in my home directory, and the problem remained. Are there any locations in which locale settings are configured or cached that I might have overlooked? Thanks in advance.
User avatar jbouter
Registered Member
Posts
4
Karma
0
OS

Re: Can't change locale  Topic is solved

Sat May 18, 2019 8:19 am
I have resolved the matter by setting LC_ALL=en_GB.UTF-8. Quite possibly, removing the value would work too.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, Google [Bot], kakosf, Majestic-12 [Bot], Mamarok, millaan, Moski, raphaelra