Reply to topic

The 'grub-efi-amd64-signed' package failed to install into

joninchaurbe
Registered Member
Posts
13
Karma
0
OS
I've had an error during an installation of KDE Neon.
In fact, I've had tried installing Kubuntu 18.04 with the same error:

"The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot"


But, it's important, not ever. I got a first installation OK but when I tried reinstalling the same OS I had that error.

I had installed KDE Neon the first time and everything finished OK. But I realized I'd committed some error, it doesn't matter what was, and I tried reinstalling and I had the error. I installed Kubuntu as I'd said and not problem. OK, Try again with Neon. Error. It wasn't matter if I had checked "Install Third-party software..." or not, if I had had a Internet connection or not, etc., as I've read. In all the times I'd chosen a manual mounting and formatting partitions.

Why the first installation OK and not the rest? I don't have any idea. It could be a bug?

But I'd got an easy solution that has worked for me and I'm going to explain to be help for others.

As simply as deactivate "secure boot" in the BIOS.
In my case, ACER R3, go to BIOS, set a password in 'Security' tab, go to 'Boot' tab and disable 'Secure Boot', which isn't possible if you hadn't set a password first. Go to 'Security' again and remove password (setting an empty password).
Install KDE Neon again, without problem, and reboot computer. Without problem, nor Neon neither Windows (In this computer I had Windows 10 too).
To finish, go to the BIOS again, set a password, enable 'Secure Boot', remove password and reboot. All has been OK.

Cheers

Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Majestic-12 [Bot], Peter Evans, Snudl, Sogou [Bot], TristanDee