Reply to topic

Issue no proxy doesnt affect Discover/PackageKit?

braxs69
Registered Member
Posts
3
Karma
0
Hi all,
anyone might know where PackageKit is getting its http proxy config from?
It may be me just be being clueless but it seems to be stuck with one configured, leading me unable to update.
I was playing around with privoxy for a weekend but removed it and cleared/defaulted the proxy settings,
but PackageKit doesn't seem to want to let it go.

To be more clear:
  • I used the Proxy section in System Settings to manually set a http proxy initially.
    (which worked as expected, was also the only place other than the browser that i used to configure use of a proxy)
  • but setting it back to "no proxy" Discover/PackageKit seems to be stuck with the last http proxy config. (even after rebooting or making a new user account)
  • I can set another http proxy back within System Settings and Discover/PackageKit will seem to reflect the changes on refresh.
  • no http_proxy set in env, neither within /etc/environment or /etc/PackageKit/PackageKit.conf.
reflipd
Registered Member
Posts
1
Karma
0
I have the same problem, there doesn't seem to be a solution. I have been trying to fix it all day, I tried reinstalling Discover as well. Didn't work.

Image

Can't install new software either.
User avatar apachelogger
KDE Developer
Posts
519
Karma
5
OS
You'll wanna click on 'About' in the bottom left and then 'Report Bug' in the top right and file a bug report against discover. I am pretty sure it doesn't forward proxies to the underlying packagekit daemon.


Annoyed with bbcode since 1999.
JJB
Registered Member
Posts
1
Karma
0
I have the same issue going back to a no-proxy configuration. Making a long story short, I made Discover to forget the old proxy by restarting a service:

Code: Select all
sudo systemctl restart packagekit.service


I explain my rationale bellow:

I noticed I had this problem with pkcon and Discover, but not with apt and relatives.

Both pkcon and Discover depend on the PackageKit. Researching it's configuration files found a policy about an action suspiciously named

org.freedesktop.packagekit.system-network-proxy-configure
.

The following is just speculation, but I'm guessing the daemon:

Code: Select all
/usr/lib/packagekit/packagekitd


.. run by SystemD, is storing the proxy in some binary database.

Sadly it seems fails to update it when no proxy is configured. In my case, restarting the daemon solved the problem.

Last edited by JJB on Fri Feb 28, 2020 1:16 pm, edited 1 time in total.
kde-rommel
Registered Member
Posts
2
Karma
0
Hello all;
try creating an apt.conf in /etc/apt directory an in this put the configuration of your proxy. Mine look like this:


$ cat /etc/apt/apt.conf
Debug::pkgProblemResolver "true";
Acquire::Languages "none";
Acquire::http::proxy "http://proxy_user:[email protected]_name_or_IP:port";
Acquire::https::proxy "proxy_user:[email protected]_name_or_IP:port";
Acquire::ftp::proxy "proxy_user:[email protected]_name_or_IP:port";

Rommel
nicuessa
Registered Member
Posts
1
Karma
0
@JJB, Thanks for the solution. It works for me. :)

KDE neon 5.18
wkun
Registered Member
Posts
1
Karma
0
OS
If someone happen to see behavior specified in OP, and restarting packagekit.service doesn't help:
There is a SQLite database in this file /var/lib/PackageKit/transactions.db
I opened the file with sqlitebrowser and deleted a record in table proxy that resembles a configured proxy (actually it was a single record in this table). After that i restarted packagekit.service. Pkcon and Discover now work smoothly.
Hope that helps.
StMartin81
Registered Member
Posts
26
Karma
0
@wkun: Thanks a lot! Had this problem also and this solved it.
egemenk
Registered Member
Posts
1
Karma
0
@wkun: that fixed it for me, thanks!
Konno
Registered Member
Posts
1
Karma
0
If anyone feel like modifying database is too troublesome, you can simply (completely) remove packagekit (make sure you've already disabled all proxies) and then reinstall it. On Arch Linux it is:

Code: Select all
sudo pacman -Rsn packagekit
sudo pacman -S packagekit
lepolau
Registered Member
Posts
1
Karma
0
Hello everyone,
I've just switched to KDE.
This proxy problem is really annoying when you use your pc in a professional environment.
For my part I found that :
1 / the proxy settings in system configuration tools are not saved
2 / if I configure kioslaverc manually it works except for packagekit except the first time,
3 / at the first configuration of kioslaverc (or apt.conf??) the proxy settings for packagekit are saved in transactions.db but, if you need to use another network without proxy, there is no way back. The only solution is to delete the transactions.db file (/var/lib/PackageKit/transactions.db).
This is a very annoying problem.
It is a concern especially the 1 exists under Neon and on kubuntu 20.04, so for this one it is certainly related to KDE and not to package kit.
Coming from Gnome (ubuntu 20.04) I had never had any problem and everything was modifiable in graphics.
Hoping that this can help you find the problem and if you need more information, I'm waiting for your requests.
Thank you in advance.
jorgelizandro
Registered Member
Posts
1
Karma
0
I just faced this issue and removing the proxy config made the trick, I hope it gets fixed soon, thank you!
Code: Select all
OS: openSUSE Leap 15.2 x86_64
Kernel: 5.3.18-lp152.66-default
DE: KDE[list=]

[/list]


wkun wrote:If someone happen to see behavior specified in OP, and restarting packagekit.service doesn't help:
There is a SQLite database in this file /var/lib/PackageKit/transactions.db
I opened the file with sqlitebrowser and deleted a record in table proxy that resembles a configured proxy (actually it was a single record in this table). After that i restarted packagekit.service. Pkcon and Discover now work smoothly.
Hope that helps.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], benderclark, Bing [Bot], Google [Bot], Majestic-12 [Bot], pauljurczak, Sogou [Bot], Yahoo [Bot]