Reply to topic

How to use other input method? (pinyin)

sugarat
Registered Member
Posts
2
Karma
0
Hi there,

My wife requires the ability to use pinyin (simplified chinese) input on KDE Neon. I have so far been completely unsuccessful in getting this working on KDE Neon.

Please advise how I can get Neon to accept pinyin input? I have tried fcitx and Ibus so far, and neither seem to work :-(

Many thanks
thunder422
Registered Member
Posts
44
Karma
0
OS
My wife had the same requirement and I had to figure this out when I installed Neon on her computer (I had Linux Mint KDE 17.3 on her computer before where previously I had Chinese input working). It was a pain (is always a pain) but I finally got it working on Neon for her though like you tried a bunch of things until I got it working. I didn't record the steps and I'm wasn't sure what actually made if work in the end. I had to figure it out again. Here are the steps I did on my computer (currently running KDE Neon 5.16.3):
Code: Select all
sudo apt install ibus ibus-sunpinyin
ibus-setup
An "EN" icon appears in the taskbar. I right-clicked on this icon a selected Preferences. Then on the Input Method tab, selected Add. I selected SunPinyin and clicked Add. The following command may also be needed, but I'm not sure:
Code: Select all
im-config -n ibus
Then you need to log out and log back in. Once I logged back in, the "EN" icon had disappeared, but the IBus Preferences had started. I just clicked Close. At this point it was working. By default Meta-Space switches input modes (Meta is the Windows key). When you do Meta-Space, a little box pops up, showing the current input mode (English or SunPinyin icons with the word below). While holding the Meta key, hitting Space toggles it back and forth. Releasing the Meta key sets the input mode to the one currently selected.

I should mention that it is SunPinyin that my wife uses, and I believe this is simplified Chinese. If SunPinyin is not right for your wife, there is another package named ibus-pinyin. I don't know the difference between these. Install this one, then in IBus Preferences (if the EN icon disappears for you to, you can get to it by selecting the launcher button and typing "ibus"), go to the Input Method tab again and add Pinyin and remove SunPinyin. May need to log out and in again.

Last edited by thunder422 on Mon Jul 29, 2019 10:43 pm, edited 1 time in total.


Currently using KDE Neon 5.16 with Windows 10 in a VM; migrated from Linux Mint 17.3
sugarat
Registered Member
Posts
2
Karma
0
Hi there.

Many thanks for your help on this one. That's a very similar setup to what we have here at the moment. We have the ibus daemon running, and the little language icon on the taskbar. Pinyin and US english are listed as available input methods. When I press meta-space, the language selector pops up. I can select pinyin there, but then.. nothing happens. Any text that is input just appears in English as normal.

I don't have an lm-config command however, so that part I was not able to run. I think that could be a missing part of the puzzle. Can you advise what package is providing that command?

Thanks a lot.
thunder422
Registered Member
Posts
44
Karma
0
OS
Looks like I typed it wrong, sorry about that. It's im-config with an I, not an L (as in "input method configuration"). It's in the im_config package, which I believe was either already installed, or was installed with the ibus packages. I now believe this should be the missing piece. (I'll go back and fix my previous message.)


Currently using KDE Neon 5.16 with Windows 10 in a VM; migrated from Linux Mint 17.3

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Dibo, Google [Bot], hsnnsnc, Majestic-12 [Bot], medmedin, nocruoro, shroobster, Snudl, tymond