Reply to topic

Dependency conflict with ark and libzip4

wolftune
Registered Member
Posts
34
Karma
0
Fresh Neon install today (but installed several packages after that today), and then updating removed ark!

I get this:
ark: Depends: libzip4 (>= 1.5.2) but 1.1.2-1.1 is to be installed

I can't figure out what's going on. Now, ark is missing from my system.
User avatar Mamarok
Manager
Posts
3842
Karma
11
OS
Which Neon? You need to be precise, as there are several versions.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu 19.10 beta, Plasma 5.16.5, Frameworks 5.62.0, Qt 5.12.4, kernel 5.3.0-17
User avatar acheronuk
KDE Developer
Posts
94
Karma
2
Code: Select all
sudo apt install ark libzip4=1.5.2-0+18.04+bionic+build2
User avatar kde-jriddell
Registered Member
Posts
70
Karma
1
OS
Sorry about that, I've updated neon-settings now (which had an override on the version). You should be able to install neon-settings and then upgrade as normal.
wolftune
Registered Member
Posts
34
Karma
0
Thanks! All resolved. Meta: Is it reasonable to report this sort of thing here on the forum or better as a bug report or…?
User avatar bobbywibowo
Registered Member
Posts
33
Karma
0
OS
I also got this issue, and used the command suggested by acheronuk, but "pkcon get-updates" is telling me that "libzip4-1.1.2-1.1" is an upgrade, and will probably forcefully downgrade it to that specific version the next time I run "pkcon update". Any idea what's up with that? I saw the mention of neon-settings, and mine is at 0.0+p18.04+git20190906.1404 right now. To be completely sure, I ran "apt install --reinstall neon-settings" before running the command from acheronuk, but yeah, that seemed to be doing nothing relevant.

Also what would be the best way of outputting the actual version of whatever base my KDE neon is at? Or something along that line. Or like, is it good enough to say KDE neon User Edition 5.16.5?


"LIfe is like riding a bicycle. To keep your balance, you must keep moving." - Albert Einstein

Homepage: https://fiery.me
User avatar bobbywibowo
Registered Member
Posts
33
Karma
0
OS
Never mind, it seems to be caused by /etc/apt/preferences.d/98-xenial-overrides. Judging by the name, it might be a leftover override file from back when KDE neon was on 16.04. It had the following lines in it:
Code: Select all
Package: libzip4
Pin: release o=Ubuntu
Pin-Priority: 1100

I also had another file named 99-xenial-overrides, in which override for libzip4 in particular didn't exist.
I've moved them elsewhere for now.


"LIfe is like riding a bicycle. To keep your balance, you must keep moving." - Albert Einstein

Homepage: https://fiery.me
User avatar kde-jriddell
Registered Member
Posts
70
Karma
1
OS
Thanks for the report, I've added a rule to delete these files on upgrades

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Google [Bot], jsalatas, kinghat, ngraham, npeter, Sogou [Bot], vinnywright, Willov