Reply to topic

processes started through ssh won't stay running

ogodinez
Registered Member
Posts
1
Karma
0
Hi,
I've found this problem and I'm not sure if there is something wrong with my configuration of if this is a bug in Neon of some sort.
I routinely ssh into my office desktop and start processes there, detaching them from the terminal using either setsid, nohup, or pause+bg+disown. Now this won't work and regardless of what I do the process dies after I close the shell.
I've tried starting the process with the aforementioned methods, and I tried with tmux and screen as well. I've verified monitoring the process tree with ps tree and confirmed the process does get detached from the terminal, but it dies when I close the window regardless.
Is there anything else that could be wrong?

Edit:
As a workaround, I figured I can just log in through ssh, and then X-forward myself another terminal, then I can start my jobs in there and they won't die after I log out.

Edit 2:
That actually doesn't work. Processes will survive the closing of the terminal they were started with, but will die after the terminal that summoned the remote terminal window is closed.

Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], htofaili, kamranahmed, KayshiAri, Majestic-12 [Bot], Sentinel, Snudl, Yahoo [Bot]