Reply to topic

Install the Linux 5.0 Update on Neon 5.16?

wrender
Registered Member
Posts
108
Karma
1
OS
Since KDE Neon is based on Ubuntu 18.04LTS will it be getting the Linux 5.0 update?


Will this command work or break KDE Neon?


sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04



ps. this is from this article I came across

https://www-howtogeek-com.cdn.ampproject.org/v/s/www.howtogeek.com/436507/how-to-install-the-linux-5.0-update-on-ubuntu-18.04-lts/amp/?amp_js_v=0.1#referrer=https%3A%2F%2Fwww.google.com&amp_tf=From%20%251%24s&ampshare=https%3A%2F%2Fwww.howtogeek.com%2F436507%2Fhow-to-install-the-linux-5.0-update-on-ubuntu-18.04-lts%2F


wrender, proud to be a member of KDE forums since 2008-Oct.
User avatar claydoh
Registered Member
Posts
484
Karma
5
OS
No, it should not break Neon, though of course your mileage may vary.
Not sure how quickly the kernel is getting to users, and I cannot recall or find info on if Neon enables HWE by default or not, buit the command given in your link is correct. If it shows as already installed, then you know you will get it shortly.

I already have it as I added it some weeks ago. No issues on my fairly generic Intel i5 laptop, with Intel graphics.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar claydoh
Registered Member
Posts
484
Karma
5
OS
I just installed a second Neon in a VM, using an iso about a month old, and one of the updates after I rebooted is the 5.0 kernel, so unbless your install is old (like my laptop) you should see the kernel in your updates.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
wrender
Registered Member
Posts
108
Karma
1
OS
I did not click yes to continue as it seemed sketchy....

Code: Select all
 sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04
[sudo] password for wren:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 5
Starting 2 pkgProblemResolver with broken count: 5
Investigating (0) xserver-xorg-video-intel-native-modesetting:amd64 < 0+p18.04+git20180904.1048 @ii mK Ib >
Broken xserver-xorg-video-intel-native-modesetting:amd64 Conflicts on xserver-xorg-video-intel:amd64 < none | 2:2.99.917+git20171229-1 @un uH >
  Conflicts//Breaks against version 2:2.99.917+git20171229-1 for xserver-xorg-video-intel but that is not InstVer, ignoring
  Considering xserver-xorg-video-intel-hwe-18.04:amd64 0 as a solution to xserver-xorg-video-intel-native-modesetting:amd64 7
  Added xserver-xorg-video-intel-hwe-18.04:amd64 to the remove list
Broken xserver-xorg-video-intel-native-modesetting:amd64 Breaks on xserver-xorg-video-intel:amd64 < none | 2:2.99.917+git20171229-1 @un uH >
  Conflicts//Breaks against version 2:2.99.917+git20171229-1 for xserver-xorg-video-intel but that is not InstVer, ignoring
  Considering xserver-xorg-video-intel-hwe-18.04:amd64 0 as a solution to xserver-xorg-video-intel-native-modesetting:amd64 7
  Added xserver-xorg-video-intel-hwe-18.04:amd64 to the remove list
  Fixing xserver-xorg-video-intel-native-modesetting:amd64 via keep of xserver-xorg-video-intel-hwe-18.04:amd64
  Fixing xserver-xorg-video-intel-native-modesetting:amd64 via keep of xserver-xorg-video-intel-hwe-18.04:amd64
Investigating (0) xserver-xorg-input-wacom:amd64 < 1:0.36.1-0ubuntu1 @ii mK Ib >
Broken xserver-xorg-input-wacom:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 -1 as a solution to xserver-xorg-input-wacom:amd64 1
  Added xserver-xorg-core:amd64 to the remove list
  Fixing xserver-xorg-input-wacom:amd64 via keep of xserver-xorg-core:amd64
Investigating (0) xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mK Ib >
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting:amd64 < none @un H >
  Considering xserver-xorg-core-hwe-18.04:amd64 11 as a solution to xserver-xorg-core:amd64 -1
  Removing xserver-xorg-core:amd64 rather than change xserver-xorg-video-modesetting:amd64
Investigating (1) xserver-xorg-input-wacom:amd64 < 1:0.36.1-0ubuntu1 @ii mK Ib >
Broken xserver-xorg-input-wacom:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 -1 as a solution to xserver-xorg-input-wacom:amd64 1
  Added xserver-xorg-core:amd64 to the remove list
  Fixing xserver-xorg-input-wacom:amd64 via keep of xserver-xorg-core:amd64
Investigating (1) xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mK Ib >
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting:amd64 < none @un H >
  Considering xserver-xorg-core-hwe-18.04:amd64 11 as a solution to xserver-xorg-core:amd64 -1
  Removing xserver-xorg-core:amd64 rather than change xserver-xorg-video-modesetting:amd64
Investigating (2) xserver-xorg-input-wacom:amd64 < 1:0.36.1-0ubuntu1 @ii mK Ib >
Broken xserver-xorg-input-wacom:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 -1 as a solution to xserver-xorg-input-wacom:amd64 1
  Added xserver-xorg-core:amd64 to the remove list
  Fixing xserver-xorg-input-wacom:amd64 via keep of xserver-xorg-core:amd64
Investigating (2) xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mK Ib >
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting:amd64 < none @un H >
  Considering xserver-xorg-core-hwe-18.04:amd64 11 as a solution to xserver-xorg-core:amd64 1
  Removing xserver-xorg-core:amd64 rather than change xserver-xorg-video-modesetting:amd64
Investigating (3) xserver-xorg-input-wacom:amd64 < 1:0.36.1-0ubuntu1 @ii mK Ib >
Broken xserver-xorg-input-wacom:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 11 as a solution to xserver-xorg-input-wacom:amd64 1
  Removing xserver-xorg-input-wacom:amd64 rather than change xserver-xorg-core:amd64
Investigating (3) xserver-xorg-input-evdev:amd64 < 1:2.10.5-1ubuntu1 @ii mK Ib >
Broken xserver-xorg-input-evdev:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 11 as a solution to xserver-xorg-input-evdev:amd64 0
  Removing xserver-xorg-input-evdev:amd64 rather than change xserver-xorg-core:amd64
Investigating (3) kde-config-tablet:amd64 < 3.2.0-0xneon+18.04+bionic+build7 @ii mK Ib >
Broken kde-config-tablet:amd64 Depends on xserver-xorg-input-wacom:amd64 < 1:0.36.1-0ubuntu1 @ii mR >
  Considering xserver-xorg-input-wacom:amd64 11 as a solution to kde-config-tablet:amd64 0
  Removing kde-config-tablet:amd64 rather than change xserver-xorg-input-wacom:amd64
Investigating (3) xserver-xorg-input-synaptics:amd64 < 1.9.0-1ubuntu1 @ii mK Ib >
Broken xserver-xorg-input-synaptics:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 11 as a solution to xserver-xorg-input-synaptics:amd64 0
  Removing xserver-xorg-input-synaptics:amd64 rather than change xserver-xorg-core:amd64
Investigating (3) xserver-xorg-input-libinput:amd64 < 0.27.1-1 @ii mK Ib >
Broken xserver-xorg-input-libinput:amd64 Depends on xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.3 @ii mR > (>= 2:1.18.99.901)
  Considering xserver-xorg-core:amd64 11 as a solution to xserver-xorg-input-libinput:amd64 0
  Removing xserver-xorg-input-libinput:amd64 rather than change xserver-xorg-core:amd64
Investigating (4) xserver-xorg-hwe-18.04:amd64 < none -> 1:7.7+19ubuntu8~18.04.2 @un puN Ib >
Broken xserver-xorg-hwe-18.04:amd64 Depends on xserver-xorg-input-all-hwe-18.04:amd64 < none | 1:7.7+19ubuntu8~18.04.2 @un uH >
  Considering xserver-xorg-input-all-hwe-18.04:amd64 1 as a solution to xserver-xorg-hwe-18.04:amd64 9999
  Re-Instated xserver-xorg-input-libinput-hwe-18.04:amd64
  Re-Instated xserver-xorg-input-all-hwe-18.04:amd64
Done
The following packages were automatically installed and are no longer required:
  fonts-dejavu gnustep-base-common gnustep-base-runtime gnustep-common gtk3-engines-breeze icoutils kde-runtime kde-runtime-data
  kdelibs-bin kdelibs5-plugins kdoctools libetonyek-0.1-1 libexiv2-14 libgc1c2 libgnustep-base1.25 libgpgme++2v5 libkactivities6
  libkcmutils4 libkde3support4 libkdeclarative5 libkdecorations2private5v5 libkdesu5 libkdewebkit5 libkdnssd4 libkemoticons4
  libkf5syndication5 libkf5texteditor5-libjs-underscore libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkxmlrpcclient4 libllvm6.0
  libllvm6.0:i386 libllvm7 libllvm7:i386 libnl-route-3-200 libntrack-qt4-1 libntrack0 libnvidia-common-410 libobjc4 liborcus-0.13-0
  libplasma3 libpolkit-qt-1-1 libqca2 libqca2-plugins libqtwebkit4 libreoffice-style-galaxy libsolid4 libstreamanalyzer0v5
  libstreams0v5 libthreadweaver4 libwps-0.4-4 libxmlsec1 libxmlsec1-nss linux-headers-4.15.0-38 linux-headers-4.15.0-38-generic
  linux-headers-4.15.0-39 linux-headers-4.15.0-39-generic linux-headers-4.15.0-42 linux-headers-4.15.0-42-generic
  linux-headers-4.15.0-43 linux-headers-4.15.0-43-generic linux-headers-4.15.0-45 linux-headers-4.15.0-45-generic
  linux-headers-4.15.0-46 linux-headers-4.15.0-46-generic linux-headers-4.15.0-47 linux-headers-4.15.0-47-generic
  linux-headers-4.15.0-48 linux-headers-4.15.0-48-generic linux-headers-4.15.0-50 linux-headers-4.15.0-50-generic
  linux-headers-4.15.0-51 linux-headers-4.15.0-51-generic linux-headers-4.15.0-52 linux-headers-4.15.0-52-generic
  linux-image-4.15.0-38-generic linux-image-4.15.0-39-generic linux-image-4.15.0-42-generic linux-image-4.15.0-43-generic
  linux-image-4.15.0-45-generic linux-image-4.15.0-46-generic linux-image-4.15.0-47-generic linux-image-4.15.0-48-generic
  linux-image-4.15.0-50-generic linux-image-4.15.0-51-generic linux-image-4.15.0-52-generic linux-modules-4.15.0-38-generic
  linux-modules-4.15.0-39-generic linux-modules-4.15.0-42-generic linux-modules-4.15.0-43-generic linux-modules-4.15.0-45-generic
  linux-modules-4.15.0-46-generic linux-modules-4.15.0-47-generic linux-modules-4.15.0-48-generic linux-modules-4.15.0-50-generic
  linux-modules-4.15.0-51-generic linux-modules-4.15.0-52-generic linux-modules-extra-4.15.0-38-generic
  linux-modules-extra-4.15.0-39-generic linux-modules-extra-4.15.0-42-generic linux-modules-extra-4.15.0-43-generic
  linux-modules-extra-4.15.0-45-generic linux-modules-extra-4.15.0-46-generic linux-modules-extra-4.15.0-47-generic
  linux-modules-extra-4.15.0-48-generic linux-modules-extra-4.15.0-50-generic linux-modules-extra-4.15.0-51-generic
  linux-modules-extra-4.15.0-52-generic ntrack-module-libnl-0 plasma-scriptengine-javascript unar x11proto-dri2-dev x11proto-gl-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  linux-headers-5.0.0-23 linux-headers-5.0.0-23-generic linux-headers-generic-hwe-18.04 linux-image-5.0.0-23-generic
  linux-image-generic-hwe-18.04 linux-modules-5.0.0-23-generic linux-modules-extra-5.0.0-23-generic xserver-xorg-core-hwe-18.04
  xserver-xorg-input-all-hwe-18.04 xserver-xorg-input-libinput-hwe-18.04 xserver-xorg-legacy-hwe-18.04
  xserver-xorg-video-all-hwe-18.04 xserver-xorg-video-amdgpu-hwe-18.04 xserver-xorg-video-ati-hwe-18.04
  xserver-xorg-video-fbdev-hwe-18.04 xserver-xorg-video-nouveau-hwe-18.04 xserver-xorg-video-qxl-hwe-18.04
  xserver-xorg-video-radeon-hwe-18.04 xserver-xorg-video-vesa-hwe-18.04 xserver-xorg-video-vmware-hwe-18.04
Suggested packages:
  fdutils linux-hwe-doc-5.0.0 | linux-hwe-source-5.0.0 linux-hwe-tools xfonts-100dpi | xfonts-75dpi firmware-amd-graphics
  xserver-xorg-video-r128 xserver-xorg-video-mach64 firmware-misc-nonfree
Recommended packages:
  xserver-xorg-input-wacom-hwe-18.04 xserver-xorg-video-intel-hwe-18.04
The following packages will be REMOVED:
  kde-config-tablet xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-legacy xserver-xorg-video-all xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon
  xserver-xorg-video-vesa xserver-xorg-video-vmware
The following NEW packages will be installed:
  linux-generic-hwe-18.04 linux-headers-5.0.0-23 linux-headers-5.0.0-23-generic linux-headers-generic-hwe-18.04
  linux-image-5.0.0-23-generic linux-image-generic-hwe-18.04 linux-modules-5.0.0-23-generic linux-modules-extra-5.0.0-23-generic
  xserver-xorg-core-hwe-18.04 xserver-xorg-hwe-18.04 xserver-xorg-input-all-hwe-18.04 xserver-xorg-input-libinput-hwe-18.04
  xserver-xorg-legacy-hwe-18.04 xserver-xorg-video-all-hwe-18.04 xserver-xorg-video-amdgpu-hwe-18.04
  xserver-xorg-video-ati-hwe-18.04 xserver-xorg-video-fbdev-hwe-18.04 xserver-xorg-video-nouveau-hwe-18.04
  xserver-xorg-video-qxl-hwe-18.04 xserver-xorg-video-radeon-hwe-18.04 xserver-xorg-video-vesa-hwe-18.04
  xserver-xorg-video-vmware-hwe-18.04
0 upgraded, 22 newly installed, 18 to remove and 0 not upgraded.
Need to get 68.8 MB of archives.



wrender, proud to be a member of KDE forums since 2008-Oct.
User avatar kdeoldster
Registered Member
Posts
42
Karma
0
OS
I have been using the 5.0 hwe kernel for a few months now and it hasn't caused problems for me. This is on an older HP 620 laptop with Intel "everything". As with any kernel upgrades your particular hardware and applications may not work as well as mine have.
wrender
Registered Member
Posts
108
Karma
1
OS
I'm not sure how to interpret those broken warnings... does that look like it would matter and it would be ok to proceed?


wrender, proud to be a member of KDE forums since 2008-Oct.
j8a
Registered Member
Posts
147
Karma
0
OS
Hi,
I have the same problem and claydoh answered to me the following:

You will need to enable https://wiki.ubuntu.com/Kernel/LTSEnablementStack.
If Neon hasn't modified how Ubuntu does this, it is not enabled on the first 'point' releases of the 18.04 ISO (18.04 and 18.04.1), but is enabled by default in the newer images. So, if your setup is a bit older, you do not automatically get this. I saw discussion somewhere on whether or not Neon were going to enable this for all installs, but I can't find it, and I don't think that I saw any decision on it. Luckily it is an easy thing to do.

I recieved newer kernels 4.18 and then 5.0 since I followed the wiki post at ubuntu.

Regards,
User avatar claydoh
Registered Member
Posts
484
Karma
5
OS
j8a wrote:Hi,
I have the same problem and claydoh answered to me the following:

You will need to enable https://wiki.ubuntu.com/Kernel/LTSEnablementStack.
If Neon hasn't modified how Ubuntu does this, it is not enabled on the first 'point' releases of the 18.04 ISO (18.04 and 18.04.1), but is enabled by default in the newer images. So, if your setup is a bit older, you do not automatically get this. I saw discussion somewhere on whether or not Neon were going to enable this for all installs, but I can't find it, and I don't think that I saw any decision on it. Luckily it is an easy thing to do.

I recieved newer kernels 4.18 and then 5.0 since I followed the wiki post at ubuntu.

Regards,

This is what the OP is doing. I do not recall seeing these conflicts myself, or if they did not seem like an issue. They certainly were not asking for the removal of what the OP has here, so holding off for now seems prudent.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Invictus, Majestic-12 [Bot]