Reply to topic

KDE Neon suspend / resume unreliable on Dell XPS13 9360

nharvey
Registered Member
Posts
11
Karma
0
OS
Hi

I am running KDE Neon User Edition, fully updated with the 5.0 kernel, on a Dell XPS13 9360. I tend to put the laptop to sleep by closing the lid when not using it. It will also automatically sleep after 10 idle minutes when on battery. Basically the default Plasma power settings. I also have secure boot enabled, and the hard drive encrypted.

Mostly the laptop will sleep and resume no problem, but fairly frequently (perhaps once every couple of days) it will freeze with a blank screen and the power light on. This can happen when sleeping after being idle for 10 minutes, or when the lid is closed. Also sometimes it will not sleep when the lid is closed, meaning when I later open the lid the laptop still responds but has a drained battery.

I am finding it difficult to diagnose these problems so does anyone know which logs I should look at to try to pin this down? Of course if anyone has seen this before and knows how to fix it then even better! I may also post this on the Ubuntu forums but thought I'd better start here in case this is know to other Neon users.

Thanks in advance for any help.
Nick
nharvey
Registered Member
Posts
11
Karma
0
OS
I am also seeing this problem on Kubuntu 18.04 and have started a thread on the Ubuntu forum here:

https://ubuntuforums.org/showthread.php ... st13882166

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Belliric, Bing [Bot], Google [Bot], jmacleod, Kresimir, Majestic-12 [Bot]