Reply to topic

Nvidia-settings blank screen

damoobler
Registered Member
Posts
2
Karma
0

Nvidia-settings blank screen

Tue Sep 10, 2019 10:51 am
Hi :)
I tried to install the drivers in different ways, but nothing seems to work properly.
It seems that the driver is somehow not working correctly, hence the screen of nvidia-settings is blank.


I am using KDE Neon with Plasma version: 5.16.5
I have an NVIDIA GP108M [GeForce MX150] on a Xiaomi Mi Notebook Pro.
The right driver, from nvidia website seems to be the 435 (https://www.nvidia.com/Download/driverResults.aspx/150803/en-us).

I'm trying to use the drivers from here: https://launchpad.net/~graphics-drivers ... ubuntu/ppa
I added the repository and tried with ubuntu-drivers autoinstall (https://www.****.com/video/LqFRNUnw748/), with apt install nvidia-driver-435 (https://askubuntu.com/questions/733183/ ... controller) and also tried to switch graphic card with bumblebee (https://github.com/Bumblebee-Project/Bu ... issues/822).

I tried multiple times, with small changes suggested on forums, and cleaned the drivers every time both with purge followed by autoremove and from muon, rebooting between every attempt.

Code: Select all
lspci -nn | grep '\[03'

returns:
Code: Select all
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
01:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d12] (rev a1)



Code: Select all
nvidia-smi

returns:
Code: Select all
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.



Code: Select all
glxinfo | grep OpenGL

returns:
Code: Select all
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.0.8
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.0.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:



Do you have any idea of what could be the problem and how to solve it?
Thank you! :)
User avatar vinnywright
Registered Member
Posts
56
Karma
1
OS

Re: Nvidia-settings blank screen

Wed Sep 11, 2019 2:28 am
it dose not sound like the Nvidia chip is getting turned on/used .

you can check by looking at
Code: Select all
lsmod
@hear if I
Code: Select all
lsmod | grep nvidia
I get

Code: Select all
vinny@vinny-Bonobo-Extreme:~$ lsmod | grep nvidia
nvidia_uvm            819200  0
nvidia_drm             45056  5
nvidia_modeset       1114112  14 nvidia_drm
nvidia              19025920  617 nvidia_uvm,nvidia_modeset
drm_kms_helper        180224  1 nvidia_drm
drm                   479232  8 drm_kms_helper,nvidia_drm
ipmi_msghandler       102400  2 ipmi_devintf,nvidia


check in your BIOS setings and see if you can select which card to use , the intel or the nvidia as some times bumblebee can be hard to get working , I have no hardware like that so no experience with it.

I would allso try the 430 and or 390 versions of the driver(nvidia) from that PPA you have their (I use the 430 from their on a GTX860M) that 435 driver is brand spanky new so may have quirks as yet .

VINNY
stephenhenderson
Registered Member
Posts
15
Karma
0

Re: Nvidia-settings blank screen

Wed Sep 11, 2019 2:45 am
I had the same problem when I upgraded driver by mistake via PPA
I had to go back down to 390
Install nouveau open source driver?
Go here lots to try.
https://linuxconfig.org/how-to-install- ... ingo-linux
damoobler
Registered Member
Posts
2
Karma
0

Re: Nvidia-settings blank screen

Wed Sep 11, 2019 7:51 am
Code: Select all
lsmod | grep nvidia

Doesn't return anything. I checked also plain 'lsmod' and it doesn't seem like having anything related to nvidia.

I will try all the other suggestions ASAP, meanwhile thank you very much for the advices :)

 
Reply to topic

Bookmarks



Who is online

Registered users: bartoloni, Bing [Bot], egerlach, Exabot [Bot], Google [Bot], joshiravi, kamathraghavendra, mcoudert, Sogou [Bot], stephanw