Reply to topic

Error on upgrading from Neon 16.04 User LTS to Neon 18.04

baxeico
Registered Member
Posts
9
Karma
0
Hi to everybody.
I'm trying to update my Kde Neon install. I'm currently on Neon 16.04 User Lts (not supported). If I use do-release-upgrade command I have an error:

E:Problem executing scripts APT::Update::Post-Invoke-Success 'if
/usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli -a !
-e
/var/lib/apt/lists/archive.neon.kde.org_user_dists_bionic_InRelease;
then appstreamcli refresh-cache > /dev/null; fi', E:Sub-process
returned an error code

If I try to give the command directly I have this error:

#appstreamcli refresh-cache
(appstreamcli:9327): GLib-CRITICAL **: g_variant_builder_end: assertion '!GVSB(builder)->uniform_item_types || GVSB(builder)->prev_item_type != NULL || g_variant_type_is_definite (GVSB(builder)->type)' failed
(appstreamcli:9327): GLib-CRITICAL **: g_variant_new_variant: assertion 'value != NULL' failed
(appstreamcli:9327): GLib-ERROR **: g_variant_new_parsed: 11-13:invalid GVariant format string
Trace/breakpoint trap

Did someone had this problem and found a solution?

Thank you very much for your help!
baxeico
Registered Member
Posts
9
Karma
0
After finding that this is a known bug in appstreamcli:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=906544

and reading that appstreamcli command is not strictly necessary for the upgrade I solved by renaming /usr/bin/appstreamcli:

sudo mv /usr/bin/appstreamcli /usr/bin/appstreamcli.bak

than I restarted the upgrade with do-release-upgrade. And the error was not shown any more.
I'm writing this answer in the case that someone else will encounter the same error and will come here in search of a solution.
User avatar fabiom
Registered Member
Posts
7
Karma
0
OS
upgrading neon 16.04 LTS to neon 18.04 LTS problems not good. I search KDE neon get download. Again KDE neon 18.04 LTS install set done my work fine If you don't need upgrading you get the search KDE neon LTS when new Version

 
Reply to topic

Bookmarks



Who is online

Registered users: arnest, Baidu [Spider], Bing [Bot], Google [Bot], llarruda, Svanto24, thunder422