Reply to topic

has anyone installed amarok?

gfielding
Registered Member
Posts
123
Karma
0
OS

has anyone installed amarok?

Sat Sep 28, 2019 8:55 am
Amarok was working fine on my system until recently.

There is now no sound backend shown (amarok / settings / configure amarok / playback / configure phonon / backend) although the gstreamer and vlc backend packages are still installed. I suspect that some recent system updates has caused the problem.

Is it just me?

Thanks
User avatar claydoh
Registered Member
Posts
510
Karma
5
OS

Re: has anyone installed amarok?

Sat Sep 28, 2019 3:57 pm
It does not work in Neon at least, possibly Kubuntu 18.04 as well. My guess is that it is due to Amarok being KDE 4 (and Qt 4), and the Ubuntu 18.04 package that is available may be too old for our Plasma. Basically, bit rot may be setting in. I think being KDE 4, it needs KDE 4 specific systems, and newer Plasma things probably broke whatever compatibility with the long-unsupported KDE 4/Qt 4 that was left.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar acheronuk
KDE Developer
Posts
104
Karma
2

Re: has anyone installed amarok?

Sat Sep 28, 2019 4:08 pm
Qt4 phonon support was removed in the latest Phonon version, which is now in Neon. Only Qt5 support remains.
gfielding
Registered Member
Posts
123
Karma
0
OS

Re: has anyone installed amarok?

Sun Sep 29, 2019 7:50 pm
Thanks very much for posting.

Rolling back the package phonon-backend-vlc to the previous version re-stored sound to amarok. Perhaps time to move to clementine though.
User avatar waynes
Registered Member
Posts
88
Karma
0

Re: has anyone installed amarok?

Mon Sep 30, 2019 2:46 pm
If You like Clementine, take a look at Strawberry. It's based on Clementine as you will see after install, but seems to be more actively developed. Works great on my system.
https://www.strawberrymusicplayer.org/
gfielding
Registered Member
Posts
123
Karma
0
OS

Re: has anyone installed amarok?

Mon Sep 30, 2019 3:38 pm
Thanks I will give Strawberry a go too.
nicolaf
Registered Member
Posts
3
Karma
0

Re: has anyone installed amarok?

Mon Sep 30, 2019 7:05 pm
Hi, I'm here for the same problem.
Thanks you for the advice about Strawberry, I never heard of it and it looks interesting

Another promising player is Elisa, it is even probably available in your distro repository:
https://community.kde.org/Elisa
But for now I'm using Clementine because with Elisa I cannot make it see the music I have on a NFS network share :< .

I will follow this thread for any positive developments.
therealsteelskin
Registered Member
Posts
7
Karma
0
OS

Re: has anyone installed amarok?

Thu Oct 31, 2019 10:24 am
I have the same problem with Amarok in KDE Neon 5.17.2, however it looks like Amarok are working on the qt5 update. In the meantime another music player to try is Pragha, it's a light weight music player written in C. It doesn't have all the bells and whistles as does Amarok however I installed it from the repositories and it worked with the absolute minimum of fuss. The only thing I had to do was point it to where my music is so it could index the collection. https://pragha-music-player.github.io/

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], chitholian, Google [Bot], kde-mikedee, Majestic-12 [Bot], Sogou [Bot]