Reply to topic

Not saved option "Holidays" and "Astronomical Events" after

makukhin
Registered Member
Posts
9
Karma
0
OS
Hi!

Not saved option ON "Holidays" and "Astronomical Events" after power off / reboot PC.

Code: Select all
Operating System: KDE neon 5.17
KDE Plasma Version: 5.17.2
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Kernel Version: 5.0.0-32-generic
OS Type: 64-bit
Processors: 4 × AMD Ryzen 3 2200G with Radeon Vega Graphics
Memory: 13,6 ГиБ
makukhin
Registered Member
Posts
9
Karma
0
OS
What configuration file to edit for applets "Holidays" and "Astronomical Events" ?
thunder422
Registered Member
Posts
60
Karma
0
OS
Why mess with configuration files? Right-click on the clock, select Configure Digital Clock... and go to the Calendar page - those options are right there.

By the way, if you want to risk messing things up, the configuration file is at ~/.config/plasma-org.kde.plasma.desktop-appletsrc under the [Containments][2][Applets][8][Configuration][Appearance] section, the enabledCalendarPlugins parameter. With both of those options enabled, it looks like:
Code: Select all
enabledCalendarPlugins=/usr/lib/x86_64-linux-gnu/qt5/plugins/plasmacalendarplugins/astronomicalevents.so,/usr/lib/x86_64-linux-gnu/qt5/plugins/plasmacalendarplugins/holidaysevents.so


Currently using KDE Neon 5.18.5 and 5.17.5 (run Windows 10 in a VM); migrated from Linux Mint 17.3
makukhin
Registered Member
Posts
9
Karma
0
OS
thunder422 wrote:Why mess with configuration files? Right-click on the clock, select Configure Digital Clock... and go to the Calendar page - those options are right there.
After rebooting the PC, the settings are reset.
User avatar Mamarok
Manager
Posts
4743
Karma
12
OS
makukhin wrote:
thunder422 wrote:Why mess with configuration files? Right-click on the clock, select Configure Digital Clock... and go to the Calendar page - those options are right there.
After rebooting the PC, the settings are reset.

Is the option to save the session settings enabled? In System Settings -> Workspace -> Startup & Shutdown -> Desktop Session, make sure to enable the option "restore previous session".


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-40
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
makukhin
Registered Member
Posts
9
Karma
0
OS
Mamarok wrote:
makukhin wrote:
thunder422 wrote:Why mess with configuration files? Right-click on the clock, select Configure Digital Clock... and go to the Calendar page - those options are right there.
After rebooting the PC, the settings are reset.

Is the option to save the session settings enabled? In System Settings -> Workspace -> Startup & Shutdown -> Desktop Session, make sure to enable the option "restore previous session".


Image
acrux
Registered Member
Posts
26
Karma
1
OS
makukhin wrote: After rebooting the PC, the settings are reset.


Can not confirm here - works as expected. And no need to enable the option "restore previous session" here, I'm using "Start with empty session".
So my answer is not very helpful for solving your problem. It looks like your home directory is on a temporary media and every new restart creates new session with default settings...
makukhin
Registered Member
Posts
9
Karma
0
OS

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], claydoh, Google [Bot], idriskalp, Section_8, Sogou [Bot], visone