Reply to topic

New update failed

mossbliss
Registered Member
Posts
12
Karma
0

New update failed

Thu Dec 26, 2019 6:31 pm
I logged into my KDE neon ... was told there was an update to 5.13 ... I told it to install and was never asked for my password, then was told it aborted. The Update icon still shows. Rinsed and repeated several times. Tried installing via Terminal sudo apt update and was told there are no updates, but the icon still shows and Discover still shows it waiting to be updated.

I have a screenshot but do not see how to upload it here.
visone
Registered Member
Posts
32
Karma
0
OS

Re: New update failed

Thu Dec 26, 2019 9:23 pm
Hi!
You can try sudo pkcon update && sudo pkcon refresh
User avatar claydoh
Registered Member
Posts
630
Karma
5
OS

Re: New update failed

Fri Dec 27, 2019 1:46 am
It well could be a snap or flatpak that needs updating, which is not handled by apt/pkcon, but is handled by Discover and the updater.
I have seen this a couple of times, a problem with a flatpak that very likely has nothing to do with Plasma or Neon.

Try this to see:
[code]flatpak update[/code]


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
mossbliss
Registered Member
Posts
12
Karma
0

Re: New update failed

Fri Dec 27, 2019 3:36 am
claydoh wrote:It well could be a snap or flatpak that needs updating, which is not handled by apt/pkcon, but is handled by Discover and the updater.
I have seen this a couple of times, a problem with a flatpak that very likely has nothing to do with Plasma or Neon.

Try this to see:
Code: Select all
flatpak update


No, I don't think the item "KDE Application Platform"would be a flatpak...
mossbliss
Registered Member
Posts
12
Karma
0

Re: New update failed

Fri Dec 27, 2019 3:39 am
visone wrote:Hi!
You can try sudo pkcon update && sudo pkcon refresh


Thanks for the attempt. I tried this and got no relief.

I will point out that I hve KDE neon on two computers, and this is only happening on one of them. (A System76 Kudu 3; the one which does not have the problem is a System76 Galago Pro 2). Main difference between the two machines is that the Kudu has a new SSD in it, the Galago Pro was left with its original drives.
User avatar claydoh
Registered Member
Posts
630
Karma
5
OS

Re: New update failed

Fri Dec 27, 2019 6:24 pm
mossbliss wrote:
claydoh wrote:It well could be a snap or flatpak that needs updating, which is not handled by apt/pkcon, but is handled by Discover and the updater.
I have seen this a couple of times, a problem with a flatpak that very likely has nothing to do with Plasma or Neon.

Try this to see:
Code: Select all
flatpak update


No, I don't think the item "KDE Application Platform"would be a flatpak...

Actually, it very likely is. Flatpaks for KDE applications use a common runtime that is installed, to keep package sizes down and reduce . Snaps do something similar as well.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar kdeoldster
Registered Member
Posts
54
Karma
0
OS

Re: New update failed

Fri Dec 27, 2019 8:37 pm
I have the same problem and although flatpak did indeed update in Konsole I still have the issue of Discover showing update available to KDE Application Platform 15.3 but aborts operation and fails to update and clear the update icon. Just a minor annoyance and not sure if I should report it to flatpak devs.
mossbliss
Registered Member
Posts
12
Karma
0

Re: New update failed

Sat Dec 28, 2019 3:24 am
claydoh wrote:
mossbliss wrote:
claydoh wrote:It well could be a snap or flatpak that needs updating, which is not handled by apt/pkcon, but is handled by Discover and the updater.
I have seen this a couple of times, a problem with a flatpak that very likely has nothing to do with Plasma or Neon.

Try this to see:
Code: Select all
flatpak update


No, I don't think the item "KDE Application Platform"would be a flatpak...

Actually, it very likely is. Flatpaks for KDE applications use a common runtime that is installed, to keep package sizes down and reduce . Snaps do something similar as well.


Well, it is, but that didn't work anyhow. I tried it twice.

[email protected]:~$ sudo flatpak update
[sudo] password for zaivala:
Looking for updates…


ID Branch Op Remote Download
1. [✗] org.freedesktop.Platform.openh264 19.08 i flathub 593.6 kB / 593.4 kB

Warning: org.freedesktop.Platform.openh264 not installed
Installation complete.
[email protected]:~$ sudo flatpak update
Looking for updates…


ID Branch Op Remote Download
1. [✗] org.freedesktop.Platform.openh264 19.08 i flathub 593.6 kB / 593.4 kB

Warning: org.freedesktop.Platform.openh264 not installed
Installation complete.
[email protected]:~$

=============
Both times it said "Installation complete." Neither time did it actually complete the installation, and my update icon is still active.
kde-iggy
Registered Member
Posts
1
Karma
0

Re: New update failed

Thu Jan 09, 2020 10:31 pm
I had the same issue. It seems to be a dependency problem between flatpaks. I had to fiddle around a little and I am not sure of the easiest solution. This should probably solve the issue:
Code: Select all
flatpak install runtime/org.freedesktop.Platform/x86_64/19.08

just Y everything, then:
Code: Select all
flatpak install org.freedesktop.Platform.openh264

Y everything. And just to be sure:
Code: Select all
flatpak install org.kde.Platform

Choose the latest version (5.13)
The system should be updated and the discovery notification gone.

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], arkascha, Baidu [Spider], Bing [Bot], gfielding, Google [Bot], ineuw, jbeeckaert, jmacleod, sandro4912, Sogou [Bot], Yahoo [Bot]