Reply to topic

How do I update Wine on Neon 18.04 Bionic

kde-bertil
Registered Member
Posts
10
Karma
0
I followed the https://wiki.winehq.org/Ubuntu and it seemed to work.

However, I am getting dependency errors when updating:

Code: Select all
 sudo pkcon refresh && sudo pkcon update
[sudo] password for qqq:
Refreshing cache              [=========================]         
Loading cache                 [=========================]         
Refreshing software list      [=========================]         
Downloading packages          [=========================]         
Running                       [=========================]         
Finished                      [=========================]         
 Disabled                             http://dl.google.com/linux/chrome/deb stable InRelease
 Enabled                              http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic InRelease
 Enabled                              http://download.virtualbox.org/virtualbox/debian bionic InRelease
 Enabled                              http://se.archive.ubuntu.com/ubuntu bionic InRelease
 Enabled                              http://se.archive.ubuntu.com/ubuntu bionic-updates InRelease
 Enabled                              http://se.archive.ubuntu.com/ubuntu bionic-backports InRelease
 Enabled                              http://dl.google.com/linux/chrome/deb stable Release
 Enabled                              https://dl.winehq.org/wine-builds/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/linuxuprising/apps/ubuntu bionic InRelease
 Enabled                              http://security.ubuntu.com/ubuntu bionic-security InRelease
 Enabled                              http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease
 Enabled                              http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic InRelease
Getting updates               [=========================]         
Finished                      [=========================]         
Loading cache                 [=========================]         
Testing changes               [=========================]         
Finished                      [=========================]         
Fatal error: The following packages have unmet dependencies:
  wine-stable: Depends: wine-stable-i386 (= 5.0.0~bionic)
               Depends: wine-stable-amd64 (= 5.0.0~bionic) but 4.0.3~bionic is to be installed


and:

Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://se.archive.ubuntu.com/ubuntu bionic InRelease                                                                                                                         
Hit:3 http://se.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                                                                         
Hit:4 http://download.virtualbox.org/virtualbox/debian bionic InRelease                                                                                                                                   
Hit:5 http://se.archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                                                                                       
Hit:6 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                                                 
Hit:7 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                                                                                   
Hit:8 http://security.ubuntu.com/ubuntu bionic-security InRelease                                                   
Hit:9 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic InRelease     
Get:10 http://archive.neon.kde.org/user bionic InRelease [131 kB]       
Hit:11 http://ppa.launchpad.net/linuxuprising/apps/ubuntu bionic InRelease                                     
Hit:12 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease
Hit:13 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic InRelease
Fetched 131 kB in 2s (73,5 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) wine-stable:amd64 < 4.0.3~bionic -> 5.0.0~bionic @ii umU Ib >
Broken wine-stable:amd64 Depends on wine-stable-i386:amd64 < none @un H > (= 5.0.0~bionic)
  Considering wine-stable-i386:i386 0 as a solution to wine-stable:amd64 1
  Holding Back wine-stable:amd64 rather than change wine-stable-i386:amd64
Investigating (0) winehq-stable:amd64 < 4.0.3~bionic -> 5.0.0~bionic @ii umU Ib >
Broken winehq-stable:amd64 Depends on wine-stable:amd64 < 4.0.3~bionic | 5.0.0~bionic @ii umH > (= 5.0.0~bionic)
  Considering wine-stable:amd64 1 as a solution to winehq-stable:amd64 0
  Holding Back winehq-stable:amd64 rather than change wine-stable:amd64
 Try to Re-Instate (1) wine-stable:amd64
 Try to Re-Instate (1) winehq-stable:amd64
Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  xserver-xorg-video-intel-arbiter xserver-xorg-video-intel-native-modesetting
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
  wine-stable winehq-stable
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.


anyone solved this?

Thanks
hsnnsnc
Registered Member
Posts
29
Karma
0
OS
Hello,

I have the same problem, is there a solution? Or will we wait for Ubuntu 20.04?
User avatar apachelogger
KDE Developer
Posts
508
Karma
5
OS
kde-bertil
Registered Member
Posts
10
Karma
0
Ok, so trying:

Ubuntu 18.04:
Download the Release.key. Navigate to the directory you downloaded it to and install it with

sudo apt-key add Release.key

Add the repository:

sudo apt-add-repository 'deb https://download.opensuse.org/repositor ... ntu_18.04/ ./'

Then update:

sudo apt-get update && sudo apt-get dist-upgrade

~$ wine --version
wine-5.0

so far so good! And my app works!
hsnnsnc
Registered Member
Posts
29
Karma
0
OS
apachelogger wrote:https://forum.winehq.org/viewtopic.php?f=8&t=32192


Hello,

This solved the problem. Thank you.
kde-bertil
Registered Member
Posts
10
Karma
0
Wine 5.0 did not work as well as 4.03 for me. So this is how I downgraded, in case someone else wants to do it to:

Code: Select all
sudo apt install winehq-stable=4.0.3~bionic wine-stable=4.0.3~bionic wine-stable-amd64=4.0.3~bionic wine-stable-i386=4.0.3~bionic
sudo apt-mark hold wine-stable wine-stable-amd64 wine-stable-i386

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], berndmj, Bing [Bot], Google [Bot], hensem, robgriff444, Section_8, Sogou [Bot], valaquarus