Reply to topic

Boot freeze after installing proprietary Nvidia driver

irvayl
Registered Member
Posts
3
Karma
0
OS
Hello, I am new to linux and KDE. I just tried installing NVIDIA proprietary driver, and reboot. After I reboot, KDE neon would display grub as usual and I chose KDE neon, after that the loading appear and then my laptop manufacturer's name is showed and stuck right there, nothing happens, SDDM doesn't appear. My questions are why is this happening ? What should I do then if I want to install NVIDIA driver ? Is it true that that happens because the driver is not compatible with the kernel ? because I notice that KDE neon did a firmware update recently. Please help me, thanks in advance.

Some info :
OS : KDE neon User Edition 5.18 64bit
Kernel : 5.3.0-42-generic
CPU : Intel i5-4210U
GPU : NVIDIA Geforce 920M
Driver that I've tried : nvidia-390 and nvidia-440

Please let me know if I have to provide another information, thank you.
sorry for the broken english too.

Last edited by irvayl on Thu Mar 19, 2020 4:31 pm, edited 1 time in total.
hsnnsnc
Registered Member
Posts
29
Karma
0
OS
Hello,
First you need to add the "Proprietary GPU Drivers" repository.

Respectively:

sudo add-apt-repository ppa: graphics-drivers / ppa
pkcon refresh
ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
sudo reboot
sudo nvidia-xconfig
nvidia-settings

To prevent screen tearing; Click on NVIDIA X Server Settings, X Server Display Configuration, Advanced, Force Composition Pipeline. Finally; Save X Configuration File "/etc/X11/xorg.conf" file should be saved.

I hope it helped.
irvayl
Registered Member
Posts
3
Karma
0
OS
hsnnsnc wrote:Hello,
First you need to add the "Proprietary GPU Drivers" repository.

Respectively:

sudo add-apt-repository ppa: graphics-drivers / ppa
pkcon refresh
ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
sudo reboot
sudo nvidia-xconfig
nvidia-settings

To prevent screen tearing; Click on NVIDIA X Server Settings, X Server Display Configuration, Advanced, Force Composition Pipeline. Finally; Save X Configuration File "/etc/X11/xorg.conf" file should be saved.

I hope it helped.


Thanks for your answer. I did add the ppa and installing the driver using step 1-4 before, and when I reboot (manually), kde freeze on boot. I never tried rebooting using sudo reboot, do i really need to do it after installing nvidia driver ? Also, last time I installed nvidia driver, I don't have the force composition pipeline option, what should i do ? Thanks in advance.
hsnnsnc
Registered Member
Posts
29
Karma
0
OS
Hello,
You must run this command. Your Xorg.conf file must be created by Nvidia.

sudo restart
sudo nvidia-xconfig

Perhaps to make things easier, a video on the subject will do your work:
https://www.youtube.com/watch?v=lqfrnunw748
irvayl
Registered Member
Posts
3
Karma
0
OS
hsnnsnc wrote:Hello,
You must run this command. Your Xorg.conf file must be created by Nvidia.

sudo restart
sudo nvidia-xconfig

Perhaps to make things easier, a video on the subject will do your work:
https://www.youtube.com/watch?v=lqfrnunw748


Thank you for your answer, I have tried your suggestion, and as I expected, after reboot my kde neon would display my laptop manufacturer's name and freeze/stuck and I've to clean install it again. Perharps I should rearrange my question to make my question more clear.
BulletDust
Registered Member
Posts
13
Karma
0
My guess is that you're using a laptop with some form of switchable graphics solution, as installing drivers via the PPA method on a desktop with only one GPU should work perfectly.

If you can boot to a TTY use sudo apt purge Nvidia* followed by sudo apt autoremove. Once this is done enter sudo add-apt-repository ppa:graphics-drivers/ppa followed by sudo apt install nvidia-driver-440 assuming that Nvidia's 440.64 driver supports your particular Nvidia GPU.
stegerpl
Registered Member
Posts
4
Karma
0
Hi
just have been running in something comparable - in my case it figured out that the nvidia-driver (340) was not compatible anymore with xorg-server and in addition my setup was 64-bit and the nvidia-drivers are 32-bit.
Check if this might be the same with your installation.
abdullah
Registered Member
Posts
1
Karma
0
install via tty. If I install via Desktop, at boot time it will be frezee. But it's different if via tty

sudo add-apt-repository ppa: graphics-drivers / ppa
sudo apt update
ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
sudo nvidia-xconfig
sudo reboot
didiloy
Registered Member
Posts
1
Karma
0
Hello I have the exact same problem but I can't boot at all I'm stuck at the manufacturer logo each Times what can I do ?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], carlitosh, Google [Bot], robbystephenson, schellong, Yahoo [Bot]