Reply to topic

KDEneon not is compatible with ubuntu ppa for FreeCAD

dacorsa
Registered Member
Posts
15
Karma
0
Goodmorning,

seems KDEneon not is compatible with ppa repository Freecad


When try to install manually package the output is:

The output is:

Code: Select all
apt source -b freecad-daily
Reading package lists... Done
NOTICE: 'freecad-daily' packaging is maintained in the 'Git' version control system at:
https://salsa.debian.org/science-team/freecad.git
Please use:
git clone https://salsa.debian.org/science-team/freecad.git
to retrieve the latest (possibly unreleased) updates to the package.
Need to get 208 MB of source archives.
Get:1 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu bionic/main freecad-daily 0.19~pre2~202003181352~ubuntu18.04.1 (tar) [208 MB]
Get:2 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu bionic/main freecad-daily 0.19~pre2~202003181352~ubuntu18.04.1 (dsc) [2638 B]                           
Fetched 208 MB in 17s (12.1 MB/s)                                                                                                                                               
dpkg-source: info: extracting freecad-daily in freecad-daily-0.19~pre2~202003181352~ubuntu18.04.1
dpkg-source: info: unpacking freecad-daily_0.19~pre2~202003181352~ubuntu18.04.1.tar.xz
dpkg-buildpackage: info: source package freecad-daily
dpkg-buildpackage: info: source version 0.19~pre2~202003181352~ubuntu18.04.1
dpkg-buildpackage: info: source distribution bionic
dpkg-buildpackage: info: source changed by Launchpad Package Builder <[email protected]>
dpkg-buildpackage: info: host architecture amd64
 dpkg-source --before-build freecad-daily-0.19~pre2~202003181352~ubuntu18.04.1
dpkg-checkbuilddeps: error: Unmet build dependencies: dh-exec libboost-date-time-dev libboost-filesystem-dev libboost-graph-dev libboost-iostreams-dev libboost-program-options-dev libboost-regex-dev libboost-serialization-dev libboost-signals-dev libboost-thread-dev libcoin-dev libdouble-conversion-dev liblz4-dev libglew-dev libopencv-dev | libcv-dev libeigen3-dev (>= 3.3~beta1) libgts-dev libkdtree++-dev libmedc-dev libmetis-dev libocct-data-exchange-dev libocct-ocaf-dev libocct-visualization-dev libproj-dev libpyside2-dev libqt5webkit5-dev libqt5xmlpatterns5-dev libshiboken2-dev libspnav-dev libvtk7-dev libxerces-c-dev libzipios++-dev netgen-headers occt-draw pybind11-dev pyside2-tools python-pyside2.qtcore python-pyside2.qtgui python-pyside2.qtsvg python-pyside2.qtuitools python-pyside2.qtwidgets python-pyside2.qtxml python3-pyside2.qtcore python3-pyside2.qtgui python3-pyside2.qtsvg python3-pyside2.qtuitools python3-pyside2.qtwidgets python3-pyside2.qtxml
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
W: Download is performed unsandboxed as root as file 'freecad-daily_0.19~pre2~202003181352~ubuntu18.04.1.tar.xz' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Build command 'cd freecad-daily-0.19~pre2~202003181352~ubuntu18.04.1 && dpkg-buildpackage -b -uc' failed.


If a try to install manually:

Code: Select all
09:39:27 [email protected] /app/lynis master# installa dh-exec libboost-date-time-dev libboost-filesystem-dev libboost-graph-dev libboost-iostreams-dev libboost-program-options-dev libboost-regex-dev libboost-serialization-dev libboost-signals-dev libboost-thread-dev libcoin-dev libdouble-conversion-dev liblz4-dev libglew-dev libopencv-dev libopencv-dev libeigen3-dev libgts-dev libkdtree++-dev libmedc-dev libmetis-dev libocct-data-exchange-dev libocct-ocaf-dev libocct-visualization-dev libproj-dev libpyside2-dev libqt5webkit5-dev libqt5xmlpatterns5-dev libshiboken2-dev libspnav-dev libvtk7-dev libxerces-c-dev libzipios++-dev netgen-headers occt-draw pybind11-dev pyside2-tools python-pyside2.qtcore python-pyside2.qtgui python-pyside2.qtsvg python-pyside2.qtuitools python-pyside2.qtwidgets python-pyside2.qtxml python3-pyside2.qtcore python3-pyside2.qtgui python3-pyside2.qtsvg python3-pyside2.qtuitools python3-pyside2.qtwidgets python3-pyside2.qtxml
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Starting pkgProblemResolver with broken count: 13
Starting 2 pkgProblemResolver with broken count: 13
Investigating (0) python-pyside2.qtcore:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python-pyside2.qtcore:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtcore:amd64 9999
    Reinst Failed early because of qtdeclarative-abi-5-9-5:amd64
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtcore:amd64 9999
Investigating (0) python3-pyside2.qtuitools:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python3-pyside2.qtuitools:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtuitools:amd64 9999
    Reinst Failed early because of qtdeclarative-abi-5-9-5:amd64
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtuitools:amd64 9999
Investigating (0) python3-pyside2.qtgui:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python3-pyside2.qtgui:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtgui:amd64 9999
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtgui:amd64 9999
Investigating (0) python-pyside2.qtsvg:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python-pyside2.qtsvg:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtsvg:amd64 9999
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtsvg:amd64 9999
Investigating (0) python-pyside2.qtuitools:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python-pyside2.qtuitools:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtuitools:amd64 9999
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtuitools:amd64 9999
Investigating (0) python-pyside2.qtgui:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python-pyside2.qtgui:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtgui:amd64 9999
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtgui:amd64 9999
Investigating (0) python-pyside2.qtwidgets:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python-pyside2.qtwidgets:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtwidgets:amd64 9999
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtwidgets:amd64 9999
Investigating (0) libpyside2-dev:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken libpyside2-dev:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH > (= 5.11.2-0ppa2~ubuntu18.04)
  Considering libpyside2-5.11:amd64 6 as a solution to libpyside2-dev:amd64 9999
  Considering libpyside2-5.11:amd64 6 as a solution to libpyside2-dev:amd64 9999
Broken libpyside2-dev:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH > (= 5.11.2-0ppa2~ubuntu18.04)
  Considering libpyside2-py3-5.11:amd64 6 as a solution to libpyside2-dev:amd64 9999
  Considering libpyside2-py3-5.11:amd64 6 as a solution to libpyside2-dev:amd64 9999
Investigating (0) python3-pyside2.qtwidgets:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python3-pyside2.qtwidgets:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtwidgets:amd64 9999
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtwidgets:amd64 9999
Investigating (0) python3-pyside2.qtsvg:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python3-pyside2.qtsvg:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtsvg:amd64 9999
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtsvg:amd64 9999
Investigating (0) python3-pyside2.qtxml:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python3-pyside2.qtxml:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtxml:amd64 9999
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtxml:amd64 9999
Investigating (0) python3-pyside2.qtcore:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python3-pyside2.qtcore:amd64 Dipende on libpyside2-py3-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtcore:amd64 9999
  Considering libpyside2-py3-5.11:amd64 6 as a solution to python3-pyside2.qtcore:amd64 9999
Investigating (0) python-pyside2.qtxml:amd64 < none -> 5.11.2-0ppa2~ubuntu18.04 @un puN Ib >
Broken python-pyside2.qtxml:amd64 Dipende on libpyside2-5.11:amd64 < none | 5.11.2-0ppa2~ubuntu18.04 @un uH >
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtxml:amd64 9999
  Considering libpyside2-5.11:amd64 6 as a solution to python-pyside2.qtxml:amd64 9999
Done
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libpyside2-dev : Dipende: libpyside2-5.11 (= 5.11.2-0ppa2~ubuntu18.04) ma non sta per essere installato
                  Dipende: libpyside2-py3-5.11 (= 5.11.2-0ppa2~ubuntu18.04) ma non sta per essere installato
 python-pyside2.qtcore : Dipende: libpyside2-5.11 ma non sta per essere installato
 python-pyside2.qtgui : Dipende: libpyside2-5.11 ma non sta per essere installato
 python-pyside2.qtsvg : Dipende: libpyside2-5.11 ma non sta per essere installato
 python-pyside2.qtuitools : Dipende: libpyside2-5.11 ma non sta per essere installato
 python-pyside2.qtwidgets : Dipende: libpyside2-5.11 ma non sta per essere installato
 python-pyside2.qtxml : Dipende: libpyside2-5.11 ma non sta per essere installato
 python3-pyside2.qtcore : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
 python3-pyside2.qtgui : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
 python3-pyside2.qtsvg : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
 python3-pyside2.qtuitools : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
 python3-pyside2.qtwidgets : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
 python3-pyside2.qtxml : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


Seems impossible....i don't know, maybe the following packages is different or customized by KDEneon and not compatible:

libpyside2-dev : Dipende: libpyside2-5.11 (= 5.11.2-0ppa2~ubuntu18.04) ma non sta per essere installato
Dipende: libpyside2-py3-5.11 (= 5.11.2-0ppa2~ubuntu18.04) ma non sta per essere installato
python-pyside2.qtcore : Dipende: libpyside2-5.11 ma non sta per essere installato
python-pyside2.qtgui : Dipende: libpyside2-5.11 ma non sta per essere installato
python-pyside2.qtsvg : Dipende: libpyside2-5.11 ma non sta per essere installato
python-pyside2.qtuitools : Dipende: libpyside2-5.11 ma non sta per essere installato
python-pyside2.qtwidgets : Dipende: libpyside2-5.11 ma non sta per essere installato
python-pyside2.qtxml : Dipende: libpyside2-5.11 ma non sta per essere installato
python3-pyside2.qtcore : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
python3-pyside2.qtgui : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
python3-pyside2.qtsvg : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
python3-pyside2.qtuitools : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
python3-pyside2.qtwidgets : Dipende: libpyside2-py3-5.11 ma non sta per essere installato
python3-pyside2.qtxml : Dipende: libpyside2-py3-5.11 ma non sta per essere installato


thanks for all
User avatar claydoh
Registered Member
Posts
546
Karma
5
OS
viewtopic.php?f=309&t=153797

FreeCAD provide an appimage on their website.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar fabiom
Registered Member
Posts
10
Karma
0
OS
Or FreeCAD flathub you try

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], farid, Google [Bot], Majestic-12 [Bot], MSN [Bot], Sogou [Bot], Yahoo [Bot]