Reply to topic

A little help

npdan
Registered Member
Posts
4
Karma
0

A little help

Tue Apr 14, 2020 9:58 am
Its not a big issue but allmost every version of linux and distro i run has this issue. Since KDE neon is my daily driver i am going to ask here.
I have a laptop with an m2 ssd running the os and a sata 3 internal secondary hard drive for my files. While the OS detects and mounts the drive every time corectly its content is not accesable until i explore it with any file browser, then its accesable from any app.
By default at startup it shows a disk with a red X and if i open it, everything is ok and working, but if i run a program that should read a file from the hard drive it will give an error saying there is no drive found, once i acces it with the file browser any program will be able to detect the drive and find files as intended.

I`ve checked that tht drive mounts automatically on boot and everything is ok. Its just a small incenvenience that i have to acces the drive first to open any saved file on the drive by programs.
Any tips?
thunder422
Registered Member
Posts
60
Karma
0
OS

Re: A little help

Tue Apr 14, 2020 2:38 pm
Whats the /etc/fstab entry look like for that drive?


Currently using KDE Neon 5.18.5 and 5.17.5 (run Windows 10 in a VM); migrated from Linux Mint 17.3
npdan
Registered Member
Posts
4
Karma
0

Re: A little help

Tue Apr 14, 2020 6:34 pm
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/nvme0n1p6 during installation
UUID=395fc018-9d84-4098-9496-c38f588b6cb6 / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/nvme0n1p3 during installation
UUID=762A-DD70 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0
thunder422
Registered Member
Posts
60
Karma
0
OS

Re: A little help  Topic is solved

Wed Apr 15, 2020 1:25 pm
Some comments and observations that may or not be of any help. I have two systems with KDE Neon both with multiple drives and partitions. I haven't seen the issue that you are having. On one system, the last parameter "<pass>" (determines the order used by fsck during boot), are all set to 1, but on the other system, only the root mount is 1, the others are 2. The later seems the logical choice - check the root drive first, then check the others, but the other system doesn't have any issues during boot (other than it takes a while as I have over a dozen mounts).

The next observation is the "<options>" parameter. I don't have any vfat mounts, but one system has a few ntfs mounts, which look like:

UUID=XXXXX /xxxx ntfs defaults,umask=022,uid=1000,gid=1000 0 0

Looks like I wanted these partitions owned by me and only writable by me, but readable by group and all. You have umask=077, which means only accessible by you, which is acceptable too. It's been a long time since I came up with the above and I don't remember why the uid/gid seem to be necessary also (I came up with these when I first transitioned from Windows XP to Linux via Mint 10 KDE). The other big difference is yours lacks 'defaults', but this may be the default and it may not actually be necessary.

Have you tried putting the mount directly off of root instead of a sub-directory of a directory? I'm not sure this matters. I assume you have a directory efi in /boot? (Probably wouldn't work if you didn't.) On my systems, I always had to create the directories of the mount points or they wouldn't mount.

One last suggestion I can think of. Install the KDE Partition Manager. Right after booting, before bringing up a file browser on the second drive, open up KDE Partition Manager, does it show the drive as mounted (will have a lock icon if mounted)?

And to fully understand your problem, upon boot, in a terminal (Konsole), doing 'ls /boot/efi' shows you nothing until you open the drive with a file browser (by which I assume you are talking about Dolphin)? If it doesn't work until you use Dolphin, it sounds to me that it is not actually being mounted during boot, and Dolphin is mounting it for you. This is why I suspect something either wrong with your fstab entry, or with the sub-directory /boot/efi.


Currently using KDE Neon 5.18.5 and 5.17.5 (run Windows 10 in a VM); migrated from Linux Mint 17.3
npdan
Registered Member
Posts
4
Karma
0

Re: A little help

Wed Apr 15, 2020 4:51 pm
https://imgur.com/a/lhVK4yz

thanks for so mutch usefull info, that gave me the ideea to check the boot automount settings, and it appears that my hard drive is considered like a usb device and it doesnt auto mount even if auto mounting is checked in the settings/removable storage/removable devices. Upon boot the drive is being detected and not mounted and indeed Dolphin does it for me.

A quick google search gave me a working solution on how to auto mount the device

https://www.linuxbabe.com/desktop-linux ... s-on-linux

works like a charm thanks @thunder422, i have allot to learn still.
bisousbass
Registered Member
Posts
7
Karma
0

Re: A little help

Thu Apr 16, 2020 8:52 am
npdan wrote:# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/nvme0n1p6 during installation
UUID=395fc018-9d84-4098-9496-c38f588b6cb6 / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/nvme0n1p3 during installation
UUID=762A-DD70 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0


thanks!
User avatar robertsm
Registered Member
Posts
4
Karma
0

Re: A little help

Sun May 17, 2020 8:40 pm
Thank you fo sharing!

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dbergstein, Don B. Cilly, dualkem, farid, Google [Bot], Ico_dY, ipwizard, koffeinfriedhof, shurato, Sogou [Bot]