Reply to topic

Update checking overwhelming old laptop.

jedipadawan
Registered Member
Posts
17
Karma
0
I am using this five year old minimal spec n2840 laptop/netbook and it is hardly fast but it is usable UNTIL packagekit starts checking for updates. When it kicks off the machine effectively freezes. If I do not have any apps running the pain passes in about five minutes but, if I am running a browser or Libreoffice my machine is unusable for something like fifteen minutes! And I use this machine for real work in my tuition business and suddenly having the machine freeze when I am about to make student notes or play a student media material is now a serious pain.

I can handle this once a day but I can hit this several times a day. There must be a way in which I can reduce the number of times packagekit (or whatever process Neon uses for checking for updates) runs? Just that would help me a lot. Or is there a way to reduce the load when it does run? Note: I have optimised Plasma as much as possible on 'old faithful' turning off desktop effects, compositing, reducing start up processes and the like so I have done my best here.

Thanks in advance.
User avatar Mamarok
Manager
Posts
4740
Karma
12
OS
Define minimal specs? The bottleneck is almost always the RAM, and insufficient SWAP space.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-40
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
jedipadawan
Registered Member
Posts
17
Karma
0
Mamarok wrote:Define minimal specs? The bottleneck is almost always the RAM, and insufficient SWAP space.


Fair question and thanks for getting back to me.

Specs:

ASUS X200M n2840 from 2015, effectively a netbook.
2GB RAM - no expansion slots! It was a gift from my wife and has serious sentimental value.
1TB HDD split into three partitions with 3.81GB (net) SWAP partition which should be enough.

I have also installed zram to take off some of the pressure of infamous Linux full RAM bug that is *finally* being investigated! That has helped the 'freeze to hard reset' problems I had.

And, as I say, I have shaved off as much on start up that I can. Next to no widgets installed.

Yes, the RAM will be the issue and I may have to deal with a 15 minute break on this machine. But if I could reduce the 'slow to a stop' to just once a day it would be a huge help!

This feeble machine has produced many an anime music video using Kdenlive, BTW!
User avatar Mamarok
Manager
Posts
4740
Karma
12
OS
With little RAM the more SWAP you have the better, you can go up to 8 GB SWAP in your case. Even with 8 GB RAM I use SWAP space double that size, and it really helps when doing a lot of things simultaneously. That is just a small bit more of your generous hard disk.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-40
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
jedipadawan
Registered Member
Posts
17
Karma
0
Mamarok wrote:With little RAM the more SWAP you have the better, you can go up to 8 GB SWAP in your case. Even with 8 GB RAM I use SWAP space double that size, and it really helps when doing a lot of things simultaneously. That is just a small bit more of your generous hard disk.


Really? A SWAP partition makes that much difference? When I had checked over the RAM usage it tended to show low use of SWAP. Although, I grant, when the machine stalls I cannot run a RAM usage utility to see so I will trust you on this!

Many thanks for the helpful and cordial response. It is much appreciated.

I will run a partition manager on the machine over an evening soon and see how it runs after that and report back. Er, it'll take some time. It's pretty busy!
jedipadawan
Registered Member
Posts
17
Karma
0
Well, I managed to resize my swap drive to 9GB and, I have to say, so far it's made quite a difference.

I will have to check this out over some time but if all does turn out well I will mark this as closed.

Many thanks again!
andreasgoebel
Registered Member
Posts
25
Karma
0
Hi,
in case you are still having problems:

a) You can remove the update-notification by
- right click on panel
- edit panel
- hover over system tray
- edit system tray
- set update notifications to never show

In the manual to packagekit it says that it is only started when requested by some other software, so it might be that this stops the update-checking.

If not, you can
b) uninstall packagekit, but this will lead to discover not working anymore

I think that there should be an easy way to stop automatic update-checking!

Regards,

Andreas
User avatar rica
Registered Member
Posts
6
Karma
0
OS
Discover starting in the background at each reboot bothered me too (other reasons than memory and freezing). The above suggested solution worked in Kubuntu 18.04, as Updates could be unchecked. On Neon with Plasma 5.19.1, Framework 5.71.0, Qt 5.14.2 the only option in the System Try settings is to hide the icon, not to disable it. As curiously as it might be, it solved the issue!

But I also did something else, believing it will help, instead retrigered Discover after rebooting. So to avoid the following: after hiding the Updates icon in the System Try settings, I went to the System Try panel and right-clicked on the Updates icon and chose Quit. At the next reboot, Updates notification restarted (in hidden mode), and doing this retriggered Discover too, but just for the first reboot. Doing too much this time, result in doing less.

Just choosing to permanently hide the Updates icon in the System Try settings, will work. Icon will still show in the System Try panel, but not in the System Try itself, and won't automatically trigger Discover anymore. It only will do it manually, if clicking on the Updates icon in the System Try panel.

Thanks andreasgoebel.


rica
jedipadawan
Registered Member
Posts
17
Karma
0
rica wrote:Discover starting in the background at each reboot bothered me too (other reasons than memory and freezing). The above suggested solution worked in Kubuntu 18.04, as Updates could be unchecked. On Neon with Plasma 5.19.1, Framework 5.71.0, Qt 5.14.2 the only option in the System Try settings is to hide the icon, not to disable it. As curiously as it might be, it solved the issue!

But I also did something else, believing it will help, instead retrigered Discover after rebooting. So to avoid the following: after hiding the Updates icon in the System Try settings, I went to the System Try panel and right-clicked on the Updates icon and chose Quit. At the next reboot, Updates notification restarted (in hidden mode), and doing this retriggered Discover too, but just for the first reboot. Doing too much this time, result in doing less.

Just choosing to permanently hide the Updates icon in the System Try settings, will work. Icon will still show in the System Try panel, but not in the System Try itself, and won't automatically trigger Discover anymore. It only will do it manually, if clicking on the Updates icon in the System Try panel.

Thanks andreasgoebel.


Thanks. I will look into that in due time. Since posting I was hit by a mass of emergencies taking my focus off tech quibbles. So I will take a closer look soon.

As it is, expanding swap space has helped quite a lot! Surprisingly so. While the old ASUS cannot have it's RAM upgraded, I have twigged that I can help things by swapping out the 5,400RPM HDD for a 7,200 device. I need serious storage space so SSD will not cut the deal!
Unfortunately, y emergencies have cost me serious monies and so that one will have to wait quite a while. Well, at lest I am still earning and in credit when so many are not!
'Old Faithful' still keeps going!
Thanks again, and, again, my apologies for delay in respond. I was being beaten around the head by problems. Almost literally. ;D
jedipadawan
Registered Member
Posts
17
Karma
0
Mamarok wrote:With little RAM the more SWAP you have the better, you can go up to 8 GB SWAP in your case. Even with 8 GB RAM I use SWAP space double that size, and it really helps when doing a lot of things simultaneously. That is just a small bit more of your generous hard disk.


It looks at if this topic has been marked as solved already but I did promise to feedback after time. Only I was then hit by a bees nest or problems talking my attention (and money!) away from tech glitches!

Anyway, for those who are searching up on this problem in the future, expanding my swap drive to 9GB HAS helped quite considerably!
I have decided that, in due time, I will up to 7,200RPM HDD (forget SSD, they just do not have the store I need at the price) but that is a year away as I continue to put fires out.)
So many thanks!

 
Reply to topic

Bookmarks



Who is online

Registered users: adetayo, Baidu [Spider], bbaker, Bing [Bot], claydoh, farid, Google [Bot], grahm, jkgoose, kde-arran, Lachu, Section_8, serxios, Sogou [Bot], spoontex, YaCy [Bot]