Reply to topic

Call for Testing of KDE neon on Focal 20.04 base

sstaeglich
Registered Member
Posts
63
Karma
0
db_data/tc.log was corrupted
imperatorstorm
Registered Member
Posts
1
Karma
0
Possible bug:
After upgrading to focal, any attempts to open a hyperlink outside of firefox gives error:
Code: Select all
Could not find the program '/usr/bin/_neon.firefox'

i have uninstalled, reinstalled, and purged and reinstalled firefox, yet this still happens.

false alarm, default browser was broken
setting default from [.sh icon]Firefox to [firefox icon]Firefox fixed it
User avatar kde-wheezy
Registered Member
Posts
3
Karma
0
Any idea for when the RC edition will be published? Also, If i decide to install the preview iso...will the future upgrades of that preview turn itself into the stable version when released? I have a few extra laptops I would like to test install it on with hopes of just rolling thru (with any bugs) that might take place.

Thanks for response back.

kde-jriddell wrote:We would like to ask for testing of the KDE neon on Focal/20.04 rebase.

We need testing of the upgrade process, which is documented here
https://community.kde.org/Neon/FocalUpgrades

And of the Preview installable ISOs which are here
https://files.kde.org/neon/images/focal-preview/

We need testing of all editions installed as full disk install, selected partiton install, encrypted partition install, OEM install. Please report back with details of what type of install you did and problems you found.
User avatar claydoh
Registered Member
Posts
1014
Karma
9
OS
kde-wheezy wrote:Any idea for when the RC edition will be published? Also, If i decide to install the preview iso...will the future upgrades of that preview turn itself into the stable version when released? I have a few extra laptops I would like to test install it on with hopes of just rolling thru (with any bugs) that might take place.


Yes, installing via ISO or testing upgrades will become 'official' automatically.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar kde-wheezy
Registered Member
Posts
3
Karma
0
One thing that I did notice was missing from the get go of my install was that the option for LUKS encryption of the partition using the installer. I even looked for it in the manual setup and did not find it. Was this option supposed to be removed from the Installer?
User avatar boospy007
Registered Member
Posts
217
Karma
0
OS
If i install Falkon Webbrowser on an upgraded system, or on a new installed system, it is the same like in 18.04. The whole webbrowser Windows is transparent, and on the cmd i get this error. Did the Browser dependig on some hardware?

If i do this in the Office with my notebook, it is the sam.

Code: Select all
qt.qpa.backingstore: composeAndFlush: makeCurrent() failed
qt.qpa.backingstore: composeAndFlush: makeCurrent() failed
qt.qpa.backingstore: composeAndFlush: makeCurrent() failed
qt.qpa.backingstore: composeAndFlush: makeCurrent() failed
qt.qpa.backingstore: composeAndFlush: makeCurrent() failed
qt.qpa.backingstore: composeAndFlush: makeCurrent() failed
dbergstein
Registered Member
Posts
43
Karma
2
OS
kde-jriddell wrote:We would like to ask for testing of the KDE neon on Focal/20.04 rebase.

We need testing of the upgrade process, which is documented here
https://community.kde.org/Neon/FocalUpgrades

And of the Preview installable ISOs which are here
https://files.kde.org/neon/images/focal-preview/

We need testing of all editions installed as full disk install, selected partiton install, encrypted partition install, OEM install. Please report back with details of what type of install you did and problems you found.


I ran into installation issues with the Developer and Testing editions this evening (20200807). Links are provided below:

https://files.kde.org/neon/images/focal ... 0807-1521/
https://files.kde.org/neon/images/focal ... 0807-1505/

For the Developer edition, the installer halted on an error setting the user password. Installation was partially done but incomplete.

For the Testing Edition, the installer crashed at the disk configuration screen when I tried selecting the disk.
User avatar boospy007
Registered Member
Posts
217
Karma
0
OS
An installation of an physical machine is posible. But on a virtualmachine not. I'fe tested it on Proxmox and on plain KVM. The installer breaks with segfault. :'( Bad, so i can't test anymore my NEON installer without an extra physical machein. https://darkdevil.osit.cc/gitlab/public ... -installer
Hokasito
Registered Member
Posts
1
Karma
0
kde-wheezy wrote:One thing that I did notice was missing from the get go of my install was that the option for LUKS encryption of the partition using the installer. I even looked for it in the manual setup and did not find it. Was this option supposed to be removed from the Installer?


I noticed the same, at least in some preview ISOs from last week. I think Calamares Installer supports this feature, and the current stable ISOs based on 18.04 have the abilty to encrypt the partition.

So what's happening? Maybe a missing package or something like that? For me, and a lot of us, this is a key feature that should work. I don't know if this problem is being tackled right now.

EDIT: As soon as I said it... The last ISO from yesterday brings back the feature. Good work!

https://imgur.com/7qo4Sna
abirer
Registered Member
Posts
1
Karma
0
Just installed User on my Thinkpad T470, works great. İnstallation, firefox media playback, wireless, apps, development on VScode and fractional scaling at 150% even, great job
User avatar jbouter
Registered Member
Posts
15
Karma
0
OS
I can't seem to get wayland to start. On my upgraded (18.04 -> 20.04) laptop I receive the following errors:

Code: Select all
...
dbus-daemon[2149]: [session uid=1000 pid=2149] Activating service name='org.freedesktop.Notifications' requested by ':1.24' (uid=1000 pid=2409 comm="/usr/lib/x86_64-linux-gnu/libexec/kdeconnectd ")
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = korgac path = /usr/bin pid = 2462
KCrash: Arguments: /usr/bin/korgac
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kdeconnectd path = /usr/lib/x86_64-linux-gnu/libexec pid = 2409
KCrash: Arguments: /usr/lib/x86_64-linux-gnu/libexec/kdeconnectd
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
The Wayland connection broke. Did the Wayland compositor die?
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kactivitymanagerd path = /usr/lib/x86_64-linux-gnu/libexec pid = 2412
KCrash: Arguments: /usr/lib/x86_64-linux-gnu/libexec/kactivitymanagerd
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
klauncher: Exiting on signal 6
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = klauncher path = /usr/lib/x86_64-linux-gnu/libexec/kf5 pid = 2239
KCrash: Arguments: /usr/lib/x86_64-linux-gnu/libexec/kf5/klauncher --fd=9
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
kdeinit5: KLauncher died unexpectedly.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/libexec/kf5/klauncher'
kdeinit5: Launched KLauncher, pid = 2556, result = 0
kdeinit5: PID 2239 terminated.
(EE) failed to read Wayland events: Broken pipe
Failed to create wl_display (Connection refused)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
kdeinit5: Communication error with launcher. Exiting!
QSocketNotifier: Invalid socket 6 and type 'Read', disabling...
X connection to :1 broken (explicit kill or server shutdown).
QProcess: Destroyed while process ("/usr/bin/plasma_session") is still running.
"/usr/bin/kwin_wayland" ("--xwayland", "--libinput", "--exit-with-session=/usr/lib/x86_64-linux-gnu/libexec/startplasma-waylandsession") exited with code 11
startplasmacompositor: Shutting down...
startplasmacompositor: Done.
dbus-daemon[2149]: [session uid=1000 pid=2149] Reloaded configuration
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kgpg path = /usr/bin pid = 2488
KCrash: Arguments: /usr/bin/kgpg
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
KCrash: Attempting to start /usr/bin/kded5
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kded5 path = /usr/bin pid = 2361
KCrash: Arguments: /usr/bin/kded5
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi


Full log is available here on pastebin.ubuntu.com

A freshly installed and upgraded Neon Focal VM also crashes and reports the following:

Code: Select all
...
dbus-daemon[907]: [session uid=1000 pid=907] Activating service name='org.freedesktop.Notifications' requested by ':1.15' (uid=1000 pid=1012 comm="/usr/lib/x86_64-linux-gnu/libexec/kdeconnectd " label="unconfined")
dbus-daemon[907]: [session uid=1000 pid=907] Activating service name='org.bluez.obex' requested by ':1.10' (uid=1000 pid=982 comm="/usr/bin/kded5 " label="unconfined")
dbus-daemon[907]: [session uid=1000 pid=907] Activated service 'org.bluez.obex' failed: Failed to execute program org.bluez.obex: No such file or directory
kdeinit5: Got EXEC_NEW '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/desktop.so' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/desktop.so'
The Wayland connection broke. Did the Wayland compositor die?
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kdeconnectd path = /usr/lib/x86_64-linux-gnu/libexec pid = 1012
KCrash: Arguments: /usr/lib/x86_64-linux-gnu/libexec/kdeconnectd
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kactivitymanagerd path = /usr/lib/x86_64-linux-gnu/libexec pid = 1014
KCrash: Arguments: /usr/lib/x86_64-linux-gnu/libexec/kactivitymanagerd
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = konsole path = /usr/bin pid = 1093
KCrash: Arguments: /usr/bin/konsole
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
klauncher: Exiting on signal 6
kdeinit5: KLauncher died unexpectedly.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/libexec/kf5/klauncher'
(EE) failed to read Wayland events: Broken pipe
kdeinit5: Launched KLauncher, pid = 1115, result = 0
kdeinit5: PID 956 terminated.
X connection to :1 broken (explicit kill or server shutdown).
QSocketNotifier: Invalid socket 6 and type 'Read', disabling...
Failed to create wl_display (Connection refused)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
QProcess: Destroyed while process ("/usr/bin/plasma_session") is still running.
"/usr/bin/kwin_wayland" ("--xwayland", "--libinput", "--exit-with-session=/usr/lib/x86_64-linux-gnu/libexec/startplasma-waylandsession") exited with code 11
startplasmacompositor: Shutting down...
startplasmacompositor: Done.
KCrash: Attempting to start /usr/bin/kded5
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kded5 path = /usr/bin pid = 982
KCrash: Arguments: /usr/bin/kded5
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi


Full log is available here on pastebin.ubuntu.com
quisimodo
Registered Member
Posts
7
Karma
0
Code: Select all
sudo apt install mysql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) mysql-server:amd64 < none -> 8.0.21-0ubuntu0.20.04.4 @un puN Ib >
Broken mysql-server:amd64 Depends on mysql-server-8.0:amd64 < none | 8.0.21-0ubuntu0.20.04.4 @un uH >
  Considering mysql-server-8.0:amd64 1 as a solution to mysql-server:amd64 9999
  Re-Instated mariadb-common:amd64
  Re-Instated mariadb-client-core-10.3:amd64
  Re-Instated mysql-client-core-8.0:amd64
  Re-Instated mysql-client-8.0:amd64
    Reinst Failed early because of mysql-server-core-8.0:amd64
  Considering mysql-server-8.0:amd64 1 as a solution to mysql-server:amd64 9999
Investigating (0) mariadb-client-core-10.3:amd64 < none -> 1:10.3.22-1ubuntu1 @un uN Ib >
Broken mariadb-client-core-10.3:amd64 Conflicts on mysql-client-8.0:amd64 < none -> 8.0.21-0ubuntu0.20.04.4 @un uN >
  Considering mysql-client-8.0:amd64 0 as a solution to mariadb-client-core-10.3:amd64 0
  Holding Back mariadb-client-core-10.3:amd64 rather than change mysql-client-8.0:amd64
Investigating (0) mysql-client-core-8.0:amd64 < none -> 0.4+p20.04+git20200805.1207 @un uN Ib >
Broken mysql-client-core-8.0:amd64 Depends on mariadb-client-core-10.3:amd64 < none | 1:10.3.22-1ubuntu1 @un uH >
  Considering mariadb-client-core-10.3:amd64 0 as a solution to mysql-client-core-8.0:amd64 0
  Holding Back mysql-client-core-8.0:amd64 rather than change mariadb-client-core-10.3:amd64
Investigating (0) mysql-client-8.0:amd64 < none -> 8.0.21-0ubuntu0.20.04.4 @un uN Ib >
Broken mysql-client-8.0:amd64 Depends on mysql-client-core-8.0:amd64 < none | 0.4+p20.04+git20200805.1207 @un uH >
  Considering mysql-client-core-8.0:amd64 0 as a solution to mysql-client-8.0:amd64 0
  Holding Back mysql-client-8.0:amd64 rather than change mysql-client-core-8.0:amd64
Investigating (1) mysql-server:amd64 < none -> 8.0.21-0ubuntu0.20.04.4 @un puN Ib >
Broken mysql-server:amd64 Depends on mysql-server-8.0:amd64 < none | 8.0.21-0ubuntu0.20.04.4 @un uH >
  Considering mysql-server-8.0:amd64 1 as a solution to mysql-server:amd64 9999
  Considering mysql-server-8.0:amd64 1 as a solution to mysql-server:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-server : Depends: mysql-server-8.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


This is a fresh install

Operating System: KDE neon 5.19
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.72.0
Qt Version: 5.14.2
Kernel Version: 5.4.0-42-generic
OS Type: 64-bit
Processors: 16 × Intel® Core™ i7-10875H CPU @ 2.30GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics
oxwivi
Registered Member
Posts
8
Karma
0
I had manually upgraded to Focal using the now obsolete and removed methods in the Neon/FocalUpgrades page. Since 20.04-based neon is now live, are we good to go or do we need to change anything to get in line with the latest release?
peperud
Registered Member
Posts
3
Karma
0
Not sure if this is the right place to ask, but I'm not seeing the upgrade message.
Is the availability different based on location or something else?
User avatar claydoh
Registered Member
Posts
1014
Karma
9
OS
oxwivi wrote:I had manually upgraded to Focal using the now obsolete and removed methods in the Neon/FocalUpgrades page. Since 20.04-based neon is now live, are we good to go or do we need to change anything to get in line with the latest release?


You are good to go :)


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], koffeinfriedhof, mmm