Reply to topic

Mouse cursor flickers when changing state

evvy
Registered Member
Posts
2
Karma
0
There's a very persistent issue I've been trying to fix on my machine. When I'm moving my mouse around and it changes what cursor icon to display (generally when switching from the regular icon to the "hand" icon when hovering over a link) there's a strange visual bug where the cursor seems to "flicker". It's difficult to describe accurately because it happens so fast, but it looks like the cursor disappears, reappears a little bit to the right, then snaps back to where it should be.

To better help you understand what I'm talking about, here's a video of the issue: https://damboy.sytes.net/tmp/cursor.mp4

Note that that video wasn't taken by me, I found it on another forum thread where someone had a similar issue, but never managed to solve it. I'm not sure if that person has the exact same problem as me, but that's pretty close to what the flicker looks like on my machine, although it often jitters much farther to the side than that. I wasn't able to provide my own video because for some reason, when I use screen recording software, the flicker doesn't show up in the video. The cursor movement appears perfectly smooth.

For reference, the forum thread I got that from is at https://forum.manjaro.org/t/mouse-wobbles-when-changing-state/99625

The weirdest part is that it only happens with some cursor themes. I don't have this issue when I use the DMZ cursor theme, but I do for every other theme I've tried, including the built-in Breeze cursor themes. It also doesn't happen all the time. Sometimes it will stop doing it for a while, and even when it's happening, it won't flicker every time it changes, just most of the time. I haven't been able to figure out a pattern to when it does or doesn't happen.

I've been trying out a few different things to try and fix it, but none of them have worked. At first I thought it might have something to do with cursors that have multiple size options, but I confirmed that that isn't it. Cursor themes with only one size option had this issue as well, and the DMZ theme I downloaded has multiple size options, and it isn't affected. I thought it might be fixable by forcing software cursor rendering, but I wasn't able to get that to work. I attempted to change the KWIN_FORCE_SW_CURSOR setting using a .sh script, but it didn't fix anything and I can't even tell if I did it correctly. I tried going into the xorg.conf.d folder and setting the software cursor option to true in the file 10-nvidia.conf but that caused a whole bunch of separate issues, so I undid it. I've gone into the compositor settings and messed around with basically every configuration I could try, but none of them did anything. I've also messed with the various mouse settings under the input tab, which didn't help either.

Right now, the main thing I'm trying to focus on is why it seems to apply to some cursor themes but not others. But I can't figure out what it might be. It feels like if the cursor themes themself were the issue, then everybody would be having this problem, which obviously isn't true.

Can anybody help me figure this out? I'm so lost.

Info on my system in case it's relevant:
OS: KDE neon 5.19 (I just installed it recently, so everything is up to date)
CPU: Intel i7-2600k
GPU: Geforce GTX 1080

Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], linkq, raphaelra, raudt, Yahoo [Bot]