Reply to topic

Updating to latest KDE Neon removes Latte Dock.

Katana97
Registered Member
Posts
2
Karma
0
Updating to latest KDE Neon removes Latte Dock. Dependancy issue with libprocesscore7, both with the version on Discover and the git version.

I can't find any info online about this, except one other user on Reddit:

https://www.reddit.com/r/kde/comments/h07r9q/lattedock_10_with_plasma_519/

Anything I can do?

Code: Select all
[email protected]:~$ sudo apt install latte-dock
[sudo] password for david:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) latte-dock:amd64 < none -> 0.9.85+git20200620.1400-0~ubuntu18.04~ppa1 @rc puN Ib >
Broken latte-dock:amd64 Depends on libprocesscore7:amd64 < none | 4:5.12.8-0ubuntu0.1build1~ubuntu18.04~ppa1 @un uH > (>= 4:5.3.0)
  Considering libprocesscore7:amd64 -1 as a solution to latte-dock:amd64 9999
    Reinst Failed early because of libkf5sysguard-data:amd64
  Considering libprocesscore7:amd64 -1 as a solution to latte-dock:amd64 9999
  Considering libprocesscore7:amd64 -1 as a solution to latte-dock:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 latte-dock : Depends: libprocesscore7 (>= 4:5.3.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Katana97
Registered Member
Posts
2
Karma
0
Sorry to bump but does anyone know if it's possible to get Latte Dock running? I miss it!
User avatar dbergstein
Registered Member
Posts
25
Karma
0
OS
Katana97 wrote:Sorry to bump but does anyone know if it's possible to get Latte Dock running? I miss it!


I ran into similar issues with another package (digikam) after upgrading, and ended up building it from source to remove the dependency problems.
User avatar acheronuk
KDE Developer
Posts
113
Karma
2
Katana97 wrote:Anything I can do?


Stop using the latte-dock packages from my PPA. They are not built for Neon, so breakage like this can happen, and will not be fixed.

 
Reply to topic

Bookmarks



Who is online

Registered users: alra, Baidu [Spider], Bing [Bot], boospy007, claydoh, Exabot [Bot], Google [Bot], passegua, raudt, Sogou [Bot], TG