Reply to topic

Cannot install clang tidy after update

sandro4912
Registered Member
Posts
23
Karma
0
I tried to reinstall clang-tidy after the upgrade from 18.04 to 20.04 but now i get this:

Code: Select all
[email protected]:~$ sudo apt-get install clang-tidy
[sudo] password for sandro:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-10:amd64 Depends on libobjc-9-dev:amd64 < none | 9.3.0-10ubuntu2 @un uH >
  Considering libobjc-9-dev:amd64 1 as a solution to clang-10:amd64 0
  Holding Back clang-10:amd64 rather than change libobjc-9-dev:amd64
Investigating (1) clang-tools-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-tools-10:amd64 Depends on clang-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (= 1:10.0.0-4ubuntu1)
  Considering clang-10:amd64 0 as a solution to clang-tools-10:amd64 0
  Holding Back clang-tools-10:amd64 rather than change clang-10:amd64
Investigating (2) clang-tidy-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-tidy-10:amd64 Depends on clang-tools-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH >
  Considering clang-tools-10:amd64 0 as a solution to clang-tidy-10:amd64 0
  Holding Back clang-tidy-10:amd64 rather than change clang-tools-10:amd64
Investigating (3) clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un puN Ib >
Broken clang-tidy:amd64 Depends on clang-tidy-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (>= 10~)
  Considering clang-tidy-10:amd64 0 as a solution to clang-tidy:amd64 9999
    Reinst Failed early because of gcc-9-base:amd64
    Reinst Failed because of libobjc-9-dev:amd64
    Reinst Failed because of clang-10:amd64
    Reinst Failed because of clang-tools-10:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 clang-tidy : Depends: clang-tidy-10 (>= 10~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Any idea what i can do? I already checked for broken packages but I cannot find any.
User avatar claydoh
Registered Member
Posts
684
Karma
5
OS
Do you have any PPAs that have not been re-enabled and updated?
It may be a conflict with one of these unofficial, unsupported thord party repos.
It won't install for me, either, but I get better info trying to install one of the missing dependencies:

$ sudo apt install clang-tidy-10
Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) clang-tidy-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un puN Ib >
Broken clang-tidy-10:amd64 Depends on libclang-cpp10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH >
Considering libclang-cpp10:amd64 1 as a solution to clang-tidy-10:amd64 9999
Reinst Failed early because of libllvm10:amd64

<some snippage>

The following packages have unmet dependencies:
clang-tidy-10 : Depends: libclang-cpp10 but it is not going to be installed
Depends: libllvm10 (= 1:10.0.0-4ubuntu1) but 1:10.0.0-4.1~f~mesarc1 is to be installed
Depends: libclang-common-10-dev but it is not going to be installed
Depends: clang-tools-10 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


The problem on my end is from a Mesa PPA I am using, though I have re-enabled this and updated it, so it is a conflict between the package and my PPA. You may have a similar conflict due to a PPA or other third party repo you have added,


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
sandro4912
Registered Member
Posts
23
Karma
0
hm in my source list I only have this:

Code: Select all
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://de.archive.ubuntu.com/ubuntu/ focal restricted main

## Major bug fix updates produced after the final release of the
## distribution.
deb http://de.archive.ubuntu.com/ubuntu/ focal-updates restricted main

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ focal universe
deb http://de.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://de.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://de.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ focal-backports multiverse universe restricted main

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

deb http://security.ubuntu.com/ubuntu/ focal-security restricted main
deb http://security.ubuntu.com/ubuntu/ focal-security universe
deb http://security.ubuntu.com/ubuntu/ focal-security multiverse
#disabled on upgrade to focal
#disabled on upgrade to focal
#disabled on upgrade to focal


Whats the best way to trouble shot this issue?
User avatar claydoh
Registered Member
Posts
684
Karma
5
OS
Try installing one of the broken dependency packages, as I did : clang-tidy-10, the error message may be better, like it was for me.
I should be able to spot a non-stock package version if there is one.

The sources.list is normal, and OK
PPAs are usually stored in /etc/apt/sources.list.d/, in individual files for each repository.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
sandro4912
Registered Member
Posts
23
Karma
0
i tryed clang-tidy-10:

Code: Select all
[email protected]:~$ sudo apt install clang-tidy-10
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-10:amd64 Depends on libobjc-9-dev:amd64 < none | 9.3.0-10ubuntu2 @un uH >
  Considering libobjc-9-dev:amd64 1 as a solution to clang-10:amd64 0
  Holding Back clang-10:amd64 rather than change libobjc-9-dev:amd64
Investigating (1) clang-tools-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-tools-10:amd64 Depends on clang-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (= 1:10.0.0-4ubuntu1)
  Considering clang-10:amd64 0 as a solution to clang-tools-10:amd64 0
  Holding Back clang-tools-10:amd64 rather than change clang-10:amd64
Investigating (2) clang-tidy-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un puN Ib >
Broken clang-tidy-10:amd64 Depends on clang-tools-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH >
  Considering clang-tools-10:amd64 0 as a solution to clang-tidy-10:amd64 9999
    Reinst Failed early because of gcc-9-base:amd64
    Reinst Failed because of libobjc-9-dev:amd64
    Reinst Failed because of clang-10:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 clang-tidy-10 : Depends: clang-tools-10 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


and then clang-tools-10:

Code: Select all
[email protected]:~$ sudo apt install clang-tools-10
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-10:amd64 Depends on libobjc-9-dev:amd64 < none | 9.3.0-10ubuntu2 @un uH >
  Considering libobjc-9-dev:amd64 1 as a solution to clang-10:amd64 0
  Holding Back clang-10:amd64 rather than change libobjc-9-dev:amd64
Investigating (1) clang-tools-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un puN Ib >
Broken clang-tools-10:amd64 Depends on clang-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (= 1:10.0.0-4ubuntu1)
  Considering clang-10:amd64 0 as a solution to clang-tools-10:amd64 9999
    Reinst Failed early because of gcc-9-base:amd64
    Reinst Failed because of libobjc-9-dev:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 clang-tools-10 : Depends: clang-10 (= 1:10.0.0-4ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


and then clang 10:

Code: Select all
[email protected]:~$ sudo apt install clang-10
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un puN Ib >
Broken clang-10:amd64 Depends on libobjc-9-dev:amd64 < none | 9.3.0-10ubuntu2 @un uH >
  Considering libobjc-9-dev:amd64 1 as a solution to clang-10:amd64 9999
    Reinst Failed early because of gcc-9-base:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 clang-10 : Depends: libobjc-9-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



and then libobjc-9-dev:


Code: Select all
[email protected]:~$ sudo apt install libobjc-9-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) libobjc-9-dev:amd64 < none -> 9.3.0-10ubuntu2 @un puN Ib >
Broken libobjc-9-dev:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK > (= 9.3.0-10ubuntu2)
  Considering gcc-9-base:amd64 5 as a solution to libobjc-9-dev:amd64 9999
Broken libobjc-9-dev:amd64 Depends on libgcc-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK > (= 9.3.0-10ubuntu2)
  Considering libgcc-9-dev:amd64 1 as a solution to libobjc-9-dev:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libobjc-9-dev : Depends: gcc-9-base (= 9.3.0-10ubuntu2) but 9.3.0-11ubuntu0~18.04.1 is to be installed
                 Depends: libgcc-9-dev (= 9.3.0-10ubuntu2) but 9.3.0-11ubuntu0~18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.


then gcc-9-base:

which he claims to be installed:

Code: Select all
[email protected]:~$ sudo apt install gcc-9-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gcc-9-base is already the newest version (9.3.0-11ubuntu0~18.04.1).
gcc-9-base set to manually installed.
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


same with libgcc-9-dev:

Code: Select all
[email protected]:~$ sudo apt install libgcc-9-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgcc-9-dev is already the newest version (9.3.0-11ubuntu0~18.04.1).
libgcc-9-dev set to manually installed.
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$



So I followed all the broken packages and at the end no errors?
User avatar claydoh
Registered Member
Posts
684
Karma
5
OS
The following packages have unmet dependencies:
libobjc-9-dev : Depends: gcc-9-base (= 9.3.0-10ubuntu2) but ]9.3.0-11ubuntu0~18.04.1 is to be installed
Depends: libgcc-9-dev (= 9.3.0-10ubuntu2) but 9.3.0-11ubuntu0~18.04.1 is to be installed

The blue text is the official package version, wile the red is from a PPA or other source.

What is the result of the command
Code: Select all
apt policy gcc-9-base


This will tell us which extra repo/PPA that you have that s causing the issue for this package.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
sandro4912
Registered Member
Posts
23
Karma
0
Code: Select all
[email protected]:~$ apt policy gcc-9-base
gcc-9-base:
  Installed: 9.3.0-11ubuntu0~18.04.1
  Candidate: 9.3.0-11ubuntu0~18.04.1
  Version table:
 *** 9.3.0-11ubuntu0~18.04.1 100
        100 /var/lib/dpkg/status
     9.3.0-10ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu focal/main amd64 Packages
User avatar claydoh
Registered Member
Posts
684
Karma
5
OS
sandro4912 wrote:
Code: Select all
[email protected]:~$ apt policy gcc-9-base
gcc-9-base:
  Installed: 9.3.0-11ubuntu0~18.04.1
  Candidate: 9.3.0-11ubuntu0~18.04.1
  Version table:
 *** 9.3.0-11ubuntu0~18.04.1 100
        100 /var/lib/dpkg/status
     9.3.0-10ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu focal/main amd64 Packages


That is odd. For me, using the US archives, it shows the correct version. Yours is using the German mirror, and has a completely different version file name.
Code: Select all
$ apt policy gcc-9-base
gcc-9-base:
  Installed: 9.3.0-10ubuntu2
  Candidate: 9.3.0-10ubuntu2
  Version table:
 *** 9.3.0-10ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status


It is not saying where that bad package is from, what PPAs have you added? If you upgraded from Neon's 18.04 to 20.04, these are all disabled beforehand, and need to be re-enabled afterward.
I am stumped.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
sandro4912
Registered Member
Posts
23
Karma
0
does this ppa list help to troubleshoot it?

Code: Select all
[email protected]:~$ sudo apt-cache policy
[sudo] password for sandro:
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu focal/main i386 Packages
     release v=20.04,o=LP-PPA-webupd8team-y-ppa-manager,a=focal,n=focal,l=Y PPA Manager,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu focal/main amd64 Packages
     release v=20.04,o=LP-PPA-webupd8team-y-ppa-manager,a=focal,n=focal,l=Y PPA Manager,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://archive.neon.kde.org/user focal/main all Packages
     release o=user focal,a=focal,n=focal,l=KDE neon - User Edition,c=main,b=all
     origin archive.neon.kde.org
 500 http://archive.neon.kde.org/user focal/main i386 Packages
     release o=user focal,a=focal,n=focal,l=KDE neon - User Edition,c=main,b=i386
     origin archive.neon.kde.org
 500 http://archive.neon.kde.org/user focal/main amd64 Packages
     release o=user focal,a=focal,n=focal,l=KDE neon - User Edition,c=main,b=amd64
     origin archive.neon.kde.org
 500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu focal/main i386 Packages
     release v=20.04,o=LP-PPA-libreoffice,a=focal,n=focal,l=LibreOffice Fresh,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu focal/main amd64 Packages
     release v=20.04,o=LP-PPA-libreoffice,a=focal,n=focal,l=LibreOffice Fresh,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal/main i386 Packages
     release v=20.04,o=LP-PPA-graphics-drivers,a=focal,n=focal,l=Proprietary GPU Drivers,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal/main amd64 Packages
     release v=20.04,o=LP-PPA-graphics-drivers,a=focal,n=focal,l=Proprietary GPU Drivers,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://ppa.launchpad.net/git-core/ppa/ubuntu focal/main i386 Packages
     release v=20.04,o=LP-PPA-git-core,a=focal,n=focal,l=Git stable releases,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/git-core/ppa/ubuntu focal/main amd64 Packages
     release v=20.04,o=LP-PPA-git-core,a=focal,n=focal,l=Git stable releases,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://developer.download.nvidia.com/compute/machine-learning/repos/ubuntu1804/x86_64  Packages
     release o=NVIDIA,l=NVIDIA CUDA,c=
     origin developer.download.nvidia.com
 500 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64  Packages
     release o=NVIDIA,l=NVIDIA CUDA,c=
     origin developer.download.nvidia.com
 500 https://deb.etcher.io stable/etcher i386 Packages
     release o=Bintray,a=stable,n=stable,l=Bintray,c=etcher,b=i386
     origin deb.etcher.io
 500 https://deb.etcher.io stable/etcher amd64 Packages
     release o=Bintray,a=stable,n=stable,l=Bintray,c=etcher,b=amd64
     origin deb.etcher.io
 500 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=multiverse,b=amd64
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu focal-security/universe i386 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=universe,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=universe,b=amd64
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=main,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=main,b=amd64
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu focal-security/restricted i386 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=restricted,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-security,n=focal,l=Ubuntu,c=restricted,b=amd64
     origin security.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu focal-backports/universe i386 Packages
     release v=20.04,o=Ubuntu,a=focal-backports,n=focal,l=Ubuntu,c=universe,b=i386
     origin de.archive.ubuntu.com
 100 http://de.archive.ubuntu.com/ubuntu focal-backports/universe amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-backports,n=focal,l=Ubuntu,c=universe,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/multiverse i386 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=multiverse,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=multiverse,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=universe,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=universe,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=main,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=main,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/restricted i386 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=restricted,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages
     release v=20.04,o=Ubuntu,a=focal-updates,n=focal,l=Ubuntu,c=restricted,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/multiverse i386 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=multiverse,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=multiverse,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/universe i386 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=universe,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/universe amd64 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=universe,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/main i386 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=main,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/main amd64 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=main,b=amd64
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/restricted i386 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=restricted,b=i386
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com/ubuntu focal/restricted amd64 Packages
     release v=20.04,o=Ubuntu,a=focal,n=focal,l=Ubuntu,c=restricted,b=amd64
     origin de.archive.ubuntu.com
Pinned packages:
     libqtavwidgets1 -> 1.13.0+ds-1build2 with priority 1100
     libqtav-dev -> 1.13.0+ds-1build2 with priority 1100
     python-sip -> 4.19.21+dfsg-1build1 with priority 1100
     python-sip-dev -> 4.19.21+dfsg-1build1 with priority 1100
     python3-software-properties -> 0.98.9.2 with priority 1100
     python3-software-properties -> 0.98.9 with priority 1100
     libgwenhywfar79 -> 5.1.3-1build1 with priority 1100
     libgwenhywfar-core-dev -> 5.1.3-1build1 with priority 1100
     libgwengui-fox16-dev -> 5.1.3-1build1 with priority 1100
     libgwenhywfar-data -> 5.1.3-1build1 with priority 1100
     libgwengui-cpp0 -> 5.1.3-1build1 with priority 1100
     libqtav-private-dev -> 1.13.0+ds-1build2 with priority 1100
     iio-sensor-proxy -> 2.8-1 with priority 1100
     bubblewrap -> 0.4.0-1ubuntu4 with priority 1100
     ubuntu-release-upgrader-qt -> 1:20.04.23+p20.04+git20200729.0939 with priority 1100
     software-properties-gtk -> 0.98.9.2 with priority 1100
     software-properties-gtk -> 0.98.9 with priority 1100
     libgwenhywfar79-dev -> 5.1.3-1build1 with priority 1100
     libgwengui-fox16-0 -> 5.1.3-1build1 with priority 1100
     zipmerge -> 1.5.1-0ubuntu1 with priority 1100
     epub-utils -> 0.2.2-4ubuntu2 with priority 1100
     python3-distupgrade -> 1:20.04.23+p20.04+git20200729.0939 with priority 1100
     ubuntu-release-upgrader-core -> 1:20.04.23+p20.04+git20200729.0939 with priority 1100
     mysql-client-core-8.0 -> 0.4+p20.04+git20200818.0814 with priority 1100
     libepub0 -> 0.2.2-4ubuntu2 with priority 1100
     libzip-dev -> 1.5.1-0ubuntu1 with priority 1100
     ebook-tools-dbg -> 0.2.2-4ubuntu2 with priority 1100
     libgwenhywfar-doc -> 5.1.3-1build1 with priority 1100
     libepub-dev -> 0.2.2-4ubuntu2 with priority 1100
     libgwengui-gtk3-dev -> 5.1.3-1build1 with priority 1100
     qml-module-qtav -> 1.13.0+ds-1build2 with priority 1100
     ubuntu-release-upgrader-gtk -> 1:20.04.23+p20.04+git20200729.0939 with priority 1100
     libqtav1 -> 1.13.0+ds-1build2 with priority 1100
     gwenhywfar-tools -> 5.1.3-1build1 with priority 1100
     libgwengui-qt5-dev -> 5.1.3-1build1 with priority 1100
     qtav-players -> 1.13.0+ds-1build2 with priority 1100
     zipcmp -> 1.5.1-0ubuntu1 with priority 1100
     ziptool -> 1.5.1-0ubuntu1 with priority 1100
     libgwengui-gtk3-0 -> 5.1.3-1build1 with priority 1100
     libgwengui-qt5-0 -> 5.1.3-1build1 with priority 1100
     base-files -> 11ubuntu5.1+p20.04+git20200727.1550 with priority 1100
     software-properties-qt -> 0.98.9.2 with priority 1100
     software-properties-qt -> 0.98.9 with priority 1100
     mysql-server-core-8.0 -> 0.4+p20.04+git20200818.0814 with priority 1100
     software-properties-common -> 0.98.9.2 with priority 1100
     software-properties-common -> 0.98.9 with priority 1100
User avatar claydoh
Registered Member
Posts
684
Karma
5
OS
sandro4912 wrote:does this ppa list help to troubleshoot it?



Not enough, as none of your PPAs or external repos have anything related to gcc in them.

This is the only place I could find gcc-9 versions for Ubuntu 18.04 is via a test build PPA
https://launchpad.net/~ubuntu-toolchain ... buntu/test
This has the exact version you have.

The list you have does not show any disabled PPAs.

You *should* be able to manually downgrade the packages to the correct stock versions lime so:
Code: Select all
sudo apt install gcc-9-base=9.3.0-10ubuntu2 libgcc-9-dev=9.3.0-10ubuntu2

and the like, but I have no idea how deep things will go, or how many 18.04-related packages you have, or what might be broken in the process.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
sandro4912
Registered Member
Posts
23
Karma
0
I tried to downgrade but then I get this mess:

Code: Select all
[email protected]:~$ sudo apt install gcc-9-base=9.3.0-10ubuntu2 libgcc-9-dev=9.3.0-10ubuntu2
[sudo] password for sandro:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 5
Starting 2 pkgProblemResolver with broken count: 5
Investigating (0) gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken gcc-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to gcc-9:amd64 10
  Removing gcc-9:amd64 rather than change gcc-9-base:amd64
Investigating (0) g++:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken g++:amd64 Depends on gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering gcc-9:amd64 10 as a solution to g++:amd64 5
  Removing g++:amd64 rather than change gcc-9:amd64
Investigating (0) cpp-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken cpp-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to cpp-9:amd64 5
  Removing cpp-9:amd64 rather than change gcc-9-base:amd64
Investigating (0) libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken libasan5:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to libasan5:amd64 4
  Removing libasan5:amd64 rather than change gcc-9-base:amd64
Investigating (0) g++-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken g++-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to g++-9:amd64 0
  Removing g++-9:amd64 rather than change gcc-9-base:amd64
Investigating (0) libstdc++-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken libstdc++-9-dev:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to libstdc++-9-dev:amd64 -1
  Removing libstdc++-9-dev:amd64 rather than change gcc-9-base:amd64
Investigating (1) libgcc-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD Ib >
Broken libgcc-9-dev:amd64 Depends on libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-10ubuntu2)
  Considering libasan5:amd64 4 as a solution to libgcc-9-dev:amd64 10001
  Added libasan5:amd64 to the remove list
  Fixing libgcc-9-dev:amd64 via keep of libasan5:amd64
Investigating (1) gcc:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken gcc:amd64 Depends on gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering gcc-9:amd64 10 as a solution to gcc:amd64 23
  Added gcc-9:amd64 to the remove list
  Fixing gcc:amd64 via keep of gcc-9:amd64
Investigating (1) cpp:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken cpp:amd64 Depends on cpp-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering cpp-9:amd64 5 as a solution to cpp:amd64 18
  Added cpp-9:amd64 to the remove list
  Fixing cpp:amd64 via keep of cpp-9:amd64
Investigating (1) build-essential:amd64 < 12.8ubuntu1 @ii mK Ib >
Broken build-essential:amd64 Depends on g++:amd64 < 4:9.3.0-1ubuntu2 @ii mR > (>= 4:9.2)
  Considering g++:amd64 5 as a solution to build-essential:amd64 12
  Added g++:amd64 to the remove list
  Fixing build-essential:amd64 via keep of g++:amd64
Investigating (1) gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken gcc-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to gcc-9:amd64 10
  Removing gcc-9:amd64 rather than change gcc-9-base:amd64
Investigating (1) g++:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken g++:amd64 Depends on g++-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering g++-9:amd64 0 as a solution to g++:amd64 5
  Added g++-9:amd64 to the remove list
Broken g++:amd64 Depends on gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering gcc-9:amd64 10 as a solution to g++:amd64 5
  Removing g++:amd64 rather than change gcc-9:amd64
Investigating (1) cpp-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken cpp-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to cpp-9:amd64 5
  Removing cpp-9:amd64 rather than change gcc-9-base:amd64
Investigating (1) libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken libasan5:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to libasan5:amd64 4
  Removing libasan5:amd64 rather than change gcc-9-base:amd64
Investigating (2) libgcc-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD Ib >
Broken libgcc-9-dev:amd64 Depends on libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-10ubuntu2)
  Considering libasan5:amd64 4 as a solution to libgcc-9-dev:amd64 10001
  Added libasan5:amd64 to the remove list
  Fixing libgcc-9-dev:amd64 via keep of libasan5:amd64
Investigating (2) gcc:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken gcc:amd64 Depends on gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering gcc-9:amd64 10 as a solution to gcc:amd64 23
  Added gcc-9:amd64 to the remove list
  Fixing gcc:amd64 via keep of gcc-9:amd64
Investigating (2) cpp:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken cpp:amd64 Depends on cpp-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering cpp-9:amd64 5 as a solution to cpp:amd64 18
  Added cpp-9:amd64 to the remove list
  Fixing cpp:amd64 via keep of cpp-9:amd64
Investigating (2) build-essential:amd64 < 12.8ubuntu1 @ii mK Ib >
Broken build-essential:amd64 Depends on g++:amd64 < 4:9.3.0-1ubuntu2 @ii mR > (>= 4:9.2)
  Considering g++:amd64 5 as a solution to build-essential:amd64 12
  Added g++:amd64 to the remove list
  Fixing build-essential:amd64 via keep of g++:amd64
Investigating (2) gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken gcc-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to gcc-9:amd64 23
  Removing gcc-9:amd64 rather than change gcc-9-base:amd64
Investigating (2) g++:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken g++:amd64 Depends on g++-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering g++-9:amd64 0 as a solution to g++:amd64 12
  Added g++-9:amd64 to the remove list
Broken g++:amd64 Depends on gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering gcc-9:amd64 10002 as a solution to g++:amd64 12
  Removing g++:amd64 rather than change gcc-9:amd64
Investigating (2) cpp-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken cpp-9:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to cpp-9:amd64 18
  Removing cpp-9:amd64 rather than change gcc-9-base:amd64
Investigating (2) libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mK Ib >
Broken libasan5:amd64 Depends on gcc-9-base:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD > (= 9.3.0-11ubuntu0~18.04.1)
  Considering gcc-9-base:amd64 10002 as a solution to libasan5:amd64 10001
  Removing libasan5:amd64 rather than change gcc-9-base:amd64
Investigating (3) libgcc-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD Ib >
Broken libgcc-9-dev:amd64 Depends on libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-10ubuntu2)
  Considering libasan5:amd64 10002 as a solution to libgcc-9-dev:amd64 10001
  Considering libasan5:amd64 10002 as a solution to libgcc-9-dev:amd64 10001
Investigating (3) gcc:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken gcc:amd64 Depends on gcc-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering gcc-9:amd64 10002 as a solution to gcc:amd64 23
  Removing gcc:amd64 rather than change gcc-9:amd64
Investigating (3) cpp:amd64 < 4:9.3.0-1ubuntu2 @ii mK Ib >
Broken cpp:amd64 Depends on cpp-9:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-3~)
  Considering cpp-9:amd64 10002 as a solution to cpp:amd64 18
  Removing cpp:amd64 rather than change cpp-9:amd64
Investigating (3) x11-xserver-utils:amd64 < 7.7+8 @ii mK Ib >
Broken x11-xserver-utils:amd64 Depends on cpp:amd64 < 4:9.3.0-1ubuntu2 @ii mR >
  Considering cpp:amd64 10002 as a solution to x11-xserver-utils:amd64 15
  Removing x11-xserver-utils:amd64 rather than change cpp:amd64
Investigating (3) plasma-workspace:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mK Ib >
Broken plasma-workspace:amd64 Depends on x11-xserver-utils:amd64 < 7.7+8 @ii mR >
  Considering x11-xserver-utils:amd64 10002 as a solution to plasma-workspace:amd64 14
  Removing plasma-workspace:amd64 rather than change x11-xserver-utils:amd64
Investigating (3) build-essential:amd64 < 12.8ubuntu1 @ii mK Ib >
Broken build-essential:amd64 Depends on gcc:amd64 < 4:9.3.0-1ubuntu2 @ii mR > (>= 4:9.2)
  Considering gcc:amd64 10002 as a solution to build-essential:amd64 12
  Removing build-essential:amd64 rather than change gcc:amd64
Investigating (3) libgcc-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mK Ib >
Broken libgcc-8-dev:amd64 Depends on libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 8.4.0-3ubuntu2)
  Considering libasan5:amd64 10002 as a solution to libgcc-8-dev:amd64 8
  Removing libgcc-8-dev:amd64 rather than change libasan5:amd64
Investigating (3) plasma-desktop:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mK Ib >
Broken plasma-desktop:amd64 Depends on plasma-workspace:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mR > (>= 4:5.14)
  Considering plasma-workspace:amd64 10002 as a solution to plasma-desktop:amd64 6
  Removing plasma-desktop:amd64 rather than change plasma-workspace:amd64
Investigating (3) libtool:amd64 < 2.4.6-14 @ii mK Ib >
Broken libtool:amd64 Depends on cpp:amd64 < 4:9.3.0-1ubuntu2 @ii mR >
  Considering cpp:amd64 10002 as a solution to libtool:amd64 5
  Removing libtool:amd64 rather than change cpp:amd64
Investigating (3) kinfocenter:amd64 < 4:5.19.4-0xneon+20.04+focal+build7 @ii mK Ib >
Broken kinfocenter:amd64 Depends on plasma-workspace:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mR > (>= 4:5.14)
  Considering plasma-workspace:amd64 10002 as a solution to kinfocenter:amd64 4
  Removing kinfocenter:amd64 rather than change plasma-workspace:amd64
Investigating (3) dh-autoreconf:amd64 < 19 @ii mK Ib >
Broken dh-autoreconf:amd64 Depends on libtool:amd64 < 2.4.6-14 @ii mR > (>= 2.4.2)
  Considering libtool:amd64 10002 as a solution to dh-autoreconf:amd64 4
  Removing dh-autoreconf:amd64 rather than change libtool:amd64
Investigating (3) libstdc++-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mK Ib >
Broken libstdc++-8-dev:amd64 Depends on libgcc-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mR > (= 8.4.0-3ubuntu2)
  Considering libgcc-8-dev:amd64 10002 as a solution to libstdc++-8-dev:amd64 2
  Removing libstdc++-8-dev:amd64 rather than change libgcc-8-dev:amd64
Investigating (3) xorg:amd64 < 1:7.7+19ubuntu14 @ii mK Ib >
Broken xorg:amd64 Depends on x11-xserver-utils:amd64 < 7.7+8 @ii mR >
  Considering x11-xserver-utils:amd64 10002 as a solution to xorg:amd64 1
  Removing xorg:amd64 rather than change x11-xserver-utils:amd64
Investigating (3) sddm-theme-breeze:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mK Ib >
Broken sddm-theme-breeze:amd64 Depends on plasma-workspace:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mR >
  Considering plasma-workspace:amd64 10002 as a solution to sddm-theme-breeze:amd64 1
  Removing sddm-theme-breeze:amd64 rather than change plasma-workspace:amd64
Investigating (3) plasma-workspace-wayland:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mK Ib >
Broken plasma-workspace-wayland:amd64 Depends on plasma-workspace:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mR > (= 4:5.19.4-0xneon+20.04+focal+build6)
  Considering plasma-workspace:amd64 10002 as a solution to plasma-workspace-wayland:amd64 1
  Removing plasma-workspace-wayland:amd64 rather than change plasma-workspace:amd64
Investigating (3) plasma-widgets-addons:amd64 < 4:5.19.4-0xneon+20.04+focal+build7 @ii mK Ib >
Broken plasma-widgets-addons:amd64 Depends on plasma-workspace:amd64 < 4:5.19.4-0xneon+20.04+focal+build6 @ii mR >
  Considering plasma-workspace:amd64 10002 as a solution to plasma-widgets-addons:amd64 1
  Removing plasma-widgets-addons:amd64 rather than change plasma-workspace:amd64
Investigating (3) gcc-8:amd64 < 8.4.0-3ubuntu2 @ii mK Ib >
Broken gcc-8:amd64 Depends on libgcc-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mR > (= 8.4.0-3ubuntu2)
  Considering libgcc-8-dev:amd64 10002 as a solution to gcc-8:amd64 1
  Removing gcc-8:amd64 rather than change libgcc-8-dev:amd64
Investigating (3) libobjc-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mK Ib >
Broken libobjc-8-dev:amd64 Depends on libgcc-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mR > (= 8.4.0-3ubuntu2)
  Considering libgcc-8-dev:amd64 10002 as a solution to libobjc-8-dev:amd64 1
  Removing libobjc-8-dev:amd64 rather than change libgcc-8-dev:amd64
Investigating (3) g++-8:amd64 < 8.4.0-3ubuntu2 @ii mK Ib >
Broken g++-8:amd64 Depends on gcc-8:amd64 < 8.4.0-3ubuntu2 @ii mR > (= 8.4.0-3ubuntu2)
  Considering gcc-8:amd64 10002 as a solution to g++-8:amd64 0
  Removing g++-8:amd64 rather than change gcc-8:amd64
Investigating (3) clang-8:amd64 < 1:8.0.1-9 @ii mK Ib >
Broken clang-8:amd64 Depends on libstdc++-8-dev:amd64 < 8.4.0-3ubuntu2 @ii mR >
  Considering libstdc++-8-dev:amd64 10002 as a solution to clang-8:amd64 0
  Removing clang-8:amd64 rather than change libstdc++-8-dev:amd64
Investigating (3) neon-desktop:amd64 < 4+p20.04+git20200803.1619 @ii mK NPb Ib >
Broken neon-desktop:amd64 Depends on kinfocenter:amd64 < 4:5.19.4-0xneon+20.04+focal+build7 @ii mR >
  Considering kinfocenter:amd64 10002 as a solution to neon-desktop:amd64 0
  Removing neon-desktop:amd64 rather than change kinfocenter:amd64
Investigating (3) ocaml-nox:amd64 < 4.08.1-8 @ii mK Ib >
Broken ocaml-nox:amd64 Depends on gcc:amd64 < 4:9.3.0-1ubuntu2 @ii mR >
  Considering gcc:amd64 10002 as a solution to ocaml-nox:amd64 0
  Removing ocaml-nox:amd64 rather than change gcc:amd64
Investigating (4) libgcc-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD Ib >
Broken libgcc-9-dev:amd64 Depends on libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-10ubuntu2)
  Considering libasan5:amd64 10002 as a solution to libgcc-9-dev:amd64 10001
  Considering libasan5:amd64 10002 as a solution to libgcc-9-dev:amd64 10001
Investigating (4) debhelper:amd64 < 12.10ubuntu1 @ii mK Ib >
Broken debhelper:amd64 Depends on dh-autoreconf:amd64 < 19 @ii mR > (>= 17~)
  Considering dh-autoreconf:amd64 10002 as a solution to debhelper:amd64 12
  Removing debhelper:amd64 rather than change dh-autoreconf:amd64
Investigating (4) libfindlib-ocaml-dev:amd64 < 1.8.1-1build3 @ii mK Ib >
Broken libfindlib-ocaml-dev:amd64 Depends on ocaml-nox-4.08.1:amd64 < none @un H >
  Considering ocaml-nox:amd64 10002 as a solution to libfindlib-ocaml-dev:amd64 3
  Removing libfindlib-ocaml-dev:amd64 rather than change ocaml-nox-4.08.1:amd64
Investigating (4) ocaml-compiler-libs:amd64 < 4.08.1-8 @ii mK Ib >
Broken ocaml-compiler-libs:amd64 Depends on ocaml-nox-4.08.1:amd64 < none @un H >
  Considering ocaml-nox:amd64 10002 as a solution to ocaml-compiler-libs:amd64 2
  Removing ocaml-compiler-libs:amd64 rather than change ocaml-nox-4.08.1:amd64
Investigating (4) ocaml-interp:amd64 < 4.08.1-8 @ii mK Ib >
Broken ocaml-interp:amd64 Depends on ocaml-compiler-libs:amd64 < 4.08.1-8 @ii mR > (= 4.08.1-8)
  Considering ocaml-compiler-libs:amd64 10002 as a solution to ocaml-interp:amd64 1
  Removing ocaml-interp:amd64 rather than change ocaml-compiler-libs:amd64
Investigating (4) libctypes-ocaml-dev:amd64 < 0.15.1-1build3 @ii mK Ib >
Broken libctypes-ocaml-dev:amd64 Depends on ocaml-nox-4.08.1:amd64 < none @un H >
  Considering ocaml-nox:amd64 10002 as a solution to libctypes-ocaml-dev:amd64 0
  Removing libctypes-ocaml-dev:amd64 rather than change ocaml-nox-4.08.1:amd64
Investigating (4) libllvm-9-ocaml-dev:amd64 < 1:9.0.1-12 @ii mK Ib >
Broken libllvm-9-ocaml-dev:amd64 Depends on libctypes-ocaml-dev-mhhn1:amd64 < none @un H >
  Considering libctypes-ocaml-dev:amd64 10002 as a solution to libllvm-9-ocaml-dev:amd64 0
  Removing libllvm-9-ocaml-dev:amd64 rather than change libctypes-ocaml-dev-mhhn1:amd64
Investigating (4) libintegers-ocaml-dev:amd64 < 0.3.0-1build1 @ii mK Ib >
Broken libintegers-ocaml-dev:amd64 Depends on ocaml-nox-4.08.1:amd64 < none @un H >
  Considering ocaml-nox:amd64 10002 as a solution to libintegers-ocaml-dev:amd64 0
  Removing libintegers-ocaml-dev:amd64 rather than change ocaml-nox-4.08.1:amd64
Investigating (5) libgcc-9-dev:amd64 < 9.3.0-11ubuntu0~18.04.1 -> 9.3.0-10ubuntu2 @ii pmD Ib >
Broken libgcc-9-dev:amd64 Depends on libasan5:amd64 < 9.3.0-11ubuntu0~18.04.1 @ii mR > (>= 9.3.0-10ubuntu2)
  Considering libasan5:amd64 10002 as a solution to libgcc-9-dev:amd64 10001
  Considering libasan5:amd64 10002 as a solution to libgcc-9-dev:amd64 10001
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgcc-9-dev : Depends: libasan5 (>= 9.3.0-10ubuntu2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], beerislife, Bing [Bot], Google [Bot], Majestic-12 [Bot], pasis, Sogou [Bot], YaCy [Bot]