Reply to topic

GIMP fails to open after Upgrade to 20.4 (GEGL pbm )

jeanjustin
Registered Member
Posts
4
Karma
0
Hi everyone

Sorry to be on the Kusers forum, I haven't found anything about GIMP here and I haven't got much experience of forums

I upgraded to Ubuntu 20.04 recently , I have kde Neon 5 19 4 and GIMP now tells me it won't open unless I update my old GEGL version
0 4 18 to at least version 0 4 22.

Using the terminal I did this and now have GEGL 0 4 22 3. But GIMP doesn't see it.... :'( :'(

see my log:

[email protected]:~$ sudo apt list --upgradable
[sudo] Mot de passe de lingyist :
En train de lister... Fait
[email protected]:~$ gegl

La commande « gegl » n'a pas été trouvée, mais peut être installée avec :

sudo apt install gegl

[email protected]:~$ sudo apt install gegl
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
appimagelauncher digikam-data ffmpegthumbs kde-style-breeze-qt4 kf5-kdepim-apps-libs-data libastro1 libgrantlee-textdocument5 libkf5libkdepimakonadi5 libkf5parts-plugins libmarblewidget-qt5-28 libpoppler87
libqt5serialport5 libshp2 libzip4 marble-data marble-plugins opencv-data phonon-backend-gstreamer python3-scour qapt-batch qml-module-qtwebkit scour xserver-xorg-video-intel-arbiter
xserver-xorg-video-intel-native-modesetting
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
libspiro1
Les NOUVEAUX paquets suivants seront installés :
gegl libspiro1
0 mis à jour, 2 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 39,7 ko dans les archives.
Après cette opération, 153 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de :1 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libspiro1 amd64 1:20190731-2 [16,2 kB]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 gegl amd64 0.4.22-3 [23,4 kB]
39,7 ko réceptionnés en 0s (176 ko/s)
Sélection du paquet libspiro1:amd64 précédemment désélectionné.
(Lecture de la base de données... 212982 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libspiro1_1%3a20190731-2_amd64.deb ...
Dépaquetage de libspiro1:amd64 (1:20190731-2) ...
Sélection du paquet gegl précédemment désélectionné.
Préparation du dépaquetage de .../gegl_0.4.22-3_amd64.deb ...
Dépaquetage de gegl (0.4.22-3) ...
Paramétrage de libspiro1:amd64 (1:20190731-2) ...
Paramétrage de gegl (0.4.22-3) ...

MY PROBLEM IS: how do I get GIMP to recognize my new GEGL version, since I can't even open the GIMP program.

Thank you for your help

jeanjustin


Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9) ...
User avatar claydoh
Registered Member
Posts
677
Karma
5
OS
Gimp is not KDE software, so it is not a common topic here.

Before the upgrade, were you using Gimp from a PPA? If so, which one?

Code: Select all
apt policy gimp

will show the version, package name, and possibly the source.

The upgrade process disables PPAs, and depending on which one was used, these unsupported third party repos can have package conflicts after an upgrade. But it should be fixable, with more info from you.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
jeanjustin
Registered Member
Posts
4
Karma
0
Hi Claydoh, thanks for trying to help me

I have entered your info in my terminal and am getting this


[email protected]:~$ apt policy gimp
gimp:
Installé : 2.10.18-1
Candidat : 2.10.18-1
Table de version :
*** 2.10.18-1 500
500 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 Packages
100 /var/lib/dpkg/status
[email protected]:~$

Can you make any sense out of it ?

Thanks
jeanjustin
Registered Member
Posts
4
Karma
0
claydoh wrote:Gimp is not KDE software, so it is not a common topic here.

Before the upgrade, were you using Gimp from a PPA? If so, which one?

Code: Select all
apt policy gimp

will show the version, package name, and possibly the source.

The upgrade process disables PPAs, and depending on which one was used, these unsupported third party repos can have package conflicts after an upgrade. But it should be fixable, with more info from you.



Hi claydoh,

A friend of mine has read my log and says I did not install GIMP from a PPA. Being a newbie I take it as true.
He suggests I disable my profile in my hidden files... whatever that means.... I'm not sure how to do it. Any idea?

Thnx
User avatar claydoh
Registered Member
Posts
677
Karma
5
OS
Hi claydoh,

A friend of mine has read my log and says I did not install GIMP from a PPA. Being a newbie I take it as true.
He suggests I disable my profile in my hidden files... whatever that means.... I'm not sure how to do it. Any idea?

Thnx


I have no idea what that means, to disable your profile. Perhaps your friend means to rename the folder /home/<your=username>/.config/GIMP
This is a hidden folder, so you need to enable that in Dolphin settings, or the key combo 'alt .'
Renaming or deleting it will clear your Gimp settings, and maybe fix the problem. I don't think it will, though.

the package gegl itself is not required for gimp, but the packages libgegl-0.4-0 and libgegl-common are needed. What version of these do you have installed?


Again, this is a Gimp issue, or rather an Ubuntu packaging one, not a KDE specific problem, so it is a little out of place here on this forum.

Last edited by claydoh on Wed Aug 26, 2020 3:50 pm, edited 1 time in total.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
jeanjustin
Registered Member
Posts
4
Karma
0
OK thank you, I'll go to another forum and ask them.

It's been helpful.

Jeanjustin
User avatar claydoh
Registered Member
Posts
677
Karma
5
OS
jeanjustin wrote:OK thank you, I'll go to another forum and ask them.

It's been helpful.

Jeanjustin


It is just that there may not be as much knowledge of a specific distro and their packaging systems here. You can still keep going here, since you have already provided a lot of info.

what versions of libgegl-0.4-0 and libgegl-common do you have? the apt policy command can be used again to provide the info.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dbergstein, gerdeg, Google [Bot], ipwizard, Majestic-12 [Bot], Wild_Penguin, Yahoo [Bot]