Reply to topic

USB3 and Sound Devices Problems with 20.4 Base

User avatar Kactux
Registered Member
Posts
3
Karma
0
After the 20.04 upgrade, my audio output and input devices aren't always recognized properly. I have also tried several clean installs from 2020821-0932.iso. I have tried Kernel 5.8. I have tried updating my BIOS. I tried changing the line of code to read: GRUB_CMDLINE_LINUX="iommu=soft" to get my USB3 to work and I have tried purging alsa pulseaudio kmix and reinstalling alsa pulseaudo plasma-pa pavucontroll-qt to get my audio to work. However they still don't work.

Upon occasional reboots sound devices kinda works sometimes but USB 3 never works. It is random though. Sometimes after rebooting audio output and mics are recognized but most times nothing is found. And the audio doesn't work unless I change ports. They don't remember which one was used last session, it's random, so it defaults to random device default settings. I found if I unplug all my USB devices and disabled my hdmi audio profile and just keep the internal 3.5mm line out soundcard then it is the only device left and pulse finds it but it doesn't actually work until I have changed the port to analog and then it works.

The the USB2 ports work fine but the USB3 ports are never recognized so no webcams, USB3 headphones, flash drives etc... are recognized anymore with USB3 either. Neon has always worked perfectly until this upgrade so it's probably something in the 20.04 base that is not right but I'm not sure what to do. I should also mention that all the same devices and ports still currently work perfectly in Manjaro and Windows.

CPU: 2015 Piledriver-Based AMD FX-8350 Black Edition Vishera 8-Core 4.0GHz (4.2GHz Turbo) Socket AM3+ Processor
Motherboard: 2015 MSI 970 Gaming AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX AMD
Graphics: 2019 AMD Radeon RX580 GTS Black Edition GDDR5 Part no: RX-580P8DBDR
Webcams: 2020 Logitech StreamCam and Logitech C920
Headphones: Corsiar Void PRo, Logitech G930 Wireless
Speakers: Bose companion Series II Multimedia Speaker System
duns
Registered Member
Posts
52
Karma
0
I have similar problems:
1) for sound, when it goes away, i use this code:
Code: Select all
sudo killall pulseaudio
and it works: the audio is back again.
2) USB: this is a very big bug: usb devices (and DVD as well) are not always recognized (sometimes yes, sometimes, no).
I have open a bug report here https://bugs.kde.org/show_bug.cgi?id=425794: I think that everybody has this problem should confirm there the problem.
SOLVED: in my pc the problem was nvidia drivers (remaining even after disinstalling nvidia graphic card).

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], kde-cfeck, Sogou [Bot]