Reply to topic

Plasma 5.20

User avatar kde-jriddell
Registered Member
Posts
75
Karma
2
OS

Plasma 5.20

Tue Oct 13, 2020 12:42 pm
Plasma 5.20 is out

The advice posted before should no longer be necessary, upgrade should now work first time, sorry for the faff

Last edited by kde-jriddell on Tue Oct 13, 2020 10:10 pm, edited 1 time in total.
heeen
Registered Member
Posts
3
Karma
0

Re: Plasma 5.20

Tue Oct 13, 2020 1:24 pm
If you have the following errors, do the above

Code: Select all
Fatal error: The following packages have unmet dependencies:
  libkwin4-effect-builtins1: Depends: libkwineffects12 (= 4:5.19.5-0xneon+20.04+focal+build14) but 4:5.20.0-0xneon+20.04+focal+build15 is to be installed
  kwin-common: Depends: kwin-data (= 4:5.19.5-0xneon+20.04+focal+build14) but 4:5.20.0-0xneon+20.04+focal+build15 is to be installed
               Depends: libkwineffects12 (= 4:5.19.5-0xneon+20.04+focal+build14) but 4:5.20.0-0xneon+20.04+focal+build15 is to be installed

Code: Select all
$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 5
Starting 2 pkgProblemResolver with broken count: 5
Investigating (0) kwin-common:amd64 < 4:5.19.5-0xneon+20.04+focal+build14 @ii mK Ib >
Broken kwin-common:amd64 Depends on kwin-data:amd64 < 4:5.19.5-0xneon+20.04+focal+build14 -> 4:5.20.0-0xneon+20.04+focal+build15 @ii umU > (= 4:5.19.5-0xneon+20.04+focal+build14)
  Considering kwin-data:amd64 4 as a solution to kwin-common:amd64 14
  Added kwin-data:amd64 to the remove list
Broken kwin-common:amd64 Depends on libkwineffects12:amd64 < 4:5.19.5-0xneon+20.04+focal+build14 -> 4:5.20.0-0xneon+20.04+focal+build15 @ii umU > (= 4:5.19.5-0xneon+20.04+focal+build14)
  Considering libkwineffects12:amd64 12 as a solution to kwin-common:amd64 14
  Added libkwineffects12:amd64 to the remove list
  Fixing kwin-common:amd64 via keep of kwin-data:amd64
  Fixing kwin-common:amd64 via keep of libkwineffects12:amd64
 Try to Re-Instate (0) libkwineffects12:amd64
Investigating (0) kwin-x11:amd64 < 4:5.19.5-0xneon+20.04+focal+build14 @ii mK Ib >
Broken kwin-x11:amd64 Depends on libkwinglutils12:amd64 < 4:5.19.5-0xneon+20.04+focal+build14 -> 4:5.20.0-0xneon+20.04+focal+build15 @ii umU > (= 4:5.19.5-0xneon+20.04+focal+build14)
  Considering libkwinglutils12:amd64 15 as a solution to kwin-x11:amd64 9
  Removing kwin-x11:amd64 rather than change libkwinglutils12:amd64
Investigating (0) plasma-discover:amd64 < 5.19.5-0xneon+20.04+focal+build10 @ii mK NPb Ib >
Broken plasma-discover:amd64 Depends on plasma-discover-common:amd64 < 5.19.5-0xneon+20.04+focal+build10 -> 5.20.0-0xneon+20.04+focal+build11 @ii umU > (= 5.19.5-0xneon+20.04+focal+build10)
  Considering plasma-discover-common:amd64 4 as a solution to plasma-discover:amd64 7
  Added plasma-discover-common:amd64 to the remove list
  Fixing plasma-discover:amd64 via keep of plasma-discover-common:amd64
Investigating (0) plasma-desktop:amd64 < 4:5.19.5-0xneon+20.04+focal+build9 -> 4:5.20.0-0xneon+20.04+focal+build11 @ii umU Ib >
Broken plasma-desktop:amd64 Breaks on user-manager:amd64 < 4:5.19.5-0xneon+20.04+focal+build10 @ii mK >
  Considering user-manager:amd64 -3 as a solution to plasma-desktop:amd64 6
  Added user-manager:amd64 to the remove list
  Conflicts//Breaks against version 4:5.18.4.1-0ubuntu1 for user-manager but that is not InstVer, ignoring
  Fixing plasma-desktop:amd64 via remove of user-manager:amd64
Investigating (0) kwin:amd64 < 4:5.18.5-0ubuntu0.1 @ii mK Ib >
Broken kwin:amd64 Depends on kwin-x11:amd64 < 4:5.19.5-0xneon+20.04+focal+build14 @ii mR >
  Considering kwin-x11:amd64 9 as a solution to kwin:amd64 5
  Removing kwin:amd64 rather than change kwin-x11:amd64
 Try to Re-Instate (0) kwin-data:amd64
 Try to Re-Instate (0) plasma-discover-common:amd64
Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  cracklib-runtime libcrack2 libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5 libpipewire-0.2-1 libpwquality-common libpwquality1
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  kwin kwin-x11 user-manager
The following packages have been kept back:
  kwin-data libkwineffects12 plasma-discover-common
The following packages will be upgraded:
  base-files bluedevil breeze breeze-cursor-theme breeze-gtk-theme drkonqi grub-theme-breeze kactivitymanagerd kde-cli-tools kde-cli-tools-data kde-config-gtk-style kde-config-gtk-style-preview kde-config-plymouth kde-config-screenlocker
  kde-config-sddm kde-style-breeze kde-style-oxygen-qt5 kdeplasma-addons-data kgamma5 khotkeys khotkeys-data kinfocenter kmenuedit kscreen ksshaskpass ksysguard ksysguard-data ksysguardd kwayland-integration kwin-addons kwin-style-breeze kwrited
  libcolorcorrect5 libkdecorations2-5v5 libkdecorations2private7 libkf5screen-bin libkf5screen7 libkf5sysguard-bin libkf5sysguard-data libkfontinst5 libkfontinstui5 libkscreenlocker5 libksgrd9 libksignalplotter9 libksysguardformatter1
  libksysguardsensorfaces1 libksysguardsensors1 libkwinglutils12 libkwinxrenderutils12 libkworkspace5-5 libnotificationmanager1 liboxygenstyle5-5 liboxygenstyleconfig5-5 libpam-kwallet-common libpam-kwallet5 libplasma-geolocation-interface5
  libpowerdevilcore2 libpowerdevilui5 libprocesscore9 libprocessui9 libtaskmanager6 libweather-ion7 milou neon-desktop neon-settings-2 oxygen-sounds plasma-browser-integration plasma-calendar-addons plasma-dataengines-addons plasma-desktop
  plasma-desktop-data plasma-nm plasma-pa plasma-runners-addons plasma-sdk plasma-thunderbolt plasma-vault plasma-wallpapers-addons plasma-widgets-addons plasma-workspace plasma-workspace-wallpapers plasma-workspace-wayland plymouth-theme-breeze
  polkit-kde-agent-1 powerdevil powerdevil-data qml-module-org-kde-ksysguard sddm-theme-breeze skypeforlinux systemsettings xdg-desktop-portal-kde
91 upgraded, 0 newly installed, 3 to remove and 3 not upgraded.
Need to get 216 MB of archives.
After this operation, 18.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
steveblezy
Registered Member
Posts
26
Karma
0

Re: Plasma 5.20

Tue Oct 13, 2020 1:59 pm
I did the upgrade just before this thread started through discover. My plasma session is a complete mess. All windows are missing the upper "title bar" with the minimize, maximize and close. The themes are completely changed, almost like the compositing is not active. When I open a wayland session, all is good but the plasma session is a complete mess. No multiple desktops and I cannot seem to be able to add them, etc.

Is there a way to "force" a complete reinstall of the update so I can repair the plasma session. Wayland is working well for 95% of the things that I need to do but it would be nice to have the plasma session back and running correctly

Steve
ccaillet
Registered Member
Posts
4
Karma
0

Re: Plasma 5.20

Tue Oct 13, 2020 2:05 pm
Hi all,

You only need to install the package kwin-x11 then logout and login ...

For me here it has worked well

Bye
User avatar gerdeg
Registered Member
Posts
6
Karma
0
OS

Re: Plasma 5.20

Tue Oct 13, 2020 2:08 pm
steveblezy wrote:I did the upgrade just before this thread started through discover. My plasma session is a complete mess. All windows are missing the upper "title bar" with the minimize, maximize and close. The themes are completely changed, almost like the compositing is not active. When I open a wayland session, all is good but the plasma session is a complete mess. No multiple desktops and I cannot seem to be able to add them, etc.

Is there a way to "force" a complete reinstall of the update so I can repair the plasma session. Wayland is working well for 95% of the things that I need to do but it would be nice to have the plasma session back and running correctly

Steve


I had exactly the same situation. No shortcuts to close a window either. So I concluded: kwin is not there. I opened Konsole, typed kwin and indeed, I had to install kwin-x11. After I did that and restarted everything was normal again. So perhaps that is the solution for you, too. I wish you luck.
steveblezy
Registered Member
Posts
26
Karma
0

Re: Plasma 5.20

Tue Oct 13, 2020 2:15 pm
Thank you ccaillet!!!!!!
Just did the kwin-x11 and is seems to resolve the issue for me.

Steve
acrux
Registered Member
Posts
31
Karma
1
OS

Re: Plasma 5.20

Tue Oct 13, 2020 2:42 pm
kde-jriddell wrote:Plasma 5.20 is out

To upgrade on neon you may need to update the neon-settings-2 package first

```apt install neon-settings-2```


Yes, that did the trick, no unresolved dependencies afterwards :)
nodenoise
Registered Member
Posts
1
Karma
0

Re: Plasma 5.20

Tue Oct 13, 2020 3:28 pm
I can confirm the same symptoms (plus more... the occasionally not-working qwerty keyboard...) as Steve and that the fix of installing kwin-x11 worked for me as well (for the window decoration problem.) Thanks for the fix.
User avatar kde-jriddell
Registered Member
Posts
75
Karma
2
OS

Re: Plasma 5.20

Tue Oct 13, 2020 10:10 pm
This should no longer be necessary upgrade should now work first time, sorry for the faff
beerislife
Registered Member
Posts
3
Karma
0

Re: Plasma 5.20

Wed Oct 14, 2020 12:12 am
Same problem here when I updated last night. Slightly sober this morning and now fixed!

Cheers for the massive update!
User avatar marcelfox
Registered Member
Posts
7
Karma
0
OS

Re: Plasma 5.20

Wed Oct 14, 2020 11:57 am
ccaillet wrote:Hi all,

You only need to install the package kwin-x11 then logout and login ...

For me here it has worked well

Bye


I was facing the same issue, just upgraded from Discover and suddenly my workspace become a mess as well.

This did the trick for me also! =)
nullpointerrg
Registered Member
Posts
1
Karma
0

Re: Plasma 5.20

Wed Oct 14, 2020 2:12 pm
I have tried all of these options after performing the update to Plasma 5.20, and nothing has worked. Plasmashell is running, but i have no widgets. I am able to Ctrl_Esc to run System Activity and use it to open Konsole so I can run a web browser. I also tried downgrading the Wayland server as suggested by pointieststick.com using
sudo apt-get install libkwaylandserver5=5.19.5-0xneon+20.04+focal+build10. This just tells me Version '5.19.5-0xneon+20.04+focal+build10' for 'libkwaylandserver5' was not found. Not sure what else to try at this point. Suggestions?
User avatar kdeoldster
Registered Member
Posts
56
Karma
0
OS

Re: Plasma 5.20

Wed Oct 14, 2020 6:54 pm
I did the upgrade to Plasma 5.20 last night on laptop and desktop without any issues. Thanks to the devs and bug squad for fixing the issues! :)
terra
Registered Member
Posts
1
Karma
0

Re: Plasma 5.20

Thu Oct 15, 2020 8:31 am
Even with my system up to date, I am still with KDE neon Plasma 5.18 ( KDE Plasma Version 5.18.6 plasma LTS edition) . Any advice please ?

 
Reply to topic

Bookmarks



Who is online

Registered users: ab, Baidu [Spider], Bing [Bot], claydoh, DeMus, Google [Bot], ipwizard, Sogou [Bot], whirlwind