Reply to topic

Windows lost shadows

User avatar gerdeg
Registered Member
Posts
17
Karma
0
OS

Windows lost shadows

Wed Nov 04, 2020 8:33 am
SInce yesterday evening the windows on my laptop KDE Neon (up to date) lost their shadows. Is it me or an update :-) I did not change anything (as far as I know). Has anyone the same experience? Is there a solution for something like this?
User avatar mchnz
Registered Member
Posts
2
Karma
0

Re: Windows lost shadows

Thu Nov 05, 2020 10:58 pm
gerdeg wrote:SInce yesterday evening the windows on my laptop KDE Neon (up to date) lost their shadows. Is it me or an update :-) I did not change anything (as far as I know). Has anyone the same experience? Is there a solution for something like this?


Normally when that happens to me it's because compositing has been disabled due to some glitch.

The compositor can be re-enabled by going to System Settings->Display and Monitor->Compositor. If Compositing is disabled, there will be a warning on that option window. Most recently after reenabling the compositor I also had to toggle the rendering backend to force the UI to enable the Apply button (not sure why, perhaps I did something wrong or wasn't paying attention).

This happens every now and then, and I sometimes don't notice, so I have a check-compositor script set to run at login to warn me, it might be useful to run the qdbus query to find out if this is the case for you too:
Code: Select all
#!/bin/bash
#set -x

compositor_enabled=$(qdbus-qt5 org.kde.KWin /Compositor org.kde.kwin.Compositing.active)

if [ "$compositor_enabled" != "true" ]
then
     notify-send -a "Check Compositor" -t 0 -i dialog-error.png 'Hardware -> Display and Monitor -> Compositor is disabled!'
fi
User avatar gerdeg
Registered Member
Posts
17
Karma
0
OS

Re: Windows lost shadows  Topic is solved

Fri Nov 06, 2020 5:55 am
Thank you very much, that did the trick.
I vaguely remember there were two updates that day with something like 'org.freedesktop' and 'nvidia', updates in the Flatpack-environment. Perhaps that caused the glitch.
User avatar gerdeg
Registered Member
Posts
17
Karma
0
OS

Re: Windows lost shadows

Wed Nov 18, 2020 1:21 pm
Today the same glitch after the update of the package org.freedesktop.Platform.GL.nvidia-450-80-02 in the Flatpack-environment. How is that even possible? This happens only on my laptop (which was upgraded to 20.04 LTS), my two desktopcomputers (whit a clean install of 20.04 LTS) are not effected.

gerdeg wrote:I vaguely remember there were two updates that day with something like 'org.freedesktop' and 'nvidia', updates in the Flatpack-environment. Perhaps that caused the glitch.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], clh333, Google [Bot], robertotamburrino, rtokumori, Sogou [Bot], YaCy [Bot]