Reply to topic

Verbose details shown during boot and shut down every time

fabgrel10
Registered Member
Posts
4
Karma
0
This is an issue that has intrigued me a long time ago: every time I perform a clean installation of KDE Neon, after a day or two, usually after receiving the first massive update of Plasma components, verbose messages start showing on every boot and on every shut down, a small annoyance I know. However, I'd like to know if there's a way to deactivate this messages and only show the black screen before entering the login credentials as normal. I tried a solution involving modifying the grub (sudo nano /etc/default/grub) but this does not apply to Neon. Any suggestion is welcomed.
User avatar thunder422
Registered Member
Posts
71
Karma
1
OS
I'd actually like to have the opposite - always show these messages. I hate the black screen and like to see that it is doing something; a black screen makes me nervous that it is not doing anything, or got stuck (same thing with Windows stupid spinning dots). (Guess I'm in the [extreme] minority here.)


Currently using KDE Neon 5.20.5 and 5.19.4 (run Windows 10 in a VM); migrated from Linux Mint 17.3
benkovsky
Registered Member
Posts
1
Karma
0
I have the same problem and also after installing KDE Neon after a clean install the system starts in about 20 seconds, but after the update, it starts booting with this screen and the boot time is doubled. I do not have another operating system installed on the machine.
https://photos.app.goo.gl/rGpDPe9GKcQ6GJje6
koffeinfriedhof
Registered Member
Posts
317
Karma
2
OS
Use quiet and splash in GRUB_CMDLINE_LINUX_DEFAULT. For current state use `cat /proc/cmdline`
Code: Select all
[email protected][~/]> grep -Ev '^#|^$' /proc/cmdline /etc/default/grub
/proc/cmdline:BOOT_IMAGE=/boot/vmlinuz-5.4.0-70-generic root=UUID=030cc118-78bb-4f89-9e92-2fdb00e3c2d9 ro quiet splash vt.handoff=7
/etc/default/grub:GRUB_DEFAULT=0
/etc/default/grub:GRUB_TIMEOUT_STYLE=hidden
/etc/default/grub:GRUB_TIMEOUT=0
/etc/default/grub:GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
/etc/default/grub:GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
/etc/default/grub:GRUB_CMDLINE_LINUX=""
[email protected][~/]>

This options should hide most things. Don't forget to update grub after changing it!

thunder422 wrote:I'd actually like to have the opposite - always show these messages.

in /etc/default/grub disable plymouth using the option »noplymouth« and remove the »quiet« and »splash« entries. Optional there are debug modes available to really spam messages, e.g. BOOT_DEBUG=3. See Kernel-Parameters for details.
fabgrel10
Registered Member
Posts
4
Karma
0
Unfortunately, in KDE Neon, there is no grub file in that location (
Code: Select all
/etc/default/grub
) @koffeinfriedhof
koffeinfriedhof
Registered Member
Posts
317
Karma
2
OS
Code: Select all
[email protected][~]> cat /etc/os-release && ls -lha /etc/default/grub
NAME="KDE neon"
VERSION="5.21"
ID=neon
ID_LIKE="ubuntu debian"
PRETTY_NAME="KDE neon User Edition 5.21"
VARIANT="User Edition"
VARIANT_ID=user
VERSION_ID="20.04"
HOME_URL="https://neon.kde.org/"
SUPPORT_URL="https://neon.kde.org/"
BUG_REPORT_URL="https://bugs.kde.org/"
LOGO=start-here-kde-neon
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal
-rw-r--r-- 1 root root 1.2K Apr  7 17:59 /etc/default/grub
[email protected][~]>


Thats on my neon UserEdition. How did you install it?
fabgrel10
Registered Member
Posts
4
Karma
0
Hello again koffeinfriedhof, I have to mention that my laptop has two SSD, I use one for KDE Neon and the other for Windows 10, no idea if this is related or not. In a previous installation I used Ventoy and the iso from KDE Neon, I noticed I wasn't able to select where to install de bootloader as shown on some tutorials. With my current installation I decided to burn the iso in Windows using Rufus, same result. With Ubiquity I don't have this problem and I don't need to create the extra boot-efi partition requested by the calamares installer, probably this has something to do indeed.

In both cases my laptop behaves normal, no verbose messages, only the grub screen and then the login screen. It's always after the first massive update of plasma that I started reciting the messages on boot/shutdown and when looking in /etc/default/ there's no grub file, there's only a default.d folder. cat /etc/os-release shows the same information, ls -lha /etc/default/grub says the file doesn't exist.

I also found this post referencing the absence of grub file in KDE Neon: https://www.kubuntuforums.net/showthread.php/71346-KDE-Neon-Grub-Edit
fabgrel10
Registered Member
Posts
4
Karma
0
Never mind is finally solved now, following uggestions from __HumbleBee__ from this Reddit post. ^-^
koffeinfriedhof
Registered Member
Posts
317
Karma
2
OS
Thats interesting. Why do I have this file in my neon installation? Perhaps an older installation or some experiments. I don't use it that often as my daily drivers are all arch without grub and I mostly use neon in a virtual machine. This time I'm using a native installation. Perhaps I had a similar issue and solved it by using the same solution, but I really cannot remember.

So you've changed the boot splash theme in system settings or did you create a /etc/default/grub with `GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"` and update-grub? Thanks for sharing your solution! ;)
fabgrel10
Registered Member
Posts
4
Karma
0
These are the steps that I followed:

Code: Select all
sudo cp /usr/share/grub/default/grub /etc/default

sudo nano /etc/default/grub/

And removed everything except the part GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

sudo update-grub


In case somebody else face the same issue ;)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], koffeinfriedhof, Majestic-12 [Bot], mouse, plistov, reevz, smankowski, Sogou [Bot]