Reply to topic

Offline solver not working

thutchison
Registered Member
Posts
1
Karma
0

Offline solver not working

Fri Aug 23, 2019 8:34 pm
I have KStars 3.2.2 installed on my Mac and am connecting to equipment through an indigosky server running on a Raspberry Pi computer. I also have Cloudmakers software installed on the same Mac.

The astrometry.net interface from Cloudmakers solves an image in ~4-5 seconds.

The offline solver for KStars/Ekos times out after 180 seconds.

The offline solver configuration for Ekos is using the same location for index files as the Cloudmakers Astrometry module, so I believe they are using the same solving subsystem. I cannot figure out why KStars/Ekos cannot solve an image.

I would appreciate any help anyone can offer.

Thank you in advance for your assistance.
Tim.
stanleyf
Registered Member
Posts
4
Karma
0

Re: Offline solver not working

Tue Dec 24, 2019 9:10 pm
I just tried out plate solving on my Air using kStars v3.3.8. Plate solving using astrometry immediately crashes using the downloaded Astrometry files (which had previously worked on an earlier version of kStars). I copied the text from the kStars output into Terminal as you suggested—here is a copy of my Terminal session. The dreaded return of the Illegal Instruction:

Last login: Sun Dec 22 16:19:11 on ttys000

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
Basidium:~ sf$ export PATH=/Applications/KStars.app/Contents/MacOS/netpbm/bin:/usr/local/opt/python/libexec/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin
Basidium:~ sf$ /Applications/KStars.app/Contents/MacOS/astrometry/bin/solve-field -O --no-plots --no-verify --resort --downsample 2 -3 310.525 -4 45.3542 -5 30 --config /Applications/KStars.app/Contents/MacOS/astrometry/bin/astrometry.cfg -W /private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/solution.wcs /private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/fitsufEmps.fits
Reading input file 1 of 1: "/private/var/folders/vd/vwnkltm92sx93mrg14plg82r0000gn/T/fitsufEmps.fits"...
Illegal instruction: 4
Basidium:~ sf$

Note: as before, it’s only the offline Astrometry which crashes. Using the online version works fine. Too bad my observing location has now internet available!

Any help would certainly be appreciated!

Thanks,
stan in Brooklyn

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Bucham, debugster, Google [Bot], ipwizard, lwalper, therealkizu, Yahoo [Bot]