Topic locked

Kwin desktop effects not working after custom kernel

Gumper
Registered Member
Posts
27
Karma
0
I had to install a patched kernel on my openSUSE installation and now it appears that the desktop effects are no longer working. Initially after installing the kernel I had problems getting the ATI drivers installed and working but I have since be able to solve that problem. I'm able to get the special effects to work in Compiz but I prefer Kwin's special effects.

When I select "Enable desktop effects" and then apply I get the following message in a pop up window:

Code: Select all
Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.


Any ideas on how I can get Kwin to work properly? I haven't tried reinstalling it yet. Does it somehow need to be compiled against my new kernel?

Thanks


Gumper, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
You do not need to reinstall. The ATI 3D driver component which provides direct access to the Graphics card lives in the kernel and thus cannot be loaded in a different version other than what it is meant for. You will need to reinstall / recompile the ATI driver. I have no experience with ATI drivers however, and cannot help you at all with regard to that procedure.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
Gumper
Registered Member
Posts
27
Karma
0
bcooksley wrote:You do not need to reinstall. The ATI 3D driver component which provides direct access to the Graphics card lives in the kernel and thus cannot be loaded in a different version other than what it is meant for. You will need to reinstall / recompile the ATI driver. I have no experience with ATI drivers however, and cannot help you at all with regard to that procedure.


The ATI driver works fine. I had to reinstall it and compile it against the new kernel. The problem that I'm having is with Kwin working, or should I say not working. The special effects from Kwin don't work at all. I was wondering if removing and reinstalling "kde4-kwin" would fix the problem or would it break something?


Gumper, proud to be a member of KDE forums since 2008-Oct.
XiniX
Registered Member
Posts
217
Karma
1
OS
I had a similar issue when in Arch I had installed Xorg from testing and then went back. I don't know what happened, but I logged on to a Failsafe session from KDM and then logged in to a regular KDE4 session and it started working again. As if KDE maintains a file that prohibits it from using accelerated graphics until the session is reset or something. Might work for you.

EDIT
I found out it had something to do with my user account, since logging in to another account allowed me to use desktop effects. If that is your case as well, it is definitely a user related thing.

Last edited by XiniX on Tue Oct 21, 2008 11:44 am, edited 1 time in total.


XiniX, proud to be a member of KDE forums since 2008-Oct.
User avatar sebas
KDE Developer
Posts
88
Karma
2
OS
For compositing, you need the xorg driver and the kernel module. The desktop will work with only the xorg module, but you won't get OpenGL (which you want for compositing).

lsmod should show fglrx.ko loaded when you start X. A peek into /var/log/xorg.0.log should reveal problems with acceleration.


-- sebas
Gumper
Registered Member
Posts
27
Karma
0
Ok so I got it going....for the most part:-) I was able to get Kwin working by entering

Code: Select all
kwin --replace &


in a terminal. Now my windows decorations are back to normal and the desktop effects work. Sort of anyhow. The only thing that I can see that doesn't appear to be working correctly at this point is the wobbly windows option. When I have that turned on in conjunction with the translucency option and I move a window, the window disappears. If I turn off the translucency option, I get the wobbly window by it's a solid black window.

Oh well, I'm getting closer. ;-)[hr]
Ok, so now everything is working fine. To fix the wobbly window I had to change the "Texture filter" under the "OpenGL options".

Life is good now :shade:

Last edited by Gumper on Wed Oct 22, 2008 2:53 am, edited 1 time in total.


Gumper, proud to be a member of KDE forums since 2008-Oct.
Witwe_Bolte
Registered Member
Posts
10
Karma
0
same prob here: opensuse10.3 Radeon 9600.
kwin --restart doesn't do anything.
modinfo fglrx says that fglrx.ko is loaded.
a piece of xorg.0.log:
LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules//drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
compiled for 7.1.0, module version = 8.52.3
Module class: X.Org Video Driver


Witwe_Bolte, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
@Witwe_Bolte: Please start a new thread for your problem. This one is solved, and your problem appears unrelated as the kernel module has loaded for you.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Topic locked

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Exabot [Bot], farid, gerdeg, Google [Bot], Merlimau, rubendecrop

cron