Reply to topic

Power management activities settings not working

whatthefunk
Registered Member
Posts
61
Karma
0
Hi all,
Running KDE 4.8 on Kubuntu 11.10. I have a movies activity set up and have set the power management settings so that the screen will never dim or turn off in this activity. However, the settings seem to be completely ignored and settings for the main activity are followed instead. Ive tried using the "Define a special behavior" settings and the "Use separate settings" settings but neither one will work.

It is also interesting to note that KDE will never shut down the screen with Dragon Player regardless of the power settings, but will dim the screen when using nearly every other media player (Im using VLC).

Any help?
whatthefunk
Registered Member
Posts
61
Karma
0
Update: Been messing around with this (actually trying to watch a movie) and the power management seems to be broken altogether. I turned off all power management settings in the main interface as well as for the activities. Still turning off my monitor every ten minutes. It doesnt require a reboot for the settings to take affect does it?
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
If you start a clean user, and try to minimally apply Power Management settings, does this take effect?

If so, does logging out and back in cause the settings to be correctly reapplied?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
swex
Registered Member
Posts
1
Karma
0
OS
I've got the same trouble, using kubuntu 11.10 with backports repo.
whatthefunk
Registered Member
Posts
61
Karma
0
Finally have had time to play around with this.

The problem seems to be limited to my main profile. I created a new profile and all power management settings worked fine. How do I get power management to work again in my main profile?
whatthefunk
Registered Member
Posts
61
Karma
0
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
I would recommend reseting your Power Management settings to attempt to repair this. Using a virtual terminal, whilst logged out of KDE, please run the following command:
Code: Select all
rm $(kde4-config --localprefix)/share/config/powermanagementprofilesrc


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
whatthefunk
Registered Member
Posts
61
Karma
0
Tried that...no dice.

Just so we're clear about "whilst logged out of KDE" part, I logged out and opened a terminal from the login screen, then deleted the powermanagement file at ~/.kde4/share/config/powermanagementprofilesrc Is that what you meant?
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
Correct. So to confirm it does work correctly under a new user (even after logging out and back in) but does not under your current user? If so, this is very strange and may indicate some link to activities...


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
whatthefunk
Registered Member
Posts
61
Karma
0
Just rechecked everything. The new user power management is also now broken (dont think I checked after logging out before). So it seems that if I make a new user, the power management settings only last for one session and then break.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
Ok, I have a suspicion here about what is happening.
Under the new user, try running the following after logging in:
Code: Select all
qdbus org.kde.Solid.PowerManagement /org/kde/Solid/PowerManagement reparseConfiguration


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
whatthefunk
Registered Member
Posts
61
Karma
0
That didnt do anything. Did the command, set the Power Management settings to turn off the screen after one minute and nothing happened. I logged out and logged in again and tried once again but still nothing happened.
whatthefunk
Registered Member
Posts
61
Karma
0
Bump.

Anybody??
c0gnu5
Registered Member
Posts
1
Karma
0
I believe I found the answer. I was trying to solve the same issue and it seems it's been around for a while. It isn't just KDE because the solution came from a Gnome user. Anyway, this worked for me.

Turn off Power Management.

Computer -> System Settings -> Startup and Shutdown
(On the left, select) Service Manager

On the lower right there is a list of startup services. Uncheck the box for Power Management. This ~should~ prevent this from happening when you restart the system.

Also be sure to click the Stop button (bottom right) and that should fix the current session.

I haven't had time to run an overnight session yet to see if it may shut down after a few hours, but it doesn't shut down after 10 minutes any more. It's also interesting to note that, if you look at Power Profiles in System Settings, everything is checked and set to 1 minute - I assume like setting things to zero to mean never.
whatthefunk
Registered Member
Posts
61
Karma
0
c0gnu5 wrote:I believe I found the answer. I was trying to solve the same issue and it seems it's been around for a while. It isn't just KDE because the solution came from a Gnome user. Anyway, this worked for me.

Turn off Power Management.

Computer -> System Settings -> Startup and Shutdown
(On the left, select) Service Manager

On the lower right there is a list of startup services. Uncheck the box for Power Management. This ~should~ prevent this from happening when you restart the system.

Also be sure to click the Stop button (bottom right) and that should fix the current session.

I haven't had time to run an overnight session yet to see if it may shut down after a few hours, but it doesn't shut down after 10 minutes any more. It's also interesting to note that, if you look at Power Profiles in System Settings, everything is checked and set to 1 minute - I assume like setting things to zero to mean never.


That seems to break everything. When power management is "on" after 10 minutes the screens will dim unless I am active or playing a video in Dragon Player. With power management "off" the screens turn off after ten minutes, even while running Dragon Player.

Im curious if other people have this problem and just dont realize it. Can some of you set your power management settings to dim the screen after one minute and then see if it works??

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, claydoh, farid, Google [Bot], nocruoro, tymond