Reply to topic

/usr/bin/startkde gone

User avatar mogliii
Registered Member
Posts
73
Karma
0
OS

/usr/bin/startkde gone

Sat Sep 15, 2012 5:01 pm
A strange thing has happened. I have Kubuntu 12.04 and it was running two days ago. Yesterday I turned on the computer remote, but did not start any graphical session.

Now I just wanted to login (lightkdm), and after typing password I got a message that /usr/bin/startkde cannot be found, and its falling back to default session (now I'm in xfce).

i checked and there is not startkde anywhere. When typing startkde in the terminal I get
Code: Select all
The program 'startkde' is currently not installed.  You can install it by typing:
sudo apt-get install kde-workspace-bin


When i try to install kde-workspace-bin I get
Code: Select all
sudo apt-get install kde-workspace-bin
Reading package lists... Done
Building dependency tree... 50%
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 kde-workspace-bin : Depends: libkephal4abi1 (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: libkscreensaver5 (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: libplasmagenericshell4 (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: libprocesscore4abi1 (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: libprocessui4a (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: libsolidcontrol4abi2 (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: libsolidcontrolifaces4abi2 (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: plasma-desktop (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed or
                              plasma-netbook (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed or
                              plasma-active but it is not going to be installed
                     Depends: kde-workspace-data (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
                     Depends: kde-workspace-kgreet-plugins (= 4:4.8.5-0ubuntu0.1~ppa3) but 4:4.9.0-0ubuntu2~precise1~ppa1 is to be installed
E: Unable to correct problems, you have held broken packages.


I had backbport repositories activated (deactivated now). How can I solve this?
User avatar mogliii
Registered Member
Posts
73
Karma
0
OS

Re: /usr/bin/startkde gone

Sat Sep 15, 2012 5:03 pm
Now I reactivated the backport and I see

Code: Select all
 sudo apt-get install kde-workspace-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  kde-window-manager kde-window-manager-common kde-workspace-data kde-workspace-kgreet-plugins kdelibs-bin
  kdelibs5-data kdelibs5-dbg kdelibs5-dev kdelibs5-plugins kdepimlibs-kio-plugins kdm kdoctools kinfocenter
  ksysguard ksysguardd libakonadi-calendar4 libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadi-notes4 libkabc4 libkalarmcal2 libkblog4 libkcal4 libkcalcore4 libkcalutils4 libkcmutils4
  libkde3support4 libkdeclarative5 libkdecorations4abi1 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkephal4abi1 libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4 libkio5
  libkjsapi4 libkjsembed4 libkldap4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4
  libkresources4 libkrosscore4 libkrossui4 libkscreensaver5 libksgrd4 libksignalplotter4 libktexteditor4 libktnef4
  libkunitconversion4 libkutils4 libkwineffects1abi4 libkwinglutils1abi1 libkwinnvidiahack4 libkworkspace4abi2
  libkxmlrpcclient4 libmailtransport4 libmicroblog4 libnepomuk4 libnepomukquery4a libnepomukutils4
  libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi3 libplasmagenericshell4 libprocesscore4abi1
  libprocessui4a libsolid4 libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libsyndication4 libtaskmanager4abi3
  libthreadweaver4 libweather-ion6 plasma-dataengines-workspace plasma-desktop plasma-netbook
  plasma-widgets-workspace
Suggested packages:
  plasma-scriptengines hspell
Recommended packages:
  kde-workspace
The following NEW packages will be installed
  kde-workspace-bin
The following packages will be upgraded:
  kde-window-manager kde-window-manager-common kde-workspace-data kde-workspace-kgreet-plugins kdelibs-bin
  kdelibs5-data kdelibs5-dbg kdelibs5-dev kdelibs5-plugins kdepimlibs-kio-plugins kdm kdoctools kinfocenter
  ksysguard ksysguardd libakonadi-calendar4 libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadi-notes4 libkabc4 libkalarmcal2 libkblog4 libkcal4 libkcalcore4 libkcalutils4 libkcmutils4
  libkde3support4 libkdeclarative5 libkdecorations4abi1 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkephal4abi1 libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4 libkio5
  libkjsapi4 libkjsembed4 libkldap4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4
  libkresources4 libkrosscore4 libkrossui4 libkscreensaver5 libksgrd4 libksignalplotter4 libktexteditor4 libktnef4
  libkunitconversion4 libkutils4 libkwineffects1abi4 libkwinglutils1abi1 libkwinnvidiahack4 libkworkspace4abi2
  libkxmlrpcclient4 libmailtransport4 libmicroblog4 libnepomuk4 libnepomukquery4a libnepomukutils4
  libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi3 libplasmagenericshell4 libprocesscore4abi1
  libprocessui4a libsolid4 libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libsyndication4 libtaskmanager4abi3
  libthreadweaver4 libweather-ion6 plasma-dataengines-workspace plasma-desktop plasma-netbook
  plasma-widgets-workspace
98 upgraded, 1 newly installed, 0 to remove and 328 not upgraded.
Need to get 123 MB of archives.
After this operation, 11.1 MB of additional disk space will be used.
Do you want to continue [Y/n]?


Is it safe to proceed?
User avatar google01103
Manager
Posts
6668
Karma
25

Re: /usr/bin/startkde gone  Topic is solved

Sat Sep 15, 2012 5:35 pm
Seems that you will be up'ing to KDE 4.9.0, is that your intent? 4.9 should be fine, I'm running 4.9.1 no issues but there is always risk in any upgrade.

If you disable the backport-ppa and run "sudo apt-get install kde-workspace-bin" does that work?

Could be when you ran the install not all of the backport-ppa was populated and therefore apt attempted to install the package and it's dependencies from 2 different ppa's


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar mogliii
Registered Member
Posts
73
Karma
0
OS

Re: /usr/bin/startkde gone

Sat Sep 15, 2012 6:57 pm
OK, KDE running again, now on 4.9.1

Everything seems to work. But I remain puzzled how this intermediate state happened. I have automatic update installation disabled.

Strange indeed.
User avatar mogliii
Registered Member
Posts
73
Karma
0
OS

Re: /usr/bin/startkde gone

Sat Sep 15, 2012 6:58 pm
google01103 wrote:If you disable the backport-ppa and run "sudo apt-get install kde-workspace-bin" does that work?


I tried, but it said that kde-workspace-bin cannot be downloaded (with backport disabled)
User avatar bcooksley
Administrator
Posts
19757
Karma
86
OS

Re: /usr/bin/startkde gone

Sun Sep 23, 2012 3:09 am
It seems that somehow or another the package was uninstalled, likely because it conflicted with another package when that was installed. As long as you did not logoff, you would not have noticed unfortunately.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: alvinwong, Baidu [Spider], bartoloni, Bing [Bot], boudewijn, cmb, CnZhx, draftman, Exabot [Bot], Google [Bot], ipwizard, kolli, Roniou2, Sogou [Bot], stephanesp, Will_S., Yahoo [Bot]