Reply to topic

Disable bookmark searching in Kickoff

mooop12
Registered Member
Posts
6
Karma
0
Is this even possible? In Krunner you can edit what is included in search results, but in Kickoff search it just seems to mash everything together and show you the result...
User avatar google01103
Manager
Posts
6668
Karma
25
if you use Lancelot instead it is possible

Lancelot Launcher Settings -> menu -> search


OpenSuse Leap 42.1 x64, Plasma 5.x

syockit
Registered Member
Posts
1
Karma
0
I tried editing the whitelist in ~/.kde4/share/config/kickoffrc under the following
Code: Select all
[KRunner][PlasmaRunnerManager]
pluginWhiteList=places,shell,services,bookmarks,recentdocuments,locations
removing the entries bookmarks, recentdocuments, and relogin. But nothing changes; KDE just refreshes the whitelist again.

I had to resort to renaming this file
Code: Select all
/usr/share/kde4/services/plasma-runner-bookmarks.desktop
so that it doesn't get a chance to be loaded. It should work until the next time I update my KDE4 package, upon which I will have to rename it again.
wolfi323
Registered Member
Posts
1108
Karma
11
OS
syockit wrote:I tried editing the whitelist in ~/.kde4/share/config/kickoffrc under the following
Code: Select all
[KRunner][PlasmaRunnerManager]
pluginWhiteList=places,shell,services,bookmarks,recentdocuments,locations
removing the entries bookmarks, recentdocuments, and relogin. But nothing changes; KDE just refreshes the whitelist again.

Well, kickoff doesn't even read this setting.

I had to resort to renaming this file
Code: Select all
/usr/share/kde4/services/plasma-runner-bookmarks.desktop
so that it doesn't get a chance to be loaded. It should work until the next time I update my KDE4 package, upon which I will have to rename it again.

Try this:
- copy the file /usr/share/kde4/services/plasma-runner-bookmarks.desktop to ~/.kde4/share/kde4/services/ (or ~/.kde/share/kde4/services/ depending on your distro)
- then search for the line "X-KDE-PluginInfo-EnabledByDefault=true" and change this in
Code: Select all
X-KDE-PluginInfo-EnabledByDefault=false

- call "kbuildsycoca4 --noincremental" (I'm not sure if this is needed, but it can't harm...)

After a logout/login (or reboot) the bookmark searching should be disabled in Kickoff.
And this will even survive system upgrades... ;)
User avatar BlaXpirit
Registered Member
Posts
6
Karma
0
OS
For KDE 5:

Copy /usr/share/kservices5/plasma-runner-bookmarks.desktop
~/.local/share/kservices5/plasma-runner-bookmarks.desktop

Replace a line
Code: Select all
X-KDE-PluginInfo-EnabledByDefault=false
Relogin.


Image
bcroq
Registered Member
Posts
3
Karma
0
BlaXpirit wrote:For KDE 5:

Copy /usr/share/kservices5/plasma-runner-bookmarks.desktop
~/.local/share/kservices5/plasma-runner-bookmarks.desktop

Replace a line
Code: Select all
X-KDE-PluginInfo-EnabledByDefault=false
Relogin.


This worked for me. Thanks.

 
Reply to topic

Bookmarks



Who is online

Registered users: adamsmark, Baidu [Spider], Bing [Bot], Exabot [Bot], flherne, geoffreywheeler, Google [Bot], KDENVIDIA, louis94, raddison, razvanr, scummos, Sogou [Bot], Yahoo [Bot]