Reply to topic

Mouse cursor theme partially resets after logout

User avatar remus
Registered Member
Posts
26
Karma
0
OS
I changed my cursor theme (Terracota) and it works fine until I relog. Then it only works when cursor is over application windows but if I hover it outside it changes to default white Oxygen cursor. This happens every time. I tried to re-enable and re-install theme but that doesn't help. In kcminputrc it says correctly "cursorTheme=Terracota". Just installed OpenSUSE 12.3 with upgraded KDE 4.11. I used this theme without problems in Mint 13 KDE from version 4.8 to 4.11.
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Over which windows does it not work exactly? Are you referring to the desktop itself, window decorations, or something else?


System Settings and Device Actions KCM maintainer
Image
User avatar remus
Registered Member
Posts
26
Karma
0
OS
It changes to Oxygen theme when hovering over window decorations or outside of them (over wallpaper, plasma panels, plasmoids etc). Exactly same happens when using other mouse themes. I have changed theme of other KDE elements and they work ok.
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
How did you install the Terracotta mouse theme?


System Settings and Device Actions KCM maintainer
Image
User avatar remus
Registered Member
Posts
26
Karma
0
OS
bcooksley wrote:How did you install the Terracotta mouse theme?


From Cursor settings -> "Search for new themes" and applied "Install".
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Can you confirm that a folder, matching the name of your mouse cursor theme, exists in ~/.icons?


System Settings and Device Actions KCM maintainer
Image
User avatar remus
Registered Member
Posts
26
Karma
0
OS
bcooksley wrote:Can you confirm that a folder, matching the name of your mouse cursor theme, exists in ~/.icons?


It doesn't. Only folder for desktop icons I installed. Guess I'll have to try install mouse theme manually.
Edit: Cancel that, I looked from wrong directory. There is a matching directory and files in ~/.icons.
I noticed that when logging in after showing loading icons it changes to correct theme for couple seconds but switches then back to Oxygen. Filed the bug to: https://bugs.kde.org/show_bug.cgi?id=324120
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
If you run the following in Konsole, does Plasma display the correct cursor theme?
Code: Select all
kquitapp plasma-desktop
sleep 10s
plasma-desktop &


System Settings and Device Actions KCM maintainer
Image
User avatar remus
Registered Member
Posts
26
Karma
0
OS
bcooksley wrote:If you run the following in Konsole, does Plasma display the correct cursor theme?
Code: Select all
kquitapp plasma-desktop
sleep 10s
plasma-desktop &


After running that the cursor theme is Oxygen when hovering over window decorations, anywhere else it's the correct one. I got several error messages, here's the output: http://pastebin.com/ZGeeY7g1 . I can't seem to reproduce the bug with other user. Although I choose same themes. Wonder if this has something to do with that I changed my UID/GID right after installation to match the user on my other dual boot distro. Not sharing same ~/.kde4 thought.
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Please verify that all files under ~/.kde4 are owned by the appropriate user. It could indeed be part of the problem here.


System Settings and Device Actions KCM maintainer
Image
User avatar remus
Registered Member
Posts
26
Karma
0
OS
bcooksley wrote:Please verify that all files under ~/.kde4 are owned by the appropriate user. It could indeed be part of the problem here.


Yes they are. I couldn't find source of problem so I tried to solved it by the ugly way - creating new user and restoring files from old user. That did the trick. My cursor theme have stayed same so far. Thanks anyway for trying to help.
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Not a problem.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: AElfwine, anditosan, Baidu [Spider], bcooksley, Bing [Bot], Deevad, Exabot [Bot], fbouchard, Google [Bot], joaob, Jucato, Majestic-12 [Bot], MSNbot Media, pouar, Thaodan, vvakk, Yahoo [Bot], Zafio