Reply to topic

"Windows + S" makes all windows dissapear - how to revert

mtjakobczyk
Registered Member
Posts
2
Karma
0
Hi,
I have openSuSE 12.4 with the following KDE desktop:
Qt: 4.8.4
KDE Development Platform: 4.10.5 "release 1"
KDE Daemon: 4.10.5 "release 1"

At some point of time I accidentally used "Windows + S" shortcut.
All windows as well as their task bar references disappeared.

I was not able to find any definition of this shortcut neither in my KDE configuration nor in the internet.
Could you share with my what actually does this shortcut do and how to reverse it?
Thanks!
Michal
User avatar google01103
Manager
Posts
6668
Karma
25
I'm not sure, I don't have Window key and can't seem to see where window+s is defined on my system, sounds like it could be that you switched to a different desktop, try ctrl+F1 this should take you to desktop 1. The taskbar references would not be shown if the task manager settings enabled "only show task from the current desktop"


OpenSuse Leap 42.1 x64, Plasma 5.x

mtjakobczyk
Registered Member
Posts
2
Karma
0
Hi,
ctrl+F1 does not work.
Actually, next to KDE "Start" button there is a switch between Desktop 1 and Desktop 2.
Switching those does not show missing windows.
Cheers,
Michal
User avatar google01103
Manager
Posts
6668
Karma
25
you don't say if the apps are still running
- do they show when you ctrl+tab
- do they show in ksysguard?
- do they show in taskmanager if you change the task manager settings so all "show only ..." are unchecked?


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar google01103
Manager
Posts
6668
Karma
25
could the meta+s switch to a different activity?
right click desktop -> activities, are multiple running? try switching by clicking if multiple available


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar metzman
Registered Member
Posts
171
Karma
3
OS
meta+s is assigned to Plasma Desktop Shell: Stop Current Activity. (openSUSE 12.3 KDE 4.11.1)

I don't use 'activities' but thought I'd try it (meta+s) and see what happens...

It closed all open applications, and changed the Desktop Settings Layout from my normal 'Default View' to 'Folder View'... :D


Image openSUSE Tumbleweed ~ KDE Plasma 5 --- Regards, Paul ---

If it isn't broken yet, then you've not fixed it enough. ;)
User avatar google01103
Manager
Posts
6668
Karma
25
metzman wrote:meta+s is assigned to Plasma Desktop Shell: Stop Current Activity. (openSUSE 12.3 KDE 4.11.1)

I don't use 'activities' but thought I'd try it (meta+s) and see what happens...

It closed all open applications, and changed the Desktop Settings Layout from my normal 'Default View' to 'Folder View'... :D

strange - it's not set on my system, maybe because it's an old setup file


OpenSuse Leap 42.1 x64, Plasma 5.x

Bevior
Registered Member
Posts
1
Karma
0
I know this is old but I am answering just in case a new user lands on this page. meta + s stops the activity if you select meta + q to bring up your activities you will see little stop squares on all the activities that are running. The activity you stopped will have the triangle "play" button press that and your activity will start. You applications should be right where you left off. There might be some applications that can't restart when you stop them and place them in memory but I haven't run across any yet.
jcisio
Registered Member
Posts
1
Karma
0
Bevior,
I've just created an account to say thank you. Yes Meta+Q fixes it.
vhanzl
Registered Member
Posts
2
Karma
0
With all respect I have to KDE, which I used many years, I think that this Windows+S shortcut is the most unfortunate thing I encountered in Linux from its first days, ever. I installed Debian Jessie with KDE three months ago. From time to time, all my windows closed and when I managed to re-open them, most of them lost useful context - e.g. some 20 xterms lost their working directory. Only today, after three months, I found out this little bomb waiting for the slightest touch to explode and destroy my weeks long working context (my box is running all the time and I have apps on some 18 virtual desktops).

How can something so destructive appear as a new keybord shortcut without any confirmation before the harm is made?? Something so hard to find out, because it only happens because of unintended random keyboard touch?

Please please please, to keep sanity of those who stay with KDE and who happen to use at least one old fashioned app (like xterm) which does not restore the state perfectly, please make this bomb visible or deactivate it by default. Maybe a little dialog - "Hey, you pressed Meta-S, all your applications will stop and some will not restart properly, are you sure?"

Thank you.

Vaclav Hanzl

P.S. Few keywords for those who google for this: Hyper-S is another name for the key. I also googled for screwup, so let's make it easier for others...
vhanzl
Registered Member
Posts
2
Karma
0
It is not easy to find out where to switch off this dangerous keyboard shortcut. Finally I managed, it is here:

System Settings - Shortcuts and Gestures - Global Keyboard Shortcuts - KDE component: Plasma Desktop Shell - Stop Current Activity
prempel
Registered Member
Posts
1
Karma
0
KDE is great, but this is a ridiculously dangerous and frustrating default shortcut. I'm sure I'm not the only person who also uses OSX and has a muscle memory to hit Cmd-S to save. Well, look you tried to save and instead you just lost all your work without even a warning.
airdrik
Registered Member
Posts
1442
Karma
2
OS
My recommendation is to submit a request to [url]bugs.kde.org[/url] to add a confirmation dialog when an activity is stopped using the keyboard shortcut.


airdrik, proud to be a member of KDE forums since 2008-Dec.
kylepeavy
Registered Member
Posts
1
Karma
0
This thread saved me from a nightmare, so I'm adding some keywords that would have helped me find it easier:
"Win+S" "Windows+S" "Meta-S" "Win + S" "Windows + S" "Meta + S"

I'm using KDE inside a VNC session on a Windows machine -- I went to take a screenshot using the "Win + S" hotkey and boom all my work disappeared.

Read the thread above to find out how to get your stuff back, using Win-Q

Then disable this hotkey as mentioned above by going to:
System Settings - Shortcuts and Gestures - Global Keyboard Shortcuts - KDE component: Plasma Desktop Shell - Stop Current Activity

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dbergstein, dngrsone, Exabot [Bot], Google [Bot], kinoe, Majestic-12 [Bot], Sogou [Bot], Yahoo [Bot]