Reply to topic

Dolphin does not show Luks (encrypted) partitions in "Places"

User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
My built in encrypted disk (cryptsetup luksformat) is not listet in "Places"
sure.. i can open and mount it manually in konsole but the thing is...
the very same disk plugged in as external usb device works perfect in dolphin.


Is there a way to make dolphin list internal encryted disks too?? :undecided:


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
*push* is this a bug..
only usb encrypted devices are shown in the location bar in dolphin.. internal encryted devices are ignored..
can anyone confirm this behaviour? if so i'll file a bug report or something..


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
so there seems to be noone out there with luks formatted usb disks.. to bad.. how do you encrypt your internal devices so they show up in dolphin?

Last edited by waldelf on Sat Jan 24, 2009 5:34 pm, edited 1 time in total.


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
This is definitely a bug report, more likely with Solid however for not idenitifying your Luks encrypted disk as a Storage Device.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
ok.. i'll file one tomorrow


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Once the bug report has been filed, could you please post a link back here so future searchers can track the issue? Thanks in advance.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
Exilant
Registered Member
Posts
13
Karma
0
I have the very same problem, and dolphin also fails to mount encrypted external partitions. does that work for you?

i miss kde3's media:/
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
USB devices are recognized... for the internal partitions i did this small script...

Code: Select all
#!/bin/bash

foo()
{
dir1="partition1"
dir2="partition2"

disk1="60909be7-c7da-4af8-85fe-712e2284177e"    #UUID
disk2="3da4ade3-1c60-445a-819c-74e6d2c11b29" 

rootdir="/home/username/"
         echo ""
         echo "..starte $dir1"
         sudo cryptsetup luksOpen /dev/disk/by-uuid/$disk1 $dir1
         echo "..starte $dir2"
         sudo cryptsetup luksOpen /dev/disk/by-uuid/$disk2 $dir2
         echo ""
         echo "...mounting all Cryptdevices!"
         sudo mount /dev/mapper/$dir1 $rootdir$dir1
         sudo mount /dev/mapper/$dir2 $rootdir$dir2
         echo "$rootdir$dir1 ready!"
         echo "$rootdir$dir2 ready!"
         echo ""
         sleep 2
}
export -f foo
exec xterm -e foo


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], gerdeg, Google [Bot], imperatorstorm, Majestic-12 [Bot], Sogou [Bot], tanmayj316