Reply to topic

Problem: Decoration, Controls, Text Blur

minecrawler
Registered Member
Posts
2
Karma
0
OS
Hello everyone,

I hope this is the right place to find a little bit of help...
I have a Gentoo machine with KDE 5 Plasma. It has been running for a few weeks, now, and I did not have problems until I restarted my computer today. Controls started blurring making texts unreadable (see picture: https://i.imgur.com/Lg15o5d.png ).
When hovering with my mouse, the text unblurs for a second, then blurs again (smoothly animated). Also holding a window and moving it around keeps the window and all controls inside unblurred.
This effect only appears when I set the compositor to OpenGL. Changing to XRender is a workaround, but I'd like to fix the OpenGL settings.
How can I fix my KDE installation?

Some version information:
Kernel: 4.3.4-gentoo
Gaphics Card: NVIDIA GTX 970 using nvidia-drivers-358.16-r1
KDE: Plasma 5.5.4
KDE Framework: 5.18.0

If you need more versions, settings, logs or USE flags, please just tell me what you need and I will happily provide it.
User avatar google01103
Manager
Posts
6668
Karma
25
any recent upgrades?

couple things to try
1) test as a new user
2) rename your kwinrc file in ~/.kde[4]/share/config/ and restart kwin
Code: Select all
kwin --replace

3) assuming you compile you own Nvidia drives recompile them

ps - no real idea, these are just something I would try


OpenSuse Leap 42.1 x64, Plasma 5.x

luebking
Karma
0
Run "nvidia-settings" and disable FXAA.

FXAA is a shader based full screen anitaliaser which causes exactly this.
Unfortunately, there's no environment to control this (so we cannot downforce it from kwin) - if you want to use it in some game, rather invoke that as

Code: Select all
nvidia-settings -a FXAA=1
quake
nvidia-settings -a FXAA=0


You may also be able to disable it for kwin_x11 in nvidia-settings with an application profile.
minecrawler
Registered Member
Posts
2
Karma
0
OS
@google01103: Thank you for the ideas. I am a lazy guy, so I just skipped to the most simple solution with the setting....
luebking wrote:Run "nvidia-settings" and disable FXAA.


Simple and effective! Seems like I enabled it at some point and it just took effect after the reboot. Thanks a lot!

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dbarron, Google [Bot], leolist, Majestic-12 [Bot], Sogou [Bot]