Reply to topic

Laptop keyboard it's doesn't recognized

User avatar alexjsk
Registered Member
Hi, I'm using KDE Plasma 5.10.5 with Debian Sid. The keyboard of my laptop doesn't work on KDE Plasma after I have connected a USB keyboard. I pressed Ctrl + Alt + F1 (to open tty1) and the keyboard works perfectly (both), but when I switch to tt7 my system plays sound notification like when a device is disconnected and the laptop keyboard stops working again. I must connect the USB keyboard to log in with SDDM. I searched Google but I did not find any solution. When I wrote
Code: Select all
xinput list
, the output of the console is this:
Code: Select all
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=17   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=19   [slave  pointer  (2)]
⎜   ↳ USB USB Keykoard                          id=9    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ HP Truevision HD                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=14   [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=15   [slave  keyboard (3)]
    ↳ Logitech USB Receiver                     id=18   [slave  keyboard (3)]
    ↳ USB USB Keykoard                          id=10   [slave  keyboard (3)]
    ↳ USB USB Keykoard                          id=16   [slave  keyboard (3)]

And this when I wrote
Code: Select all
xinput --list-props 12
Code: Select all
Device 'AT Translated Set 2 keyboard':
        Device Enabled (139):   1
        Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Send Events Modes Available (259):     1, 0
        libinput Send Events Mode Enabled (260):        0, 0
        libinput Send Events Mode Enabled Default (261):        0, 0
        Device Node (262):      "/dev/input/event0"
        Device Product ID (263):        1, 1

Thanks by any suggestions.

Reply to topic


Who is online

Registered users: Baidu [Spider], Bing [Bot], Clancularius, Exabot [Bot], Google [Bot], jonathanbe, khatami, Majestic-12 [Bot], Massimiliano, mcarpino, nocin, Sogou [Bot], vollreof, whoopsdecade, xerosugar