Reply to topic

fonts in Konqueror look ugly

User avatar atrox
Registered Member
Posts
209
Karma
0
OS

fonts in Konqueror look ugly

Sun Nov 30, 2008 8:45 pm
Hello.

I would really like to use Konqueror as my KDE4 default web browser, but I can't since zooming pages makes fonts look really bad. I have this issue on PC-BSD 7 (FreeBSD 7.0.1-PRE) as well as on OpenSuse 11, both of them have KDE 4.1.3 installed.

One good example:
page without zooming:
Image
page zoomed once:
Image
page zoomed twice:
Image

The ugliness is not the only problem - zooming the site shown above makes the page really slow and hovering text ain't coloring it as it should (it won't get colored, sometimes only parts of it get colored, etc - I can't show this with KSnapshot).

Googling about it turns up suggestions to play with fonts anti-aliasing and hinting style, but I've tried it and it doesn't help.

What should I look into to get it fixed?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

RE: fonts in Konqueror look ugly

Mon Dec 01, 2008 4:00 am
I cannot confirm this under KDE trunk, the website you showed in those screenshots looks fine. What I see at full zoom ( where it should look its worst ) is below:
Image


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar atrox
Registered Member
Posts
209
Karma
0
OS

RE: fonts in Konqueror look ugly

Mon Dec 01, 2008 7:38 am
Full zoom looks actually quite OK on my machine too, but the worst ones are from 2nd to 5th zoom or so..

So in your case the site in Konqueror looks OK and hovering text (especially in news section) is OK and it doesn't get slow?

If everything is fine in your case.. could you say me what are your fonts' settings in KDE?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

RE: fonts in Konqueror look ugly

Tue Dec 02, 2008 10:20 am
You don't happen to be using NVidia ( in particular 180.08 beta ) do you? there is a known font corruption bug with that driver ( more info here )

I definitely get no performance issues, however what do you mean by hovering text? do you mean that effect by where the text goes orange? it flies past my screen scrolling down at a pretty high speed at full and partial zoom.

Font settings, they are the default 4.2 settings, which for me are:
Minimum: 7, Medium: 12.
Standard, Sans Serif, Cursive, Fantasy fonts: Albany AMT.
Fixed font: DejaVu Sans Mono.
Serif Font: Thorndale AMT.
Font size adjustment for encoding: 0
Default encoding: use language.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar atrox
Registered Member
Posts
209
Karma
0
OS

RE: fonts in Konqueror look ugly

Tue Dec 02, 2008 10:38 am
I use NVidia, but not 180.08 (MX 4000 at home and MX 440 at work). I switched to NVidia at work just lately, before that I used some older ATI card.

I now set my general font to Sans Serif 10 (usually I use Bitstream Vera Sans) and now the page zoomed once looks like this (hovering over the text left behind the half-yellow text as can be seen in today's screenshot):

Image

There is smth really wrong with my fonts.. What are your anti-aliasing settings?
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS

RE: fonts in Konqueror look ugly

Tue Dec 02, 2008 10:48 am
This doesn't really seem like a Konq issue, but a driver issue.

This is how it is for me:
Image

Also notice the black gradient is smooth in my case as compared to your gradient in the first image. But well, as I have an intel card, I cant really help with setting up your nVidia

Last edited by sayakb on Tue Dec 02, 2008 10:50 am, edited 1 time in total.


User avatar atrox
Registered Member
Posts
209
Karma
0
OS

RE: fonts in Konqueror look ugly

Tue Dec 02, 2008 10:59 am
But I wonder why is it so only in KDE4 Konquror. If I use KDE3 Konqueror or Opera (linked against QT4), fonts are perfectly fine.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

RE: fonts in Konqueror look ugly

Tue Dec 02, 2008 11:42 am
Which version(s) of Qt are you using? on OpenSuSE make sure you are actually using the latest Qt from the KDE:Qt repository. I believe I have instructions here for that :-)

You could also try testing with a plain xorg driver such as vesa.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar atrox
Registered Member
Posts
209
Karma
0
OS

RE: fonts in Konqueror look ugly

Fri Dec 12, 2008 11:45 am
I do use latest QT.

As a matter of fact, I just installed OpenSuse 11.1 RC on my new PC that has NVidia 7300 video card.

When I had not installed NVidia driver yet (so Xorg was using vesa), I saw the same issue. And after installing proper NVidia driver, nothing has changed. I don't really think it's a matter of hardware, drivers or user settings :'(
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

RE: fonts in Konqueror look ugly

Sat Dec 13, 2008 1:19 am
Does running trunk ( 4.2 beta should suffice ) make any difference? That is what I have been running for some time now, and where that screenshot was taken.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar atrox
Registered Member
Posts
209
Karma
0
OS

RE: fonts in Konqueror look ugly

Sat Dec 13, 2008 9:47 am
Well.. I should get a spare HDD to install and try it on that.. I don't think there's a good way going back after installing KDE 4.2 :)
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS

RE: fonts in Konqueror look ugly

Sat Dec 13, 2008 1:18 pm
Well, there is :)

Comment out or remove the apt line from /etc/apt/sources.list for KDE 4.2 beta.
Now do:

[code]sudo apt-get update && sudo apt-get remove kdelibs5 && sudo apt-get install kubuntu-desktop[/code]

That should get you back from KDE 4.2 to KDE 4.1.x


EDIT: If yours isnt a debian based distro, just remove the kdelibs5 package using your respective package manager.

Last edited by sayakb on Sat Dec 13, 2008 1:21 pm, edited 1 time in total.


User avatar atrox
Registered Member
Posts
209
Karma
0
OS

RE: fonts in Konqueror look ugly

Sat Dec 13, 2008 6:26 pm
Actually I use OpenSuse, not Kubuntu ;)

But I rather meant my settings being "updated" to 4.2 and then they may not be fully backwards compatible with 4.1.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

RE: fonts in Konqueror look ugly

Sat Dec 13, 2008 11:34 pm
I also run OpenSuSE. I just used a seperate user for my trunk usage. I used kdesvn-build to install 4.2 alongside 4.1 ( I compiled this myself )

With regard to settings becoming incompatible, you are probably right. It would probably be best to start 4.2 with a clean slate, so a new user would be best.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS

RE: fonts in Konqueror look ugly

Sun Dec 14, 2008 7:13 am
atrox wrote:Actually I use OpenSuse, not Kubuntu ;)

But I rather meant my settings being "updated" to 4.2 and then they may not be fully backwards compatible with 4.1.


I implemented that on my test machine which had, oh well, Kubuntu :D
They worked out quite well as when configuring (dpkg) after installation, the settings were overwritten.
If there isn't a metapackage for kde (like kubuntu-desktop in kubuntu), try marking the most common apps for installation manually.



 
Reply to topic

Bookmarks



Who is online

Registered users: Awang Ruoto, Baidu [Spider], bassamanator, Bing [Bot], bovender, Google [Bot], grosser, imkdeuser, Majestic-12 [Bot], Merlimau, norobot, pareekyashovardhan, samidon, Sogou [Bot], Yahoo [Bot]