Reply to topic

[SOLVED] KDE4.1 Display Settings not saved in Kubuntu

mertress
Registered Member
Posts
6
Karma
0
OS
bcooksley wrote:At this time, adding xrandr with the manually entered resolution to Xsetup is the only way other than editing xorg.conf to change resolution at the login screen.

Thx a lot
markno
Registered Member
Posts
1
Karma
0
OS
Hi !

I'm using KDE 4.3.1 (6) on openSUSE 11.2 with 2 monitors. With systemsettings I could set up all perfectly but it does not save the settings.

With your help and a little bit testing using "xrandr --verbose" I figured out that I only have to add the following 3 lines to /etc/X11/xdm/Xsetup:
xrandr --output VGA_1 --mode 0x3f
xrandr --output DVI-I_1/digital --mode 0x58
xrandr --output DVI-I_1/digital --right-of VGA_1

A little bit funny: When the system is successfully booted, I can put all the above in one line and it works. Used in Xsetup, it only works like above. Packed into one line it only produces an error in /etc/log/kdm.log and ends up with no display.

Thanks to all for the tips
Martin
futurefreak
Registered Member
Posts
13
Karma
0
OS
Just installed Kubuntu 10.04 on an old system with a Geforce2 MX and have the same problem with the Display Settings not being applied on startup.

Wanted to confirm that the fix still works.


futurefreak, proud to be a member of KDE forums since 2008-Dec.
VolkerBause
Registered Member
Posts
4
Karma
0
OS
I agree with Photon Blizzard. This is not resolved.

While it may be acceptable for some freaks to hack configuration files, general adoption of KDE, Linux or whatever system will only come when the ordinary user which knows virtually nothing about programming can configure the system. Generally the best example is Google's search engine.

While I managed to figure out at least partially how to manually edit xorg.conf files and use xrandr and Xsetup for that matter, these are no solutions. If you don't get this, you don't get the point of KDE.

Editing scripts and configuration files and manipulating terminals are nothing but workarounds and are to say the least intended for system administrators. Surely you don't believe KDE was developed for System Administrators.

Up to OpenSUSE 11.2 I used sax2 to configure my xorg files. In OpenSUSE 11.3 this changed. While I for one may find it interesting to fiddle with configuration files and understanding how they work (i.e. If I can find the time), it p***s me off that developers can expect ordinary users to waste so much time and energy to fix issues in this fassion. In this respect, I have to still take my hat of for Microsoft which I love to hate. At least when I set something, it is sort of permanent. Don't get me wrong. What I dislike about Microsoft is how they force you to do things in a certain way and if you don't like it, you have to either hack your way around them or find some 3rd party software that has already achieved what you are trying to do.

I don't know who programmed the Display and Monitor settings in KDE, but in my opinion the job is only half done. If I select a display setting and it works and I press Apply, I expect these settings to be permanent. I haven't seen the "Apply until Next Time" button yet?

I appreciate somebody bringing this matter to the attention of the developers while also providing workarounds but as mentioned already, the job is only half done. I can fully understand that Open Source Linux releases like OpenSUSE, Fedora and Kubuntu etc. are not intended for the end user but seriously, KDE 4.0 was hopeless and KDE 3 is an era gone by. If you genuinely want to impress people, this type of problem should not even exist. Pointing fingers does also not solve any problems as ultimately end users don't care other than that things work for them and that they can use the system to get work done instead of adding to their workload. It is this type of bug or nonsense that makes people think twice about using KDE or Linux for that matter.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
You need to run KRandRTray on startup, which will apply the settings on startup.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar BartOtten
Moderator
Posts
33
Karma
0
OS
bcooksley wrote:You need to run KRandRTray on startup, which will apply the settings on startup.


It doesn't for me (multiple displays, different resolutions) So it's still a dealbreaker
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
If you right click on it's icon are they applied?

I consider the fact that it doesn't apply them on startup ( like the mouse settings are ) to be a bug itself though, and running krandrtray to be a workaround.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
fmjrey
Registered Member
Posts
5
Karma
0
OS
Actually the next release of kdebase-workspace (4.5.2 I suppose) should contain a fix that will probably resolve our problem:
http://bugs.kde.org/show_bug.cgi?id=163707
Juwanis_Bas
Registered Member
Posts
1
Karma
0
OS
khamil8686 wrote:I had this problem and was googling for a solution and came across this thread. I hope to help out other googlers who come across this page, including the threads creators if they still need the help. I found that adding this line
xrandr --output DVI-0 --mode 1440x900
hope this helps :) this setting persists through reboots:-)

I have entered all 4 modes(VGA-O , 1 DVI -1) all i get is this
Code: Select all
warning: output DVI-0 not found; ignoring


where DVI-0 is the name of your monitor output (VGA-0, VGA-1, DVI-1) and 1440x900 is the resolution you would like to start up your computer with, to the file /etc/kde4/kdm/Xsetup

How can I Do this ? o)
& FYI I'm a newbie to KDE and other than this i find Kubuntu very impressive than previous versions. But I find this very frustrating to change the SR In each time when i Reboot.Thanks in advance
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
The parameter supplied to --output will vary from system to system. Please pastebin the output of "xrandr" so that the correct one can be selected for you.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
meow9th
Registered Member
Posts
1
Karma
0
OS
bcooksley wrote:If you right click on it's icon are they applied?

I consider the fact that it doesn't apply them on startup ( like the mouse settings are ) to be a bug itself though, and running krandrtray to be a workaround.


Yes, right-clicking on the krandrtray icon in systray shows the customized settings are indeed applied. However, after I restart, even though krandrtray runs on startup it doesn't apply the customized settings from last session.

fmjrey wrote:Actually the next release of kdebase-workspace (4.5.2 I suppose) should contain a fix that will probably resolve our problem:
http://bugs.kde.org/show_bug.cgi?id=163707


I'm glad somebody wrote a fix. I ended up reverse-engineering xrandr commands from the xrandr output after customizing settings in krandrtray. Then I added those xrandr commands to /etc/kde4/kdm/Xsetup to make them persistent. It wasn't so bad, even for a newbie, but the requisite Googling to figure out every single step was pretty painful (ie, should I be working on xorg.conf or xrandr commands?). There are other things I'd rather spend my time on, but that's the price of Linux. Still, I wouldn't've minded so much if the behaviour of display settings not persisting isn't so awfully counterintuitive.
beeb
Registered Member
Posts
1
Karma
0
OS
Hi there.

New to this place so hi everyone

The problem I had initially which led me to this thread is now solved.

However I found a solution when you got the following configuration:

A Laptop (Dell Studio 15 for this solution)
A VGA (1280x1024) display connected to it.
The laptop rarely leaves my desk as I use it as a desktop computer, however if I want to put my feet up I need to quickly change the display back to "LCD" whenever I need.

In order to switch quickly you need a button on the Desktop to press and reset the display back and forth. The solution requires 2 bash scripts called via a Quicklaunch Widget.

So first create a file, I personally use vi or kate but any editor will do:

Let's call it switch_to_lcd_display.sh and insert the following two lines:

Code: Select all
#!/bin/bash
xrandr --output VGA-0 --off


Second, create another file, let call it switch_to_vga_display.sh and insert this:

Code: Select all
#!/bin/bash
xrandr --output VGA-0 --mode 1280x1024


Note that the resolution could be any compatible to your own config.

Remember to chmod thse two files to 755:

Code: Select all
chmod 755 switch_to_vga_display.sh
chmod 755 switch_to_lcd_display.sh


On the upper left hand side of your desktop, add a Quicklaunch widget.
Right mouse over the icons, then select "Add Launcher", as the file is a script, use the "Browse" button and select one of the two script above. Do the same for the second script.
Select a different icon (click on the current Icon) to help you remember what button does what).

Once you got those two launchers ready, do some tests. Hey presto, quick switch!

Hope you'll find this useful
futurefreak
Registered Member
Posts
13
Karma
0
OS
Confirmed to still be present in Kubuntu 10.10.
Might be Kubuntu specific as I remember trying a KDE4.x version of Suse and it worked fine with GMA3100 gfx.

Fix still works thankfully.


futurefreak, proud to be a member of KDE forums since 2008-Dec.
nahas7211
Registered Member
Posts
1
Karma
0
OS
Hi,

I was having the same problem as mentioned by everyone,its really annoying to see the monitor going back to 1024x768 each time i login.The display setting was not being saved by xrand.But the fix is very easy...you just have to edit 2 files in xorg.conf.d.The files are "device" and "monitor".You have to add the device in the device file and the preferred resolution for each device in the monitor file.Good examples are given on Gentoo documentation in configuring X.It high time that these types of bugs are addressed so that average users are able to use Linux with less pain.

 
Reply to topic

Bookmarks



Who is online

Registered users: aperali, Baidu [Spider], Bing [Bot], claydoh, Exabot [Bot], Felix Ernst, ghevan, Google [Bot], lemjo, ramskulls, stanleyf, TheBeheader, YaCy [Bot]