Reply to topic

[SOLVED] Application switcher behavior issue

feffer
Registered Member
Posts
13
Karma
0
I'm using Kubuntu Intrepid with kde4 and trying to get used to a few features. One problem is with the app-switcher (Alt+Tab). I have a mixed network with WinXP, MacOSX, and a couple of Linux machines. Prior to kde4, Alt-Tab worked very similarly on all of them. While kde4 is pretty, the app list is covered by the focus app. I often work with a lot of apps open and want to be able to go forward, backward or mouse clip to a particular app. On my other machines, I shortcut backward movement with Alt+` but kde4 won't reverse properly unless I use the default, Alt-Shift+Tab. So is there a way to get the more traditional app-switcher behavior back? Or at least not have the focus app cover the others? Also, why won't Alt+` work for me?

I realize a lot of work has gone into kde4 and I appreciate it. Thanks.

Last edited by feffer on Tue Dec 30, 2008 9:24 pm, edited 1 time in total.


feffer, proud to be a member of KDE forums since 2008-Dec.
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS
This looks like a bug. I can reproduce this on my box here.
Please file a bug report at http://bugs.kde.org
Don't forget to post a link to the bug report here. Thanks.


feffer
Registered Member
Posts
13
Karma
0
LinuxIsInnovation wrote:This looks like a bug. I can reproduce this on my box here.
Please file a bug report at http://bugs.kde.org
Don't forget to post a link to the bug report here. Thanks.


OK, I assume you mean the Alt+` shortcut not working; I'll report it. How about the other issue -- reverting to the previous (traditional) app-switcher appearance/behavior? I would be OK with the kde4 switcher, if the horizontal app-list were higher, the focus app was smaller, or some other way that the horizontal list was not covered. Maybe, my only recourse here is to add this to the kde4 wish-list? Thank you.


feffer, proud to be a member of KDE forums since 2008-Dec.
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS
Yes, Alt+` bug. This applies to Cover switcher, flip switcher and box switcher.


feffer
Registered Member
Posts
13
Karma
0
LinuxIsInnovation wrote:Yes, Alt+` bug. This applies to Cover switcher, flip switcher and box switcher.

Reported as Bug 178930: https://bugs.kde.org/show_bug.cgi?id=178930

Last edited by sayakb on Sun Dec 28, 2008 7:13 am, edited 1 time in total.


feffer, proud to be a member of KDE forums since 2008-Dec.
feffer
Registered Member
Posts
13
Karma
0
[/quote]
Reported as Bug 178930: https://bugs.kde.org/show_bug.cgi?id=178930
[/quote]

Darío Andrés replied to my bug report and found that restarting Kwin, or logging out and back in again made my shortcut, Alt+` (key above the Tab key) work. So this is a good work-around for those who might be having shortcut issues like this. I left it as an unresolved bug, though, because normal shortcut changes are immediate and don't require restarting the app, or logging out and in.

My other issue, that the switcher covered the app list was the result of having two effects enabled and interfering with each other: BoxSwitcher, and CoverSwitch. The BoxSwitcher was in the background and obscured by the CoverSwitch. I probably inadvertently started them both. In any case, that isn't a bug. I'm now using BoxSwitcher alone and get the behavior I want. ;-)


feffer, proud to be a member of KDE forums since 2008-Dec.
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS
Please add a [SOLVED] to the title of the thread. Thanks in advance.



 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], bovender, Google [Bot], jmacleod, lucianosalomoni, Majestic-12 [Bot], p2ranger, raphaelra, Sentinel, TheBeheader, thunder422