Reply to topic

kdebindings make error

nebloof
Registered Member
Posts
6
Karma
0

kdebindings make error

Thu Jan 01, 2009 6:33 pm
Ok, previously I was having problems with kdepimlibs make errors. The only other one that I'm having a problem with is kdebindings (4.1.85). Everything else is installed.

I'm getting this:
Found 'qtdefines'. Reading preprocessor symbols from there...
Can't open perl script "4.2/kdebindings/kdebindings-4.1.85/kalyptus": No such file or directory
make[2]: *** [smoke/qt/smokedata.cpp] Error 2
make[1]: *** [smoke/qt/CMakeFiles/smokeqt.dir/all] Error 2
make: *** [all] Error 2

I think I found that kalyptus is also part of kdelibs? What do I need to do to get it made?

Last edited by nebloof on Fri Jan 02, 2009 12:55 am, edited 1 time in total.


nebloof, proud to be a member of KDE forums since 2008-Dec.
nebloof
Registered Member
Posts
6
Karma
0

RE: [SOLVED] kdebindings make error

Fri Jan 02, 2009 12:27 am
ok, I finally noticed what the error was:
Can't open perl script "4.2/kdebindings/kdebindings-4.1.85/kalyptus": No such file or directory

For whatever reason, it doesn't like "KDE 4.2" and was only looking at the "4.2"
So I just renamed the folder from "KDE 4.2" to "KDE4.2"
------------------------------------------------------------------------

Ok, I spoke too soon. That fixed the problem with kalyptus.

kdebindings will go to 74% and I get this error:
[ 74%] Building CXX object smoke/akonadi/CMakeFiles/smokeakonadi.dir/smokedata.o
/root/KDE4.2/kdebindings/kdebindings-4.1.85/smoke/akonadi/smokedata.cpp:103:31: error: kabc/contactparts.h: No such file or directory
make[2]: *** [smoke/akonadi/CMakeFiles/smokeakonadi.dir/smokedata.o] Error 1
make[1]: *** [smoke/akonadi/CMakeFiles/smokeakonadi.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX shared library ../../../lib/korundum4.so
[ 74%] Built target korundum4
make: *** [all] Error 2

Last edited by nebloof on Fri Jan 02, 2009 12:57 am, edited 1 time in total.


nebloof, proud to be a member of KDE forums since 2008-Dec.
User avatar YeahReally
Registered Member
Posts
71
Karma
1
OS

RE: kdebindings make error

Fri Jan 02, 2009 1:03 pm
You need the kdepimlibs includes


Debian GNU/Linux Lenny
KDE 4.1.96

How many bugs have you triaged today?

 
Reply to topic

Bookmarks



Who is online

Registered users: atopp, Baidu [Spider], Bing [Bot], dbarron, Exabot [Bot], farid, gfielding, Google [Bot], pasis, rafamar, Rytelier, Yahoo [Bot]