Reply to topic

Multimedia keys stoped responding kde 4.2RC

NIVOSH
Registered Member
Posts
20
Karma
0
Hello.
i Enjoy kde 4.2RC very much!!!

but... my keyboard multimedia keys on my Logitec Internet 350 stopped responding.
The keyboard is recognized in sex2.

tried to select them in the keyboard shortcuts but they don't even respond.

When i was using kde 4.2 beta there was no problem...
User avatar sayakb
Administrator
Posts
1973
Karma
12
OS
Try changing the shortcuts from KMix instead. Click on the systray volume control icon, click Mixer. Goto Settings -> Configure Shortcuts. Under the "Global" column, expand those entries that have arrows and set the combination next to "Custom"


NIVOSH
Registered Member
Posts
20
Karma
0
LinuxIsInnovation wrote:Try changing the shortcuts from KMix instead. Click on the systray volume control icon, click Mixer. Goto Settings -> Configure Shortcuts. Under the "Global" column, expand those entries that have arrows and set the combination next to "Custom"


The problem is that the keys are not working. there is no signal from any of them...
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
That would mean that your X configuration has been changed or reset. Make sure to update your ~/.Xmodmap.
NIVOSH
Registered Member
Posts
20
Karma
0
Zarin wrote:That would mean that your X configuration has been changed or reset. Make sure to update your ~/.Xmodmap.


please guide me... i dont want to make any damage.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Changing this file will not harm your system in any way, since it only affects key bindings ( you will still be able to use your mouse in a worst case near impossible scenario )

I currently do not have anything in my ~/.Xmodmap

Could you try running the application "xev" in a terminal and see if any "KeyPress event" lines come scrolling past when you press any of your Multimedia keys ( there will be plenty of them, try not to move your mouse )


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
NIVOSH
Registered Member
Posts
20
Karma
0
bcooksley wrote:Changing this file will not harm your system in any way, since it only affects key bindings ( you will still be able to use your mouse in a worst case near impossible scenario )

I currently do not have anything in my ~/.Xmodmap

Could you try running the application "xev" in a terminal and see if any "KeyPress event" lines come scrolling past when you press any of your Multimedia keys ( there will be plenty of them, try not to move your mouse )


Yes the xev command generate key press events for the multimedia keys.
I don't have .xmodmap file in my root folder.

Last edited by NIVOSH on Thu Jan 22, 2009 8:45 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
That means you have struck the same problem another person reported in the "Installation & Configuration" forum here. I provided some information which might resolve the issue.

Last edited by bcooksley on Thu Jan 22, 2009 8:51 am, edited 1 time in total.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
eyewitness
Registered Member
Posts
4
Karma
0
I run into the same problem, that my multimedia keys are not recognized by KMix. This is since i upgraded to the unofficial prerelease of kde 4.2 from debian in an extra repository.
It's possible to assign a different global shortcut to kmix, which is fully working (whatever ui I use - kmix or the system-settings for global shortcuts). But when resetting to the defaults kmix don't notice the default global shortcuts for volume up/down/mute. But there seems no problem regarding the x config, 'cause all setting dialogs und x-keyboard tools showing the multimedia keys working right. Also I've no modmap configured.

things I've already tried:
- deleted the kglobalshortcutsrc
- verified that there is no Xmodmap
- reseted the global keyboard shortcuts under system-settings, like mentioned in changelog of kmix

May be i missed some hint here in the forum?

Thx, eyewitness
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
You might also want to try removing KMix's configuration as well.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
eyewitness
Registered Member
Posts
4
Karma
0
bcooksley wrote:You might also want to try removing KMix's configuration as well.


Hi bcooksley

Thx for your advice, but this seems not to be the final solution. I've shut down the kdm including all the X stuff and loged into a console as normal user:
- deleted the kglobalshortcutsrc
- deleted all the kmix config files
- started kde an logged in

But there was no change in behavior of kmix.
So i straced kmix, and it seems as all global shortcuts, assigned to an multimedia key, are not forwarded to the configured application (whatever application, not only kmix). However, shortcuts not related to these multimedia keys are working well. So it seems as some magical thing must happen to the keystrokes on their way through the message system. Maybe some dbus related issue?

Cheers, eyewitness
Edit: Let me point out, that when I assign the multimedia keys as local shortcut to kmix (overwriting the global defaults) they are working. Of course only when the kmix window gets the focus. ;-)

Last edited by eyewitness on Tue Jan 27, 2009 2:07 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Perhaps your Keyboard layout gives them a different name to what KHotkeys is expecting. If you can find out what it expects ( probably listed in kmix's notifyrc file ) then you check it against what your keyboard generates.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
eyewitness
Registered Member
Posts
4
Karma
0
bcooksley wrote:Perhaps your Keyboard layout gives them a different name to what KHotkeys is expecting. If you can find out what it expects ( probably listed in kmix's notifyrc file ) then you check it against what your keyboard generates.


Hi bcooksley

I didn't get any further. So let me sum up again what I've tried so far:

starting position:

- kde 4.2 from debian experimental branch
- logitech cordless comfort duo keyboard with multimedia keys

problem:
- assigned global shortcuts are not doing there way to the configured application

diagnostic
  • to exclude possible sources of trouble I created a new user with a fresh user profile
  • also I switched the language of this new user to us-en, to exclude translation issues
  • in these fresh profile the multimedia keys are not working
  • so I activated the keyboard layout, an initialized it to "Logitech Cordless Desktop iTouch", which I used hundred times before ("setxkbmap -model logicd_it -layout de -variant nodeadkeys")
  • now the multimedia keys are recognized by kde 4.2, which means, when configuring a new custom shortcut under "global keyboard shortcuts" in "system settings" the multimedia keys can assigned
  • to ensure there is no X problem i run xev, which showed me the normal key names like XF86AudioRaiseVolume, XF86AudioLowerVolume, XF86AudioMute ... and so on
  • under kde these keys seems to get mapped to "Volume Down", "Volume Up", "Volume Mute" .. and so on
  • when assigning these multimedia keys as a local shortcut, all works well - so i think it can't be a problem of keyboard mapping
  • when assigning other global shortcuts (e.g. ctrl+alt+pgup to kmix volume up) - all is fine
  • trying to assign the multimedia keys to other programs then kmix result in the same behavior - the keystroke didn't find the way to the application (straced checked)


That's all i could find out. Actual I've no further ideas what or which config-file to check, may be as a lack of knowledge how keystrokes are finding there way through the kde message system.

Cheery, eyewitness
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
This sounds like a bug in KHotkeys possibly, as it is responsible for Global Shortcuts.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
eyewitness
Registered Member
Posts
4
Karma
0
bcooksley wrote:This sounds like a bug in KHotkeys possibly, as it is responsible for Global Shortcuts.


Seems to be a plausible reason.

Today i tried the tip from ivan, regarding using dbus to force kded to reread the hotkey configuration. But there was no advancement.

I'm still using the "legacy" ;-) amarok 1.4.10 under 4.2. The mysterious thing: I can assign the multimedia keys to amaroks global shortcuts. And it's doing fine. The only difference is, that the shortcut dialog recognizes these keys with their well known X-names like XF86AudioMute and so on. It would be interesting in which config file the mapping between these XF86Audio* keycodes and the new naturally one, like used in kglobalshortcutsrc, takes place.

Cheers, eyewitness

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Clancularius, gammazoid, Google [Bot], Marcus Gama, Sogou [Bot], taha_mcp, Yahoo [Bot]