Reply to topic

Unable to modify font hinting style

rdaysky
Registered Member
Posts
2
Karma
0

Unable to modify font hinting style

Sun Feb 01, 2009 9:54 pm
Greetings,

today’s upgrade of Kubuntu 8.10 to KDE 4.2 went great, but I can’t sort out one thing which is important for me—font hinting. I want slight hinting, but whatever I do I get a stronger level which causes ugly uneven letters.

My .fonts.conf was unchanged by the upgrade, and it does contain the “hintslight” entry, as well as subpixel aliasing. I ran dpkg-reconfigure fontconfig-config to no avail. The only entries in /etc/fonts/conf.d that look relevant are 10-hinting-slight.conf, 11-lcd-filter-lcddefault.conf, 53-monospace-lcd-filter.conf, but whatever I do with them, KDE (or Qt? or FreeType?) disregards my wishes and displays heavily hinted text. Are there any other files which control font rendering?

What do I do to be sure hinting is set to slight? If I run ftdiff from freetype2-demos and choose what it calls “light auto hinter”, then it displays text perfectly (for me).

--
TIA
Roman.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
System Settings > Appearence > Fonts. Enable Anti-Aliasing, the Configure it with the Sub-pixel rendering and Hinting style desired.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
rdaysky
Registered Member
Posts
2
Karma
0
Thanks, of course that was the first thing I tried. Somehow it fails to work.

I tried creating a user with empty home (and no .kde), even in such a clean setup I can’t affect font rendering in any way. What might be the cause?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Do the other forms of Font Hinting available work?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
XiniX
Registered Member
Posts
217
Karma
1
OS
Maybe this is an inheritance from Debian. It has irked me no end that Debian always seem to disable the hinting style in KDE.

You can fix it by running (IIRC, since I am on Arch now), 'dpkg-reconfigure fontconfig-config'. Check out the exact package name.


XiniX, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Bryan ??, Google [Bot], grahm, keithw, Lupccs, Mace68, Raxker, Yahoo [Bot]