Reply to topic

Desktop cube effects etc..

Registered Member

Desktop cube effects etc..

Mon Feb 02, 2009 1:50 pm
I am a relative newbie to linux desktop, having used servers for a long time, I decided to give them a go. I started off with gnome based ubuntu and am now trialling kde based open suse 11.1 - with kde upgraded to 4.2.

I have pretty much got everything setup as I want it, but I get really jealous when I see screenshots of those fancy effects (desktop cube for example) that I cannot seem to enable.
I have been into my 'Desktop Effects' setting and have set it to use 'xrender' compositing type because the opengl would not work. It came up with 'failed to activate desktop effects'. If i disabled the functionality checks, opengl had a go at working, but all I saw was an outline of all of my windows - I let it time out and it reverted back.

My machine is a decent spec - 64 bit quad core processor and a 9500GT graphics card.
I have not dabbled with anything like drivers etc.. I come from a MAC background so not used to having to do that - couldnt find any suggestion that I needed to though ?

I don't even know if I am testing this correctly. I try to switch desktops using the desktop switcher - no sign of cube - I try 'ctrl+f11' which I discovered somewhere - that does nothing.
When I try simpler effects from the options such as the 'Invert' option from the accessibility section - and that did nothing ?

Can anyone point me in the right direction please ? I don't know if I should even be using 'compiz' or not - which I did for ubuntu, but I have heard that KDE have developed their own.

Many Thanks

User avatar bcooksley

RE: Desktop cube effects etc..

Tue Feb 03, 2009 9:01 am
Please ensure that you are using the latest version of the NVidia driver for your graphics card. You may alos want to ensure that you have 3D acceleration ( glxinfo | grep -i direct should return "direct rendering: Yes" )

KDE Sysadmin
User avatar ivan
KDE Developer

RE: Desktop cube effects etc..

Tue Feb 03, 2009 11:27 am
And that you're using the proprietary aka binary nvidia driver and not nv or vesa. Do:
grep Driver /etc/X11/xorg.conf
and check whether it contains this line:
Driver "nvidia"


Reply to topic


Who is online

Registered users: Baidu [Spider], Bing [Bot], Garthhh, Google [Bot], kde-jmadero, Sogou [Bot], Yahoo [Bot]