Reply to topic

[SOLVED] How to set up dual monitors with Intel graphics?

User avatar StanleyK
Registered Member
Posts
6
Karma
0
OS
Hello everyone.

When I tried the KDE 4 for the first time coming with the new Intrepid Ibex Kubuntu in October, I was really disappointed about the performance of dual monitor settings, as I also described in comments here and I had to downgrade to the KDE 3.
Last days I've read about KDE 4.2 with remarkable better multiple monitor handling and I decided to give it a second chance. Anyway, it still doesn't work! :[email protected]
What am I doing wrong? In display settings, when I click the "Identify Outputs", both monitors identify with both labels (I can see the "VGA" and "LVDS" monitors in the display manager, and a square containing "VGA" and "LVDS" labels on each monitor"). As expected, both monitors have the same output, whereas the resolution is set according to the primary monitor (the laptop's) to 1024x768. though the external monitor should be 1280x1024. It seems to me that it cannot distinguish the monitors in some way...

I have been using the dual desktop with KDE 3.x with no problems, so what's going on? I have done some experiments with xorg.conf settings, with no result, the version I used in KDE 3.x is useless. I only get the "Low graphics mode" dialogue with "(EE) No devices detected", or some DRI error I don't remember exactly.
I am using ASUS laptop with Intel 915GM graphics and external monitor together.
Does anyone know the solution?

Thanks a lot for understanding and for the replies. :-)

The xorg.conf configuration I used in KDE 3 is here:
Code: Select all
Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "cz(qwerty),us"
        Option          "XkbOptions"    "grp:switch,grp:shifts_toggle"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "HorizScrollDelta"      "0"
EndSection

Section "Device"
       Identifier       "Device Interni"
       Driver           "i810"
       BusID            "PCI:0:2:0"
       Option           "MonitorLayout" "NONE,LFP"
       VideoRam 65536
EndSection

Section "Device"
       Identifier       "Device Externi"
       Driver           "i810"
       BusID            "PCI:0:2:0"
       Option           "MonitorLayout" "NONE,CRT"
       VideoRam 65536
EndSection

Section "Device"
       Identifier       "Device Interni Dual"
       Driver           "i810"
       BusID            "PCI:0:2:0"
       Option           "MonitorLayout" "CRT,LFP"
       Screen           0
EndSection

Section "Device"
       Identifier       "Device Externi Dual"
       Driver           "i810"
       BusID            "PCI:0:2:0"
       Screen           1
EndSection

Section "Monitor"
        Identifier      "Interni Monitor"
        Option          "DPMS"
EndSection

Section "Monitor"
        Identifier      "Externi Monitor"
        Option          "DPMS"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
EndSection

Section "Screen"
       Identifier      "Screen Externi"
       Device          "Device Externi"
       Monitor         "Externi Monitor"
       DefaultDepth    24
       SubSection "Display"
               Depth   16
               Modes   "1280x1024" "1024x768"
       EndSubSection
       SubSection "Display"
               Depth   24
               Modes   "1280x1024" "1024x768"
       EndSubSection
EndSection

Section "Screen"
       Identifier      "Screen Interni"
       Device          "Device Interni"
       Monitor         "Interni Monitor"
       DefaultDepth    24
       SubSection "Display"
               Depth   16
               Modes   "1024x768"
       EndSubSection
       SubSection "Display"
               Depth   24
               Modes   "1024x768"
       EndSubSection
EndSection

Section "Screen"
       Identifier      "Screen Externi Dual"
       Device          "Device Externi Dual"
       Monitor         "Externi Monitor"
       DefaultDepth    24
       SubSection "Display"
               Depth   16
               Modes   "1280x1024" "1024x768"
       EndSubSection
       SubSection "Display"
               Depth   24
               Modes   "1280x1024" "1024x768"
       EndSubSection
EndSection

Section "Screen"
       Identifier      "Screen Interni Dual"
       Device          "Device Interni Dual"
       Monitor         "Interni Monitor"
       DefaultDepth    24
       SubSection "Display"
               Depth   16
               Modes   "1024x768"
       EndSubSection
       SubSection "Display"
               Depth   24
               Modes   "1024x768"
       EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Dual"
        Screen          0 "Screen Interni Dual"
   Screen          1 "Screen Externi Dual" RightOf "Screen Interni Dual"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "Synaptics Touchpad"
        Option          "Xinerama" "true"
EndSection

Section "ServerLayout"
        Identifier      "Externi"
        Screen          "Screen Externi"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "Synaptics Touchpad"
EndSection

Section "ServerLayout"
        Identifier      "Interni"
        Screen          "Screen Interni"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "Synaptics Touchpad"
EndSection

Section "DRI"
        Mode    0666
EndSection

Section "ServerFlags"
        #Option         "DefaultServerLayout" "Interni"
        #Option          "DefaultServerLayout" "Externi"
        Option         "DefaultServerLayout" "Dual"
EndSection
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
In the same place you find "Multiple Monitors" there should be another Control Module, "Size & Orientation" which offers resolution, refresh rate, orientation, and postition settings per output. ( LVDS, VGA, etc. )


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar StanleyK
Registered Member
Posts
6
Karma
0
OS
Very well! :shade:

I figured it out! The "Display" module in "System settings" (I've got a translated system, so maybe the original names are different...) was pretty the same as the KRandRTray utility and didn't work. So I did some googling once more and found this. I altered the xorg.conf according to the instructions and followed the instructions for xrandr usage. First time it didn't work, but the reason was a too high refresh rate of external monitor set up with --auto mode (I just wonder, why...). I added the --rate option and everything works now well, including the startup script.

Thanks for your attention, have a nice day! :)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bassamanator, Bing [Bot], Google [Bot], grosser, Majestic-12 [Bot], Merlimau, norobot, pareekyashovardhan, samidon, Sogou [Bot], Yahoo [Bot], zachalexy