Reply to topic

intel graphics vs google earth vs kde4

User avatar Riinse
Registered Member
Posts
167
Karma
2
OS
Hi,

I have a laptop with an intel mobile gm 45 express graphics chipset, with opensuse11.1 and kde 4.2 installed.

I want to use google earth, but due to a bug in the driver, the X-server gets hard locked as soon as i start using it.
This can be solved by appending these lines to the devices section of xorg.conf:
Code: Select all
Option "AccelMethod" "exa"
  Option "MigrationHeuristic" "greedy"
  Option "ExaNoComposite" "false


After that google earth runs fine, but kde4.2 fails to render the icons of knetworkmanager, opensuse updater, klipper and kmix in the systray, it shows blank spaces or black squares in stead. Is there a way to make plasma show these icons again?

Another issue with google earth, intel and kde 4.2:
When i activate the desktop effects, google earth fails to render the images on the map. This can be solved by changing the render mode of the desktop effects from 'opengl' to 'xrender' After that google earth is rendering the maps better (although its interface still tends to flicker when changing windows etc..), but this makes the desktop effects of kde 4.2 slower and behaving unexpectidly (e.g wobly windows makes the windows unmovable)
Does anyone know an option that ensures that google earth can still render correctly with opengl activated in kde's desktop effects?


Riinse, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
I was also affected by the OpenGL hardlock issue, until I reported the bug, and it was resolved. The fix is ( due to stupid SUSE policies on updates ) only available in Factory or Xorg build service repository.

Remove those lines from xorg.conf, Then install the following packages from the repository and restart
Code: Select all
Mesa
libdrm
xorg-x11-driver-video


Repository: http://download.opensuse.org/repositori ... SUSE_11.1/


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Riinse
Registered Member
Posts
167
Karma
2
OS
Thanks for the quick reply.
That indeed solves the lock issue with google and the intel graphics.
I noticed some threads about this on forum.opensuse.org as well (that is where i got my previous fix from), but they didn't provide your solution. So i posted to those threads as wel ;)

The opengl issue with google vs kde4.2 desktop effects still stands: if i use opengl as desktop rendering, google fails to display its maps correctly. I tried to change the various options in systemsettings, but none take away this issue.
Does anyone know a way to use google earth with kde 4.2 opengl desktop effects enabled?

Regards, Rinse


Riinse, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
I do not think it is currently possible, because they do not know about each other trying to use OpenGL, and sharing isn't obviously working too well currently.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: acrux, Baidu [Spider], Bing [Bot], dimzev, Google [Bot], hiteshshah, kailassingh, lesturner, Majestic-12 [Bot], rblackwell, sadi, YaCy [Bot]