Reply to topic

[SOLVED] KDE 4.2 Power Management: Missing Shutdown, CPU freq, Unable to Suspend

leahcim
Registered Member
Posts
4
Karma
0
Hey all,

Computer: Asus G50V: Nvidia 9700: Intel Core 2 Duo 2.53Ghz
Distro: Arch Linux 32bit -- completely up to date -- 2.6.28
DE: Vanilla KDE 4.2

Shutdown and Restart:

I'm a new user to KDE and I am having some trouble with almost all power-related functionality in KDE 4.2. First off, I do not see shutdown or restart options in the KDE menu. If I click on the menu and then "leave" all I see is "logout", "Lock", "Switch User", "Suspend to Ram", and "Suspend to Disk". Also, if I add the "Lock/Logout" widget to the panel, all I see is "logout".

However, I have used Arch for several months now and all of the methods I usually use to shutdown and restart work fine. For instance, entering "sudo shutdown -h now" in a terminal works fine, I just can't access shutdown from any of the menus or utilities in KDE.

Suspend and Power Management:


Similar to the problem above (and probably related) I'm unable to suspend to RAM using any of the KDE menus or utilities. I see an entry for "Suspend to RAM" in the KDE menu, but when I click on it nothing happens at all and I see no dmesg errors. Also, if I click on the Power Management widget, I see an option for "Sleep", but when I click on it, nothing happens.

However, I am able to suspend fine by entering the "pm-suspend" command in a terminal

Power Management also seems to not be working. I can adjust the brightness using the FN keys and xbacklight, but the Power Management widget slider has no effect and neither does setting the brightness through "solid-powermanagement". Switching the Power Profile in the Power Management widget also seems to have no effect either on screen brightness, CPU frequency, or power consumption.

I have "cpufrequtils" installed and can set the governor using "cpufreq-set -g ondemand", but when switched using "solid-powermanagement" or the Power Management widget, "cpufreq-info" says the frequency has not been changed.


In short, I know shutdown, restart, suspend, and cpufrequency work (both from other DEs and from the terminal in KDE), but for some reason it seems completely disconnected from the KDE power management utilities. Not really sure how to trouble shoot the problem given my unfamiliarity with KDE and any advice would be greatly appreciated. I've searched through the Arch Linux forums and this forum as best I could and haven't found any resolved threads with this issue.

I also tried a completely fresh install of Arch without installing cpufrequtils or pm-utils (although they are included in the kernel) to try and see if it was a conflict with my existing setup and the way KDE wanted to do things, but all of the problems were still there. I confirmed that the Power Devil service is started and appears to be running and restarted it several times. Hal is installed and working flawlessly in all other respects (as far as I can tell)

Here's the output from some commands I've seen people ask for on the forums:

Code: Select all
$ lshal | grep suspend
  org.freedesktop.Hal.Device.SystemPowerManagement.method_execpaths = {'hal-system-power-suspend', 'hal-system-power-suspend-hybrid', 'hal-system-power-hibernate', 'hal-system-power-shutdown', 'hal-system-power-reboot', 'hal-system-power-set-power-save'} (string list)
  power_management.can_suspend = true  (bool)
  power_management.can_suspend_hybrid = false  (bool)
  power_management.quirk.dpms_suspend = true  (bool)


Code: Select all
$  solid-powermanagement query suspend
to_disk
to_ram


The "capabilities" tab of the Power Management KDE Control Module:
Code: Select all
System Capabilities:
Number of CPU: 2
CPU can be turned Off: No
Scheme Support: yes
Scaling capability: No
Supported CPU policies: No methods found
Suported Suspend methods: Suspend to Disk, Suspend to Ram
Supported schemes: performance, powersaving


Sorry for the long post!
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Sounds like your Solid Hardware backend is broken. This interacts between KDE and your System ( HAL in this case ). Please ensure that you have valid backends selected under System Settings > Advanced > Hardware. ( HAL in particular )


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
leahcim
Registered Member
Posts
4
Karma
0
Thank you for your reply!

I checked System Settings => Advanced => Hardware and under the Power Management Backend section I see one entry that says "HAL-Power" and the description reads "Hardware power management using freedesktop.org HAL daemon". The other backends selected are NetworkManager0.7 and BlueZ. I don't see any other options or information.

Is there some way I can reinstall solid-powermanagement or further trouble-shoot?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Are any Solid errors mentioned in ~/.xsession-errors?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
leahcim
Registered Member
Posts
4
Karma
0
Thanks for the reply again, sorry for all the trouble!

I don't have a .xsession-errors file in my home directory and can't seem to find it anywhere else. I printed out everything in logs directory (/var/log/) and searched for solid or powermanagement and didn't find any errors. I did see some acpi related errors, but they appear to be in regards to the Nvidia drivers being unable to connect to the acpi daemon.

/var/log/Xorg.0.log
Code: Select all
(II) NVIDIA(0): ACPI display change hotkey events enabled: the X server is new
(II) NVIDIA(0):     enough to receive ACPI display change hotkey events.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) NVIDIA(0):     configuration option may not be set correctly.  When the
(II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0):     Config Options in the README.

Last edited by leahcim on Wed Feb 11, 2009 6:27 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Are you using KDM as your Desktop Manager? ( Login screen ) It would be required to initiate suspend ( which usually requires root powers ) along with shutdown ( also root required ) and probably CPU frequency as well ( also probably needs root )


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
leahcim
Registered Member
Posts
4
Karma
0
Alrighty, that appears to have done it. I wasn't using KDM before as I'm in the habit of just running startx from a consol and specifying my DE in .xinitrc. I setup my system to boot into runlevel 5 by default (using the inittab method) and set KDM as the default login manager and the power management options are back!

Still can't use the screen brightness slider on the Power Management applet, but I suspect that is a driver/hardware problem and not related to KDE. However, suspend, resume, shutdown, restart, and frequency scaling are working great.

Thanks for all of the help! Greatly appreciate it and totally enjoying KDE so far!

P.S. Also works perfectly on my new Samsung NC10.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
The screen brightness problem might be relating to not running the ACPI daemon.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
poushma
Registered Member
Posts
1
Karma
0
How do you make your computer processor work faster? My computer is reeeeallly slow at the moment and I think its my processor that is the problem. How do you get it to work faster?
_________________________________
yahoo keyword tool ~ overture ~ traffic estimator ~ adwords traffic estimator

 
Reply to topic

Bookmarks



Who is online

Registered users: abrahamoli, Baidu [Spider], bartoloni, bednarsky, Bing [Bot], Diver, Google [Bot], Majestic-12 [Bot], Sogou [Bot], YaCy [Bot], Yahoo [Bot]