Reply to topic

[SOLVED] KDE 4.2 and monitor power management problem

User avatar Githzerai
Registered Member
Posts
54
Karma
0
OS
Hi,

This is sort of a strange problem: I just can't make my monitor to automatically go to standby mode, though everything in SystemSetings, monitor power management section, is tuned on.

It's not an xorg problem (or at least I don't think it is), as DPMS is enabled and xset dpms force standby command works.

Also, weird thing, if I leave it at KDM login screen (without logging into KDE session) for a few minutes it will go to standby ?!?!?

Ugly thing if your box works 24/7... :)

Any hint is very much appreciated ...


Stercus accidit
User avatar RGB
Registered Member
Posts
341
Karma
0
OS
I have the same problem in my lap with openSUSE 11.1 and kde 4.1.3: the back-light is always on, no matter the system is instructed to turn it off after 4 minutes.


RGB, proud to be a member of KDE forums since 2008-Nov.
And proud to be a kde user since 1.1.2
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Currently, running KDE 4.3 trunk my system turns the backlight off properly according to the time I specify in Powerdevil. This might have happened with KDE 4.2, can't remember.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
XiniX
Registered Member
Posts
217
Karma
1
OS
It is a known bug and has been fixed. The fix has been backported to 4.2, but probably your distro will incorporate it once the first official hotfix package is released by the KDE team.

Workaround: use powerdown settings in the Display section of the system settings and do not let powerdevil take care of DPMS. Sole disadvantage of that is that you cannot use different settings according to the profile.


XiniX, proud to be a member of KDE forums since 2008-Oct.
User avatar Rettich
Registered Member
Posts
123
Karma
0
OS
The bug is fixed in the KDE Factory packeges of openSuse11.1


Murphy's Law is recursive. Washing your car to make it rain doesn't work.
User avatar Githzerai
Registered Member
Posts
54
Karma
0
OS
Thank's everyone. So it's definitely a bug.... Oh, well, 4.2.1 should be released soon, we'll wait and see.. :)


Stercus accidit
User avatar Githzerai
Registered Member
Posts
54
Karma
0
OS
I'm happy to say that 4.2.1 solved this for me. Works perfect. ;)


Stercus accidit

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Don B. Cilly, Google [Bot], kde-stephen, Majestic-12 [Bot], mossbliss, Sogou [Bot]